Manjaro - Pacman

Hello,

I though that I would install TOR.

Octopi tells me that the tor in the repo is version 0.3.2.10-1

The TOR website gives the latest version as 7.5.3, and now 9,0a5.

I thought I would check using pacman

I typed pacman -s tor. The -s is not recognised.

Can any one comment on the -s, and on the disparity between the tor versions. It is almost as if tor in the repo, is not TOR the privacy programme.

Thanks

Whilst I’m not an Arch aficionado by any means, have you tried the long version of the command

pacman --search tor

I have no idea how version numbers work in the AUR … as the packages are created by Arch users rather than the original developers themselves, maybe versioning is left up to the package creator themselves, so 0.3.2.10-1 in the AUR may contain the latest version of Tor (?)

According to this
https://www.archlinux.org/packages/community/x86_64/tor/

it does look like that package was last updated in March 2018, so I’d assume it’s pretty current.

Thank you for responding.

It looks like you are correcct judging by the tor version.

I tried pacman --search tor. But I still get invalid option --search

tor-browser?

https://aur.archlinux.org/packages/tor-browser

Have you tried the following format for searching pacman repositories:
pacman -Ss