Mark and MP do your best!! lol

guess what mark :stuck_out_tongue: my 256ram on here… when i swap to windows view system info says 512on xp!

linux ram 256
xp 512

… 2x 256 stick

lol :S mark confused me and made me crazy lol the codes i did was awsome lol i loved it,
now i think i need ya to tell me gedit to read more ram or something lol :smiley:

otherthan that pc is Great and games run fine no errors so far, just my ram

thanx so much would be honored for you to help me
(btw not being cockey)

What is the output from:

sudo dmidecode --type 17


cat /proc/meminfo | grep MemTotal



Do you have an “onboard” graphics card (i.e. is it built into your motherboard) ?

If so, can you go into the BIOS and see if you can see how much memory is being reserved for the VGA interface?

Linux will report system memory - memory allocated to VGA … I’m not sure whether Windows will do the same … although there are a number of reasons why Linux will report “more” RAM than Windows, nothing else occurs to me with regards to it reporting less … unless of course you’re reading it wrong … (?)

Yup, I agree… check shared/reserved memory setting in the BIOS… but Windows normally reports memory as ‘installed minus shared’, and I haven’t seen too many older mobo’s that allow 256mb for shared memory, but I could be wrong… It’s been known to happen… erm, occasionally :slight_smile:

Certainly worth a look though, to see how much (if any) is being shared for onboard graphics use.

I’m wondering if memory density (high density module(s) maybe?.. although this wouldn’t really explain Windows seeing it and Linux not) has anything to do with it… would also be nice to know what the BIOS reports as total installed memory, along with how much is reserved as shared graphics memory.

Will your system boot with just 1 memory module installed… try them both, but 1 at a time, and if it boots, see how much memory is reported as installed… classic symptoms of using high density RAM in a motherboard that doesn’t support it, is either the system doesn’t recognize the RAM at all, or it is reported as only half its capacity.

One other thing to try would be if you have any spare memory slots, try moving the memory modules to different slots… some boards can be weird in the way they treat different module configurations in different slots.

Mm, but the point is that Windows is reporting memory that Linux isn’t … which is a bit of a first … changing the hardware shouldn’t make a difference … :o

Yup, I’m a bit baffled by this one. :-\

If I’m understanding this correctly, Windows gets its memory information from the BIOS DMI pool, but Linux kernels/grub probe the memory directly and build their own meme820 (int 15h call) memory map.

So I thought moving the memory might make a difference… just as a “worth a try” kind of thing.

But dmidecode reads info from the DMI pool, so it will be interesting to see if

sudo dmidecode --type 17

sees all the memory, but free doesn’t.

A little light reading, for anyone that’s interested :wink:

It would appear (after reading this link) that MP is correct, the Linux kernel/grub also gets its memory map from a BIOS call so moving the memory is unlikely to make any difference… so I’m baffled again ::slight_smile: … although I suppose there may be a difference between a BIOS call and getting the info stored in the DMI pool, resetting the DMI pool would be more likely to “loose” the memory in Windows too, if it did anything at all.

Which probably brings us back to reserved memory (sorry folks this turned into a “thinking out loud” exercise)

sudo dmesg | grep e820

should give some hex values that we can use to see what the BIOS has mapped as ‘available’ and ‘reserved’ memory.

Question for MP - Do you think acpi=off or acpi=oldboot would help?, as the ACPI also seems to be involved with how memory is reported to the system.


I’m starting to think she may have a point :wink:

sudo dmidecode --type 17

dmidecode 2.9

SMBIOS 2.3 present.

Handle 0x001B, DMI type 17, 27 bytes
Memory Device
Array Handle: 0x001A
Error Information Handle: Not Provided
Total Width: Unknown
Data Width: Unknown
Size: 256 MB
Form Factor: DIMM
Set: None
Locator: A0
Bank Locator: Bank0/1
Type: Unknown
Type Detail: None
Speed: Unknown
Manufacturer: None
Serial Number: None
Asset Tag: None
Part Number: None

Handle 0x001C, DMI type 17, 27 bytes
Memory Device
Array Handle: 0x001A
Error Information Handle: Not Provided
Total Width: Unknown
Data Width: Unknown
Size: 256 MB
Form Factor: DIMM
Set: None
Locator: A1
Bank Locator: Bank2/3
Type: Unknown
Type Detail: None
Speed: Unknown
Manufacturer: None
Serial Number: None
Asset Tag: None
Part Number: None

laurennmarty@laurennmarty-desktop ~ $ cat /proc/meminfo | grep MemTotal
MemTotal: 509332 kB

laurennmarty@laurennmarty-desktop ~ $ free
total used free shared buffers cached
Mem: 509332 495168 14164 0 18224 182028
-/+ buffers/cache: 294916 214416
Swap: 1951856 2428 1949428
laurennmarty@laurennmarty-desktop ~ $ ^C

nah im using 6800 graphics card, linux showing 1/2 ram windows dows btw …mark…win xp will play 4story and WoW (this how the graphics are ok :S so must be the ram in linus slowing me down)

my computer>system infoxp>512of ram
linuxsystem>hardwarestuff>256 :S

basicly want me to take each stick out and try them alone,
wans me just view systeminfo or type the demi things again for ya

NO, free and meminfo are both reporting the correct amount of installed RAM… 512mb (509.332mb, but a small amount is always reserved), and dmidecode is showing both 256mb memory modules… Linux IS seeing/using ALL your memory.

There is nothing wrong with your system.

As I said …

.. unless of course you're reading it wrong .. (?)

lol i was going by what it said lol, but nevermind, so that was reason my pc was slow and wont load games… or so we thort, so :S what will be doign this problem now then?

i cant even play tux racer lol

Run “glxgears” and tell us what your frame rate is …

{ Post was removed for using an unreadable font colour }

On Ubuntu, type “glxgears” on the command line, if it doesn’t run, it’ll tell you what to type to acquire the application.
Failing that, consult your package manager and search for “glxgears” …

laurennmarty@laurennmarty-desktop ~ $ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
9372 frames in 5.0 seconds
8674 frames in 5.0 seconds
10145 frames in 5.0 seconds
10028 frames in 5.0 seconds
10037 frames in 5.0 seconds
10003 frames in 5.0 seconds
10018 frames in 5.0 seconds
10049 frames in 5.0 seconds
10023 frames in 5.0 seconds
10051 frames in 5.0 seconds
9950 frames in 5.0 seconds
10002 frames in 5.0 seconds
9585 frames in 5.0 seconds
9641 frames in 5.0 seconds
8109 frames in 5.0 seconds
9467 frames in 5.0 seconds

And you can’t run Tuxracer ?!

You may not have the fastest graphics in the world, but 2000 fps isn’t too bad.


cat /proc/cpuinfo

And tell me what “bogomip” rating your machine has … and;

lspci | grep VGA

And tell me what sort of graphics card you have.

As MP is alluding to, it’s probably not the graphics card… you are getting twice(ish) the frame rate I’m getting and I have no problem running flash videos at 720p full screen, but that’s on a dual-core CPU with 3gb RAM. (CPU usage is about 30% each core playing youtube videos)

Moving to my other older laptop (single core 2.8 P4 - 768mb RAM), which has problems with flash, although has a crappy graphics card, I notice whenever I fire up a youtube video, the CPU usage tops out (99.8% - 100%) but memory is still not all used (around 50%).

So I’m guessing the CPU is the bottleneck.

Sometime in the next few days I’m going to experiment with a lighter distro, and see if it makes a difference but as it doesn’t seem to be a memory footprint issue, I doubt if it will make much difference… I’m putting this one down to Adobe writing a crap flashplayer for Linux that is very resource hungry… I had put it down to the ATI drivers (same with VESA though), but if you’re having the same problem with an nVidia 6800 LE 256mb using the nvidia drivers…

I’ve also noticed the latest version of (32bit) seems to crash quite a bit (64bit is fine, although for some strange reason won’t let my Mrs save her score in Bejeweled on Facebook… 32bit does, but crashes a lot).

Just got a 32bit flashplayer update (10.1 r82) which seems to have solved the crashing issues, AND the Mrs can save on Facebook… That’s her happy then… no longer hassling me about Windows :slight_smile:

Might be useful to see what top reports CPU usage as whilst running a flash video in the background.


Exactly the same thing happens with ExtremeTuxRacer and SuperTuxKart (100% CPU usage)... but as this is a 3D game this is probably down to ATI's lack of 3D support for this graphics chip (older laptop) so the CPU is having to do the OpenGL calculations... so is probably unrelated to your problem, at least as far as Tuxracer is concerned.