Mdm and Lightdm (SOLVED)

Hi All
In my efforts to configure Mint 18.2 I’ve managed to break my display manager… :-[

I changed from mdm to lightdm using a ‘how to’ from the official Mint site and all seemed to go well until it came to reboot. The boot now just hangs at the splash screen. I can see a screen full of output (by hitting ‘enter’) and that reports an error ‘failure to start light display manager’. It then runs on for a few more lines then halts, waiting for ‘another process’. Unfortunately, the ‘how to’ said to remove mdm as part of the changeover so there’s no way to switch back to it.

I have the Mint 18.1 install disk (original install was 18.1 - upgraded to 18.2 via Update Manager) and also Mint 17.3 installed on a separate Hdd (sda) - M18 is on Hdd sdb.

Is it possible to re-install mdm on to M18 from either of these mediums? I could just reinstall M18 afresh but have made a lot of changes that I would prefer to keep if possible.

Thanks in advance

Rich

can you link to the instructions you followed ?

[EDIT]

And if you hit Ctrl+Alt+F3 (to drop to a text console), log on, then run:

sudo service lightdm restart

does it give any clues why lightdm doesn’t start ?

Hi Mark - I can only get to a console via ‘Advanced Options’.( Hitting Ctrl+Alt+F3 in Mint 18.2 drops me to a grub screen where ‘sudo service lightdm restart’ isn’t recognised). In ‘advanced …’ I can get to a console and log in as root then run the command and get errors ‘…failure to start light display manager…’. I think that lightdm didn’t install properly (if at all) and removing mdm has left me with no display manager at all.

Trying to boot M18 and hitting Esc brings up a screenfull of messages - at the end it states ‘Failed to start Light Display Manager’ - See systemctl status lightdm.service for details, but I don’t know how to get to this, then last line is 'A start job is running for Hold unt…finishes up (timer running/no limit)

Have you got a Mint 18 Live USB ?

If so, can you boot to it and post the output from:

sudo fdisk -l

so we can figure out which is your Mint partition.

Then we can mount that partition, chroot into it, and reinstall mdm.

and check /etc/X11/default-display-manager contains the right entry.

My box won’t boot from a usb but I have the M18 disk - will that work?

Sure it will … just do the same thing from the LiveDVD :slight_smile:

I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0001ba51

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 980991 978944 478M 83 Linux
/dev/sda2 983038 312580095 311597058 148.6G 5 Extended
/dev/sda5 983040 152638097 151655058 72.3G 83 Linux
/dev/sda6 304693248 312580095 7886848 3.8G 82 Linux swap / Solaris

Disk /dev/sdb: 37.3 GiB, 40020664320 bytes, 78165360 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x7ad54111

Device Boot Start End Sectors Size Id Type
/dev/sdb1 2048 976895 974848 476M 83 Linux
/dev/sdb2 978942 78163967 77185026 36.8G 5 Extended
/dev/sdb5 * 978944 70352895 69373952 33.1G 83 Linux
/dev/sdb6 70354944 78163967 7809024 3.7G 82 Linux swap / Solaris
mint@mint ~ $

sda is Mint 17.3 Qiana - sdb is Mint 18.2 Sonya. It’s 18 that won’t boot.

Okay, boot to the LiveDVD, make sure the Live session is online, open a terminal and run:

sudo mount /dev/sdb5 /mnt

then

for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done

then

sudo chroot /mnt

then

apt-get install mdm

then hit Ctrl+D to exit the chroot environment

Reboot to the hard drive to test.

Mark that’s brilliant! All up and running :wink: Thanks very much - I’ll set this as solved shortly.

Just a couple of points.

The installer also listed lightdm as available. Given that there is a possibility for future conflict, I’d rather remove it altogether. What’s the best way?

And, looking at the output from fdisk -l, the boot files in M18 are in a different location to those in M17, yet I deliberately set things up on sdb in exactly the same way as I’d done on sda due to previous issues with Grub finding the files. Does this matter? And would it cause further issues if they were moved from sdb5 to sdb1?

Thanks again

Rich

sudo apt-get remove --purge slick-greeter lightdm lightdm-settings apparmor

and NO, don’t mess with the boot files :wink: