Mint 19.1 install issues

Hi All - I’ve just completed a fresh install of the above and, as in the past, have run into a few problems…

Initially, the install went perfectly and booted as expected. Grub menu showed the correct version. I then did the usual updating etc etc and within that was an updated kernel. Then the problems started.

First it wouldn’t boot at all with the new kernel; I got it to boot in recovery mode with the original kernel and removed the new one but Grub menu then showed ‘Ubuntu’ and not Mint 19.1… ??? Next, boot failed into kernel panic (AGAIN). I referred back to this excellent reply from Mark -

and fortunately it was the instructions in post #19 that got me up and running - many thanks again to Mark!! :wink:

Original kernel (as shipped) is - 4.15.0-20 - boots ok, updated (recommended kernel) 4.15.0-47.49 which doesn’t boot.

So, I need assistance please for the following -

I now have only 1 kernel in the grub menu and wish to add a 2nd one as a back up. A net search hasn’t brought up any method I can understand. (And how can I determine which is the best kernel to add, keeping in mind patched versions etc?)

Is it possible (or even advisable) to ‘anchor’ the kernel to the system? (Also with ref: to the above)

I’m baffled as to why official updates constantly cause these kernel panics and non-boots and this happens whether I let the installer ‘do it’s own thing’ or use a dedicated partitioning scheme. (I currently use /boot, / and /home + swap as this seems to fit my hardware, though I’ve no idea why…) Can anyone shed any light please?

Mint runs beautifully (normally ::)) even on my old rig but having to go through this rigmarole every so often is becoming a real pain!

As ever, thanks in advance


What’s the output from:

inxi -Fz

Hi Mark - as requested

richard@richard-OEM:~$ inxi -Fz
  Host: richard-OEM Kernel: 4.15.0-20-generic x86_64 bits: 64 
  Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa 
  Type: Desktop System: DIXONSXP product: N/A v: N/A serial: <filter> 
  Mobo: Foxconn model: 945 7MC Series serial: <filter> BIOS: Phoenix 
  v: 6.00 PG date: 12/09/2006 
  Topology: Single Core model: Intel Pentium 4 bits: 64 type: MT 
  L2 cache: 2048 KiB 
  Speed: 2400 MHz min/max: 2400/3200 MHz Core speeds (MHz): 1: 2400 2: 2400 
  Device-1: NVIDIA G86 [GeForce 8500 GT] driver:[b] nouveau [/b]v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: nouveau 
  unloaded: fbdev,modesetting,vesa resolution: 1440x900~60Hz 
  OpenGL: renderer: NV86 v: 3.3 Mesa 18.0.5 
  Device-1: Intel NM10/ICH7 Family High Definition Audio 
  driver: snd_hda_intel 
  Device-2: Trust Widescreen 3MP Webcam type: USB 
  driver: snd-usb-audio,uvcvideo 
  Sound Server: ALSA v: k4.15.0-20-generic 
  Device-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter 
  driver: 8139too 
  IF: enp2s3 state: unknown speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 149.05 GiB used: 18.43 GiB (12.4%) 
  ID-1: /dev/sda vendor: Western Digital model: WD1600BB-22RDA0 
  size: 149.05 GiB 
  Hardware-1: Intel 82801GR/GDH (ICH7R/ICH7DH) SATA Controller [RAID mode] 
  driver: ahci 
  ID-1: / size: 36.41 GiB used: 6.29 GiB (17.3%) fs: ext4 dev: /dev/sda5 
  ID-2: /boot size: 1.85 GiB used: 83.4 MiB (4.4%) fs: ext4 dev: /dev/sda1 
  ID-3: /home size: 102.17 GiB used: 12.06 GiB (11.8%) fs: ext4 
  dev: /dev/sda6 
  ID-4: swap-1 size: 5.58 GiB used: 524 KiB (0.0%) fs: swap dev: /dev/sda7 
  System Temperatures: cpu: 12.0 C mobo: N/A gpu: nouveau temp: 52 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
  Processes: 156 Uptime: 4h 17m Memory: 1.95 GiB used: 831.5 MiB (41.7%) 
  Shell: bash inxi: 3.0.27 


I’ve just noticed that the graphics were using nouveau driver instead of the Nvidia one so changed it over in Driver manager. (The GeForce 8500 GT card has been fitted to this rig for years and works fine with it’s own driver - usually… ::)) When asked to reboot - yep! you’ve got it - KERNEL PANIC!!

So I’ve run through your instructions once more and have posted this before I reboot to test in case it goes belly-up again! Will update asap.

EDIT 2: No joy this time using either of the previous set of instructions, just ends up in kernel panic and I have to power off manually. Is there a way of uninstalling the Nvidia driver using the install disk and forcing the use of the nouveau one? Perhaps these later iterations of Mint might not like the Nvidia software (but I’m only guessing) though how it would screw up the boot sequence is beyond me! ???

EDIT 3: Now this is getting weird… I ran both sets of instructions (from your replies #15 & #19) and this time (in the #19 set) added ‘update-grub’ to the end and it’s booted! I’ve no idea which set has worked or if ‘update-grub’ has made the difference… but it still says ‘Ubuntu’ in the Grub menu ??? I ran inxi Fz again and got this -

  Device-1: NVIDIA G86 [GeForce 8500 GT] driver: nvidia v: 340.107 
  Display: x11 server: X.Org 1.19.6 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1440x900~60Hz 
  OpenGL: renderer: GeForce 8500 GT/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107 

so the Nvidia driver has loaded. As a precaution, I’ll suspend rather than shut-down until I know the system is stable.

On reflection, it may be that my old box and me may have come to the end of the road, good servant that it has been! Having lasted much longer than it would have done under Windows, it owes me nothing and, though I’m always reluctant to ditch something that still has life, perhaps with the advance in capability and complexity of the latest versions of Linux, the old girl needs a younger successor? The continuing issues I get when trying to update to a newer version of Mint are proof of that, I think. To that end I’ve had a look at various options available in the marketplace but would like some advice please, before I spend my money?

I have no need of anything ‘high-end’. My usage is very modest - no gaming or streaming of large files etc - just your average day-to-day stuff. So a more ‘budget’ pc would do. A decent motherboard in terms of speed and reliability, a minimum of 4GB Ram, an SSD around 150GB, an optical drive and a power supply with enough beef to handle future upgrades. My monitor is ok though only has VGA connection but I believe a VGA to HDMI lead would sort that? And a new keyboard wouldn’t go amiss. That’s about it.

Do any of you have a preference between AMD and Intel CPU’s? Is one better than the other in regard to Linux, specifically? Ditto RAM?

There is a highly rated computer parts supplier who also build to order near to me that I’m planning on checking out soon. It’s a close call as to whether I go self-build or let them do it. It comes down to price in the end - if it’s close enough I’ll let them build it and take the guarantee that comes with it.

Any advice on these points and possible pitfalls would be very helpful before I take the plunge!

Thanks to all


Yep, get an SSD, even if it’s just 128GB, though they’ve come down in price considerably lately and a 240GB model can now be found for around £30 or a 480GB for £45

The bigger the better where SSD’s are concerned, the more free space on the drive the longer it will last … simply because of the way wear levelling works.

Processor, and more specifically which is better AMD or Intel - Historically I’ve been a fan of AMD, but experience is showing me at least at the low to mid end processors Intel seem (to me) to have the edge in Linux, now this may not specifically be to do with the processor as much as the chipsets that come on the respective motherboards. For example I had a couple of laptops with quad core AMD A8 CPU’s, now on paper they were supposed to be roughly equivalent to an i5 from around the same date, but in the real world appeared to be being held back by the AMD AHCI chipset/driver to where an i3 laptop I had was faster.

That said, that was a few years ago now so things may have changed but I’m still worried that though the low/mid end Ryzens seem very good on Paper they may again be let down by supporting hardware.

There’s also the fact that people have had some rough experiences with SOME of the Ryzen processors not yet being well supported in Linux … so if you’re thinking AMD, do your homework.

It’d probably be better if you posted a couple of specific component lists here, and then let people research those components for known issues.

Oh, and these days I’d likely be looking at 8GB RAM … you can easily get away with 4, but 8 isn’t that much more and will future proof the system … it’ll also mean you’re much less likely to ever start paging out to swap, which will lengthen the life of the SSD.

Hi Mark - thanks for the sound advice, much appreciated!

I’m going to the supplier on Tuesday to do a comparison re: self-build/built to order and hopefully will get a clearer picture on component prices then.

I take your point on processors and I am leaning towards Intel as there seems to be more options on motherboards. Plus, on-board compatible graphics chips are important and save money also. I’m hoping to find an earlier gen quad core CPU that would fit the bill - don’t need bleeding edge stuff and having gaming power would just be a waste anyway.

Good tip on the size of RAM - they’ve got 8GB Corsair DDR4 sticks for under £40. Would it be better to have 1 x 8GB or 2 x 4GB sticks, or does it make no difference? (I’m thinking if one stick failed, there’s still 4Gb available?) I’ve actually got 2 x 2GB DDR2 Black Dragon gaming sticks (one is installed in this rig at mo’ - bought for an upgrade some years ago but the mobo wouldn’t power both, even though it said it would). Would these work if added or would they not be compatible?

I’ll post back when I know more - thanks again


Personally I’d go for 2 x 4GB to take advantage of the wider/faster bandwidth of dual-channel memory.

I can’t really comment on the memory you currently have because I don’t know it’s speed (we could easily find this out) … nor do we know the speed/type of RAM the new motherboard can accept yet.

But chances are if these stick work with a Pentium 4, they’re unlikely to be compatible with a modern system … they’re most likely DDR which (I’m 99.9% sure) use a different socket type to DDR4 as well as different bus frequencies.