Monitor colour imbalance after installation of Ubuntu 16.04 [SOLVED]

[Not sure if this ought to be in the Ubuntu section. Let me know if so]

I have recently bought a desktop built to my spec for an elderly lady friend. It had Windows 10 on it just as a demo and I promised to over-write it with Linux, which I did, with Ubuntu 16.04. Having an SSD it works like lightening and is a joy to use – except that there is no red at all displayed on the monitor.

The monitor’s own colour controls are set to max for all colours and it works fine on Linux 12 and 14. The computer shows the same problem on any monitor that I use, and with a different VGA cable. When the PC was demonstrated to me at the “factory” on his monitor with Windows, the colours were fine.

I tried using the xgamma command to alter the colours and discovered that changing the red intensity had no effect at all over the entire range (blue and green work as expected).
lorene@ox12:~$ xgamma -rgamma 1
→ Red 0.100, Green 1.000, Blue 1.000
← Red 1.000, Green 1.000, Blue 1.000

So this installation of Ubuntu 16.04 is not outputting red colour info. I checked the md5sum for the downloaded iso, which was OK.
I am at a loss for an explanation/solution and would be very grateful for advice.

Graphics info from lshw:
*-display
description: VGA compatible controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
PC vendor tells me that this controller is built in to the motherboard and guesses Intel HD 3000. He has offered to fit an AMD HD5450 for which he believes Linux drivers are available

Ubuntu 16.04 on another PC with NVIDIA Corporation G86 [GeForce 8500 GT] works OK on the same monitor.

Keith

***Just found this link on the latest Intel Graphics Update: Open Ecosystem. Would this be a good place to start?

Is it like this from a LiveUSB ?

Have you tried a LiveUSB from another 16.04 based distro such as Mint 18 or Peppermint 7 ?

Have you fully updated the system ?

Might be worth installing inxi:

sudo apt-get install inxi

then posting the output from:

inxi -Fz

Ah, now I can’t remember what it looked like on the Live USB and I haven’t tried a live USB of Mint/Peppermint. The system is fully updated. Here is the output:
lorene@ox12:~$ inxi -Fz
System: Host: ox12 Kernel: 4.4.0-62-generic x86_64 (64 bit) Desktop: Gnome Distro: Ubuntu 16.04 xenial
Machine: Mobo: ASRock model: H61M-HVS Bios: American Megatrends v: P1.90 date: 03/09/2012
CPU: Dual core Intel Core i3-2120 (-HT-MCP-) cache: 3072 KB
clock speeds: max: 3300 MHz 1: 1604 MHz 2: 1684 MHz 3: 1602 MHz 4: 1601 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.00hz
GLX Renderer: Mesa DRI Intel Sandybridge Desktop GLX Version: 3.0 Mesa 11.2.0
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.4.0-62-generic
Network: Card-1: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) driver: ath9k
IF: wlp1s0 state: up mac:
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
IF: enp2s0 state: down mac:
Drives: HDD Total Size: 628.1GB (2.5% used) ID-1: /dev/sda model: ST500DM002 size: 500.1GB
ID-2: /dev/sdb model: TOSHIBA_THNSNF12 size: 128.0GB
Partition: ID-1: / size: 110G used: 7.4G (8%) fs: ext4 dev: /dev/sdb2
ID-2: swap-1 size: 8.28GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 34.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 202 Uptime: 1:03 Memory: 1183.3/7690.6MB Client: Shell (bash) inxi: 2.2.35
lorene@ox12:~$

Can’t hurt to try the Intel Graphics Driver installer.

But I’d like to know what happens with a 16.04 LiveUSB, and the inxi output from a 14.04 LiveUSB too … for comparison.

How did you install 16.04, as an UPGRADE, or a fresh install ?

If an upgrade, is the red missing ALL the time … eg. do you get white text at the GRUB menu, and does red work if you sign into the Guest account ?

Just downloading the Peppermint 7 ISO and shall report back on that.

As for the Intel driver: do I just download it, or must I do something else afterwards?

I really must remember to scroll down to see the remainder of your posts!
It was a fresh install onto a Windows machine.

Please re-read the above posting, I was adding stuff when you reappeared.

Also is this 32bit or 64bit Ubuntu 16.04 ?

It’s a 64 bit machine.

Just tried to install the Intel graphics update tool but the usual Ubuntu software install appeared, I clicked on “Install” and that screen went blank. If if has installed, then it had no effect on colours, unless I now need to down load drivers using the tool.

Will try Peppermint Live USB shortly.

Using a Peppermint Live USB produces the same lack of red. Looks like a driver problem? I have no objection to buying graphics card (they are cheap enough) if you can recommend one.
By the way: Peppermint 7 looks wonderful! Can I dual boot Peppermint and Ubuntu?

Is red missing BEFORE Linux loads … ie, is the GRUB boot menu text (or any other text BEFORE Linux loads) WHITE ?

[EDIT]

If if has installed, then it had no effect on colours, unless I now need to down load drivers using the tool.

IIRC you now need to run it from the menu

Using the Peppermint Live USB: what may be the GRUB menu is all blue/green.

Not sure what IIRC means, and there is no sign in the menus that anything has been installed relating to Intel driver update tools.

If there’s no white text in the GRUB menu this can’t be OS/driver related … the OS and drivers haven’t been loaded yet.

So would using an appropriate, plug-in graphics board be the answer? If so, what would you recommend? The PC would not be used for gaming or anything strenuous like that - just editing photos, at best.

it might be yes.

But are you SURE you’ve tested the monitor (with the same VGA cable) on another PC first ?

Just tried it now on my laptop with the same VGA cable and it displays beautifully in glorious colour.
In all, I have tried three monitors with this desktop and they all fail to display red.

Do you know which graphics card slot you have ?

The vendor told me that the graphics device is built into the motherboard (and, indeed, the VGA socket is grouped amongst all the other sockets), but offered to supply a separate, plug-in board.
I haven’t checked what kind of slots are available.

I notice that the inxi output says:
Graphics: Card: Intel Mobile 4 Series Integrated Graphics Controller
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1280x800@60.00hz
GLX Renderer: Mesa DRI Mobile Intel GM45 Express
GLX Version: 2.1 Mesa 11.2.0

Is the “unloaded” relevant here?

Can’t really make any recommendations without that information :wink:

Sorry; I’m being a bit dim here. Would you tell explicitly what need to tell you?

Open the case, take a picture of the spare slots, host it on IMGUR
http://imgur.com
post a link here.

Also post the output from:

inxi -Fz