Monitor won't get active on my Peppermint notebook

If you remember guys I bought a Dell monitor to plug into my Asus notebook that runs on the latest Peppermint distro. Last time I plugged it in it would immediately go live; that is the desktop comes on it with all the icons and I can use it ( go online, open files etc etc). Now the desktop comes on but with no icons. I just get my desktop itself but nothing else. It isn’t live. The desktop is only live on the Asus notebook. I have tried doing the following:

Powering up the notebook, then plugging in the monitor/on

Powering up the notebook with the monitor already plugged in, switched on

Rebooting the notebook with the monitor plugged in/on

None of this works.

After leaving it off then plugging it in after the notebook had been on about an hour it then decided to work. Since both my computers acted up tonight must have had Gremlins! But any advice on the best and fastest way to connect the monitor to the notebook gratefully received!

Have you tried the monitor on any other hardware (to see if it’s the monitor) ?

No, I only got the Chromebook and it wouldn’t work on that I expect. I think it was just the settings, as some box came up when I plugged it back in later asking me to choose a setting ( one screen, dual screen etc). Might be that I need a better package on the netbook for screen settings? There’s the monitor settings but once they are both on it seems to be too late to choose the Dell monitor. I think it’s due to the time it takes to power up the netbook- the big monitor is faster to boot up obviously.

Are both monitors listed in:-

Menu > Settings > Display


If not, click “Identify Displays” … are both listed now ?

and is “Configure new displays when connected” ticked ?

That sounds familiar Mark. I’ll try that out tomorrow in daylight and get back to you on it. I kinda like the big screen for Star Trek on Netflix!