MP3 Problem For K3b

I keep getting the same thing pop up every time I run K3b telling me I can install MP3 encoding package but it doesn’t do anything.
What can I do to stop it from poping up every time I run K3b or can I check to see if it’s already installed and K3b can’t see it.
[URL=ImageShack - Extra_For_K3b.jpg]
ImageShack - Best place for all of your image hosting and image sharing needs

You can stop that notification from popping up (see here):

Once the notification appears, click the X to close it. This will leave an icon in the system tray (blue world w/arrow). Right-click on it and you have the option to 'Never show again'. Check that and it won't ever appear again when you launch K3b

But check if lame is installed:

sudo apt-get install lame

Heres what comes up when I search for ‘lame’ in Muon Package Maanger
[URL=ImageShack - Lame.jpg]
ImageShack - Best place for all of your image hosting and image sharing needs

OK, go to in k3b:
Settings->Configure K3b->Plugins
and see if K3b Lame Mp3 Encoder is present and enabled.
If not the you may need to install libk3b6-extracodecs

sudo apt-get install libk3b6-extracodecs

Looks like it’s not installed, so I’ll install it.
[URL=ImageShack - K3b+Plugins.jpg]
ImageShack - Best place for all of your image hosting and image sharing needs

Strange!..

pooky2483@pooky2483-ubuntu12:~+$ sudo apt-get install libk3b6-extracodecs
[sudo] password for pooky2483:
Reading package lists… Done
Building dependency tree
Reading state information… Done
libk3b6-extracodecs is already the newest version.
The following packages were automatically installed and are no longer required:
libsvga1 libvdpau1 computer-janitor
Use ‘apt-get autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pooky2483@pooky2483-ubuntu12:~$

I know sod all about K3b (it starts with a K, so I immediately consider it evil :wink: ), but is the lame package installed ?

dpkg -l | grep lame

[EDIT]

If it’s mentioning a licensing issue … have you got the ubuntu and kubuntu restricted-extras packages installed ?

dpkg -l | grep restricted-extras
dpkg -l | grep lame

pooky2483@pooky2483-ubuntu12:~$ dpkg -l | grep lame
ii lame 3.99.5+repack1-3~ppa2 MP3 encoding library (frontend)
ii libmp3lame0 3.99.5+repack1-3~ppa2 MP3 encoding library
ii libtwolame0 0.3.13-1build1 MPEG Audio Layer 2 encoding library
ii twolame 0.3.13-1build1 MPEG Audio Layer 2 encoder (command line frontend)
pooky2483@pooky2483-ubuntu12:~$

dpkg -l | grep restricted-extras

pooky2483@pooky2483-ubuntu12:~$ dpkg -l | grep restricted-extras
ii kubuntu-restricted-extras 57 Commonly used restricted packages for Kubuntu
pooky2483@pooky2483-ubuntu12:~$

Also, see Reply #2.

Have you got all the repos eneabled … such as universe, mutiverse, independent, and canonical partners ?

Have you tried reinstalling libk3b6-extracodecs

sudo apt-get install --reinstall libk3b6-extracodecs

?

[URL=ImageShack - Sources.jpg]
ImageShack - Best place for all of your image hosting and image sharing needs

Have you tried reinstalling libk3b6-extracodecs
sudo apt-get install --reinstall libk3b6-extracodecs

pooky2483@pooky2483-ubuntu12:~$ sudo apt-get install --reinstall libk3b6-extracodecs
[sudo] password for pooky2483:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
libsvga1 libvdpau1 computer-janitor
Use ‘apt-get autoremove’ to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/28.0 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database … 270708 files and directories currently installed.)
Preparing to replace libk3b6-extracodecs 2.0.2-3ubuntu4 (using …/libk3b6-extracodecs_2.0.2-3ubuntu4_amd64.deb) …
Unpacking replacement libk3b6-extracodecs …
Setting up libk3b6-extracodecs (2.0.2-3ubuntu4) …
pooky2483@pooky2483-ubuntu12:~$

Doesnt come up with install the mp3 stuff now, don’t know whether it’s due to telling it not to notify me or what I’ve just done in re-installing the restricted extras but the mp3 plugin is not there in the list as in the post where I show the list of plugins…

What are the settings of the “K3b external audio encoding” plugin ?

I have been using K3b for a long time and find it to be the best CD burner software around. Although I had no problem like this on my Debian Testing based SolydX install, i did come across some reports that there seems to be a bug affecting K3b shipped with K/Ubuntu 12.04

I’m with seZo on this it’s the best by far (for me).

[URL=ImageShack - K3b_Ext_Audio.jpg]
ImageShack - Best place for all of your image hosting and image sharing needs

Well lame seems to be set in there … have you tried encoding to mp3 again ?

I might agree with you both if I could bring myself to use a Kapplication and all the sh*te it brings with it … but I’m unlikely to ever find out, I have little use for CD/DVD’s any more so don’t load burning software at all

On the odd occasion I do need to burn one, I tend to just create an ISO and burn it in ImgBurn on my missus laptop.