My Computer Is Running Slow

Today it took a little over 7 minutes for Peppermint 5 to open up to my desk top. I’m not sure if it’s something in the computer or if it’s something up with the operating system. How can I find out what the problem is?

Hi Buckwoody

Is the problem only with booting up or is it still slow once it is booted up ?

Have you made any changes to your system or installed any new programs just prior to this problem happening ?


Have a look in the boot log

gedit /var/log/boot.log

and if nothing looks out of place … try looking at dmesg:

gedit /var/log/dmesg

the number at the beginning of each line is how many seconds into the boot the message got logged … so look for any major jumps in the time count (may give you an idea what was happening when the boot stalls for a while.

Was this a one-off? Could have been a boot-time filesystem check (after X number of boots, the filesystem gets checked for errors)

Hey guys!
Sorry it’s taken me so long to get back to you. Ok, here’s a little more information. When I first turn on the computer, after the Dell Computer splash screen, a blue box comes up with options for loading. The first being Peppermint 5. If I do nothing, the loading sequence will begin. The first thing that happens is the screen goes black for about 10 - 15 seconds and a line stating Searching for some file system. This can take anywhere from 1 minute to 3 or 4 minutes. Once again the screen goes black for about 30 seconds, followed by some code and a bunch of numbers with a message stating the chexsum is wrong, followed by another paragraph of numbers with another statement that the chexsum is wrong, followed by the Peppermint logo and a red loading bar which gets about a third of the way across and then stalls for about a minute or more. Usually more. The screen will then go black again for a few minutes and eventually the desktop will come up. From then on anything either my wife or I do is very slow.
When I first loaded Peppermint 5 into this thing, it was like lightning! I couldn’t believe how fast it was. It loaded in at a blazing speed and shut down almost immediately. I have no idea of what happened.

I would say that it points to corrupted filesystem and / or failing hard drive.

You could try to force fsck (file system check) on next boot using shutdown command:

sudo shutdown -rF now

That should on boot up at least show you if there are filesystem errors.

Ok, maybe I missed something. I copied and pasted that into a terminal, put in my password and hit enter. The computer shut down, rebooted, and nothing else happened. Was I supposed to do something else?

That should have forced the filesystem check to be carried out on reboot.
Even for a brief time it would have shown that it was running. Perhaps peppermint hides this part during boot up.
If that run and found nothing wrong or fixed whatever it found.
You could check date for the last filesystem check (replace /dev/sda1 accordingly):

sudo dumpe2fs /dev/sda1 | grep checked

You could try to reboot now and see if it is any faster.

If not then please post the content of your /etc/fstab

cat /etc/fstab

It is possible that it tries to mount a non-existent drive (perhaps USB).

I also thin this points to a corrupt file system or failing hard drive.

First run:

sudo touch /forcefsck

then reboot.

During the boot sequence you should see a message similar to
Hit C to cancel checks
DON’T hit C … just let it finish booting.

Now let’s remove the scan for btrfs during bootup, if you don’t know what btrfs is you’re unlikely to have manually partitioned and chose that filesystem during installation so run:

sudo apt-get remove --purge btrfs-tools

How is it booting now ?

Hey Mark,
I was hoping to report that it would be running like lightning again, but it doesn’t seem to be much faster. The one difference is that it’s not searching for the file system but the screen was black for a lot longer. I’m going to have to get back to this in the morning. I hope it’s not a hard drive. In the mean time, if there’s something else for me to do, let me know and I’ll get to it in the morning. Thanks for your help!


dmesg > ~/Desktop/dmesg.txt

you’ll then find a file on your desktop called dmesg.txt … attach that to your next post

Now let’s remove the scan for btrfs during bootup, if you don’t know what btrfs is you’re unlikely to have manually partitioned and chose that filesystem during installation so run:
Code: [Select]
sudo apt-get remove --purge btrfs-tools
Hi Mark,
Can I try this command as well ?

Sure you can … unless during installation you manually set up your partitions and chose btrfs as a file system (btrfs will NOT have been automagically chosen as a file system).

Hey Mark,
I hope I’ve done this right?

The biggest jump is in these lines:

[ 6.178062] EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: (null) [ 129.661480] Adding 3999740k swap on /dev/sdb3. Priority:-1 extents:1 across:3999740k FS
To see if that makes any difference try disabling the swap partition:
sudo swapoff /dev/sdb3

then disable it in fstab:

sudo gedit /etc/fstab

and comment the line out (with #) which refers to the swap drive (/dev/sdb3)
save and exit. Reboot to test it.

How much RAM do you have OP? If you need the swap space to boot, you can’t disable it!

Thanks Mark. All done and dusted, thanks :wink:

OK, before I do this, the only thing I don’t understand is the part about commenting the line. How and where do I do that?

The best would be if you could post the contents of your /etc/fstab and then we will tell you which line to comment out and how.

sudo gedit /etc/fstab
OK, before I do this, the only thing I don't understand is the part about commenting the line. How and where do I do that?

Commenting out a line simply means adding a # at the beginning of the line which means the line will be ignored, that way the line can easily be restored without retyping it