My general help questions

I’ve noticed I ask a lot of questions, most of which don’t warrent a new topic, so I made this topic.
(Currently dual-booting 7 (64bit) & Ubuntu Studio (64bit) on a 4GB Intel Core 2 Duo machine with D-link wireless & an 8800.)

  • First, Wine.
    I know it’s been explained to me before, but I still didn’t quite get it. How do I fully switch from latest version to stable version? (and visa versa for future reference.) I’ve tried just using the Ubuntu Software centre, but it somehow doesn’t fully remove either, so I’m left with a stable version that won’t run itself, and a latest version that won’t run the programs I want to run (Steam, specifically that chat feature & the Touhou games).

  • Second, Firefox add-ons.
    At the moment, I have the download status bar, Java, various adobe things & Foxit reader on 7 (used to have No-script & Foxy proxy for security in XP, but I don’t really know how they work and now no-script is getting annoying & after turning Foxy proxy on, nothing worked) and on Ubuntu I only have a flash player & a pdf reader.
    What does everyone recomend for Linux and (if I may ask) Windows?

WINE:
To COMPLETELY remove WINE, uninstall it from the synaptic package manager (NOT the software centre), mark it for ‘complete removal’, and then go to your ‘home’ directory, and delete the .wine directory (this directory is hidden, so you will have to enable ‘show hidden files’ from ‘View’ on the toolbar) .

Then reinstall the version you want (preferably from the synaptic package manager) then open a terminal and type:

winecfg

to configure WINE (and recreate the .wine dir).

BE AWARE: deleting the .wine directory will delete ALL the windows programs that you previously installed with wine, and the wine configuration files.

As for FireFox… I don’t use firefox anymore, Google Chrome is MUCH faster

Thanks for that, I’ll have to start actually trying the solutions people give me. ^^

Anyway, new story. I’m back at home now and I’d try some things out while I’m here.

  • Third, connecting.
    I’ve got Windows7 to connect to our BT voyager router (after a lot of bother then eventually realizing we just need to enter the code on the bottom of the router), but I’m having problems with Ubuntu.

The guys back in the computer society had some fun with it and got it on the University wireless that’s available in all flats, but they put me on the society’s server. I was then having problems with random lag spikes, the occasional disconnection and general poor performance, so I asked the president about this (who was not happy with the society later that day ^^), and he gave me some simple instructions on how to fix this. I have since thrown these away, bit I can remember it was something like Preferences > Network Proxy > Proxy config > Manual proxy config > HTTP proxy > [a url & a number]. I want to be able to reconnect to the internet immediately when I got back to my flat, but I also want to be able to connect here.

Any help?

  • Fourth, Firefox.
    Foxy proxy and No script are giving me real grief now, and disabling them makes it worse. 4 out of 5 times, after I post on any forum, the post gets lost and I can’t recover it. :frowning:

  • Fifth, where the fun begins. BD
    We’ve had this Dell dimension 3100 since about 2004, and I’ve decided to try and convert my family (who are all PCs, even though all our relatives are macs) to Linux by getting Ubuntu to work on it.

When I first put it on back over Christmas, the internet didn’t work, so I abandoned it, but never bothered to uninstall. I don’t know what I did wrong back then, but I logged on today and everything works fine . . . ish. It’s got a 2.66GHz Celeron D with 2GB of DDR2 RAM, an 80GB IDE HDD (or 75GB, depending on what program you look at), a 500GB USB HDD, a PCI 5200, a Belkin Wireless G adapter (rt73 version) and a 1024x768 CTR monitor. It used to have a blast-from-the-past ball mouse, but laser mice had become so cheap. B) The internal HDD has XP (about 64GB), Ubuntu 9.10 (about 12GB) and some Dell utility memory checking software that I’ve never really looked at filling the rest on it.

It still runs aggravatingly slow, though it’s better now than it was about 2 hours ago before updating, and I’m wondering if there’s something I can do to the software to make it run any better. I read on another website that there can be some problems with the driver. I’m hoping to get everything to run better than XP.

  • Sixth, users & sharing.
    There are now 4 computers in this house all using the same Router.

My dad’s Dell Vostro 1500 laptop, which cannot be touched [yet ;)], my home-made setup, this Dell Dimension, and an ancient IBM Thinkpad laptop from around 2000 with the same Belkin wireless, 125MB of RAM, and XP. There’s also a desktop with ME on it, but that’s in the attic and is unlikely to ever be used again, ever.

If, say, they all used Ubuntu, would it be possible to create some sort of network? I’ve never bothered with the concept of users until now, even back in XP, we all just used the same admin account.
a) I want there to be 6 accounts on this computer at least (not including the root), one for every member of this house with the same access as I do now with the default accout and a guest account. I also want this account deleted because it’s name as the root password (yes, I was an idiot). Just so everyone can stay logged in to they’re own email/facebook/etc. without having to log out of everything whenever someone wants to use the computer.
b) After that, would it be possible to let everyone sign in from every computer in this house? To whatever extent thats achievable . . .

  • Seventh, email.
    I can loggin to my yahoo chat account with Empathy, but would it be possible to do the same with my yahoo email & Evolution (or Thunderbird)? Would this also be possible for my brother & sister who use MSN/hotmail?

i just set up a home network used an old box i had lying around used that as a server put all the files we need on that one and then we have our own accounts on our own computers and connect through a network drive for the shares

my server is linux wifes laptop is windows and my pc at current is windows and although had some issues with shared folder untill i learned about nautilus (thanks mark) all seems to be running smoothly (wifes using wireless on her laptop to connect to server). also on the server each user (me and wife) has their own home directories where we can store stuff :slight_smile: wasnt to hard to setup. i used samba to link the linux machine to the windows

Third Connecting:

As long as you’ve not deleted/overwritten the network settings for your home network, all you should have to do is disable the proxy settings in firefox.

Open firefox then click Edit > Preferences > Advanced > Network > then the ‘Settings’ button under ‘Connection’…then put the tick in the ‘No Proxy’ box, and click OK.

Before you put the tick in the ‘No Proxy’ box write down the proxy settings in case it removes them.

Your internet should now work at home…to make it work at work again you will have to put the tick back in the ‘Manual proxy configuration’ box

Or use a different browser for home, such as Opera or Chrome, ‘without’ a proxy server set.

Another option would be to add another user for home or work, and have different settings in Firefox for each user… which is probably the best option, as you can change the setting for anything when logged in as ‘work’(user) and then when you log back in as ‘normal’ user your setting will not have changed.

Fifth, where the fun begins:

If you are running Ubuntu Karmic 9.10, the Belkin Wireless G USB adapter will be detected as a Ralink rt73 (this is the chip used) and will work immediately… This adapter IS supported in 9.10, so this is unlikely to be the cause of the slowdown.

I take it you mean the internet is slow?.. things to check:
how far from the router (signal strength)
is anyone else connected to the net, and what are they doing (downloading large files)
if there is another PC on the net, is it a windows PC, and are you SURE it is malware free (malware often uses bandwidth)

Make sure all other PCs are switched off, and see if your connection is still slow, if not it isn’t a problem with this PC.

Sixth, users & sharing:

If all you want is internet access from every computer, you don’t ‘need’ them networking (though it can be done), as long as you have a router, the router should take care of network address translation (NAT) and give them all internet access.

Multiple users on a single computer - Yes this can be done very easily too.

Can you let us know exactly what you are trying to achieve.

Seventh, email

Yes both Evolution or Thunderbird can connect to Yahoo email, as either IMAP or POP3 clients, but hotmail is different, currently there are NO IMAP server settings available for hotmail though I do believe you can connect as a POP3 client.

Apparently there ARE IMAP server settings for Hotmail+, but not ‘vanilla’ Hotmail

this is correct currently there are no IMAP settings for users on free hotmail (tried setting up email other day) had to use pop3 which was annoying so pretty much ditched hotmail and used my google account which also has IMAP settings. (don’t fancy paying M$ for something that’s available free)

just an added note for “Fifth, where the fun begins:”

try restarting your router this generally fixes alot of probs with sluggish internet connections

Fourth:
Ok, I’m still having issues with posts being lost but it’s less frequent (though still mostly on this forum :frowning: ).

Fifth:
Seems our internet was borking yesterday :/. I guess I’m just too used to a dual-core and the Celeron is the problem for me.

Sixth:
After sleeping on it, I’ve decided to scrap the multicomputer thing. At the moment, there are 3 people (mother, brother & sister) using that computer and I only think that number will go down (well, I will occasionally use it to do maintanece like backing-up). I want it so that when each of them login, they’re automatically logged into their chat, email, mybook, facespace or whatevertheybloodyuse, and so they (especially my mum with her ebay & amazon acounts) don’t to have to worry about signing in and out of 6 different places everytime there’s a change of user. Also would be nice if changing the appearence of one acount changes it for the others ('casue that really bothers my brother).
I want there to be only one set of programs that everyone can use and everyone can add to for everyone to use, for all users to be locked out of other’s acounts, files, and everything specific to that user, but for everyone to have the root access like I do now on my computer (because mum might phone me with a problem and I’d need to get her to do it from her acount when everyone else is out). So 4 users, each with the enough access to fix any problems or add programs but no access to others acounts, but only one of them (mine) that can change users, groups & maybe unlock other acounts for when someone inevitable forgets their password.

Seventh:
IMAP, POP3? What? O~o;
I think I’ll deal with this a little later . . . ^^;

In ubuntu karmic (cant say for any other system only used ubuntu) you can go to System>Administration>Users and Groups (click the keys at the bottom type password and you can edit remove add users)

from here there’s a few settings you can change ie for access purposes. may i suggest not giving root with root they can change accounts passwords and if knowledgeable enough (or even a quick google search) they can enter other family members folders if you don’t allow them root this isn’t possible.

Im sure i read somewhere you can actually restrict what commands to certain groups but if i recall it requires a long and painful process.

Best thing to do set it up correctly the first time and you shouldn’t have an issues with not giving them root access.

as for remembering passwords for ebay, amazon etc just let firefox remember them each visit that way when your mum opens up ebay will auto log her in :slight_smile:

these are just email protocols

Internet Message Access Protocol (IMAP)
Post Office Protocol (POP)

For example you have folders for certain emails to be kept in like receipts etc. Hotmail, Gmail and Yahoo and no doubt all the little email providers allow this

With IMAP set up, this will allow you to see the whole folder structure you have and keep all email within them folders.

However POP3 doesn’t see the folders just the emails which will result in a mess of emails not knowing which folder they belong into etc.

Hope that explained it.

Sixth:

You are asking for 2 conflicting things here… first you say give everyone root access, then you say lock them out of other users accounts… root access specifically means ‘FULL access to everything with FULL privileges’ so effectively you can have one or the other.
It would be possible to unlock/activate the root account, then lock down user accounts requiring them to log out then log back on as root, but even then you would be giving them the root password and tempting them to log in as root every time for added ‘power’ (which is dangerous).
Another way for you to be able to ‘fix’ their problems from ‘your’ house without giving them root access would be to create an ‘admin’ account (only you know password) with root access, and RDP into it from your house, and lock down their user accounts.

When you say automaticaly logged in to their chat etc… just autostart these apps in individual user accounts.

As far as I’m aware, without root access there is no way to have one users appearance changes act system wide.

Same for program installation…without root access… no way to install programs system wide.

So your first decision really needs to be, do you want to allow them system wide root access… they would still have their own home folders/settings, but ‘could’ if they wanted to do ANYTHING.

Gah, have to remember to come to this place more.

Sixth:
OK, easier question.
I have a mother, brother & sister who all share the same half-decade old Dell Dimension.
My brother is warming to Linux because A, it’s working now, and B, it’s the first option in the GRUB. :expressionless:

Currently, they all use that same Admin acount for everyday use (lol, wtf MS?), and they all have lots of websites they sign into. Bearing in mind that my mum has difficulty remembering her +20 passwords, and stays signed into most, yet has to sign out of some crucial ones for peace of mind, what would you recomend?
Also, is it possible to transfer all her favourites/bookmarks from Win IE to Linux Firefox?

Eighth:

[spoiler]So I’m part of a modding group that’s making skins for TF2 from the Touhou games. TF2 is a FPS by valve, so it’s very mod-friendly, and the Touhou game are vertical scrolling shooters that run run well in linux.

Now, one of the memebers wants to make a sound replacement, replacing the sound of dodging bullets as a scout in TF2, with the sound of “grazing” in Touhou. Because most of us have little skill in computing or model making, only gaming on computers (yes, we’ve had problems as a group), we’re not sure how to rip the soud effect from the game (all the games use the same SFX), but you can dissable the music in-game.

So I had the idea of recording the sounds directly from the games whilst playing them with the music off. I first tried finding a free windows sound recorder and use my 3mm Jack-to-Jack wire to plug the output jack into the input jack, and record that. But sourceforge only gave me a program that recorded directly to an mp3 file, which would’ve been fine, if we didn’t need wav files and if I didn’t have to compile it myself because of licensing issues. DO NOT WANT AT 2 IN THE MORNING! 8|[/spoiler]

So then I had the idea to use Ubuntu Studio’s Jack. I could start a Touhou game in window mode (if it doesn’t crash linux completely, which it has done), get wine to send the game’s audio to the Jack audio server instead of the output jacks, then record it to an audio file of my choice, play the game to get the SFX I want to play, then we could edit & convert that file later…

I just want to know, is this possible, or am I asking too much of myself & my computer?

just wrote this out quick but thought i would add it to tips and tricks section for others

http://forum.linux.co.uk/index.php/topic,492.0.html

just follow the steps quickest way is using a USB thumb drive.

To capture audio directly from your soundcard to a file:

First create a file in you home directory called :
.asoundrc (make sure you include the full stop)
if one doesn’t already exist (remember, you will need to enable ‘show hidden files’)

Copy the following to the .asoundrc file:

pcm.copy {
type plug
slave {
pcm hw
}
route_policy copy
}

and save the file.

Now in a terminal type:

alsamixer

then hit the ‘tab’ key once to select ‘Capture’ (at top).

now use the arrow keys to move to ‘Capture’ (at bottom) and hit the spacebar to select it, now use the PgUp/PgDn keys to raise the volume to about 33%

Now use the arrow keys again to move to ‘Mix’ and hit the spacebar to select it.

Now if you type:

arecord -d 10 -c 2 -f S16_LE -r 44100 -t wav -D copy foobar.wav

in a terminal, it will record 10 seconds of audio from your soundcard to a file called foobar.wav and place it in your home directory.

If you require longer than 10 seconds, just change the ‘-d’ parameter in the command from ‘10’ to your required length.

If you aren’t sure how long you want to record, set the ‘-d’ parameter to any large value… say 1800 (half hour)
This way when you have reached the end of the recording you can just hit ‘Ctrl-C’ to quit.

BE AWARE - The audio is saved in .WAV format, so 10 secs = approx 1.5mb… 30mins = approx 270mb
And whilst recording make sure the volume in your system tray isn’t set too high… about 30% will do

Thanks guys, the group and I really appreciate it. ^^

no problem’s :slight_smile: need anything else don’t hesitate to ask :slight_smile:

sigh A plethora of problems . . .

Ninth, I formatted the Dell’s hard drive (after dumping all 60GB of it’s contents onto an external), and tried to put Ubuntu back on it, but the DVD drive in it is shot so it can’t read DVDs for extended periods of time, so I plugged the HDD into MY computer, and used my optical drive. This worked fine for the Dell, which is now utterly fine running Ubuntu, but it messed up my GRUB. It just gave me an error message everytime it tried to boot up, so I had to put another partition with linux on it.

Long story short, my computer’s working fine now and I can boot up 7, Ubuntu Studio and both Ubuntu 9.10’s, but if it happens again, where I need to fix the GRUB, is there a less . . . crude solution than just putting another Linux on it?

Tenth, I was going to just post a problem with wine, but now EVERY thing is just . . . wrong! Dx
-Firefox crashes every time I move away from a youtube video. I can watch it, but if I try to close the window or the tab, or click back, or click another video, it freeses and I have to Force Quit.
-There’s no sound, not from Skype, not from Youtube vids, not from MuseScore. All volume adjustments are at max, the desktop icon, my headphone slider (which are plugged into the rear output jack), all the sliders in the sound preferences. Sound works fine on Win7, but nothing from Ubuntu Studio.

  • Everything’s working a lot slower. I’ve typed some of this post very quickly and it’s occasionally taken a few seconds for what I typed to appear, programs are loading slower.
  • The update manager couldn’t connect to search for any updates.
    Help! ;_;

Mmm, sounds like the experience could be a little smoother for you … (!)

Re; grub

When installed the “new” grub system creates a file called /boot/grub/grub.cfg … this should contain all the profiles your machine “knows” about including your multi-boot / windows options. If you get to a point where Windows (or something else) has screwed the boot process to the point where grub can no longer process this file, the solution is to boot off the live CD, mount your root filesystem, then re-run grub-install, which ‘should’ re-activate your grub configuration.

For example, booting off a CD and assuming you have a single SATA drive with a boot partition, swap partition and root partition;

Starting a terminal session, Applications → Accessories → Terminal

mount /dev/sda3 /mnt
chroot /mnt
mount /dev/sda1 /boot
grub-install /dev/sda
umount /mnt/boot
exit
umount /mnt
<reboot>

Notes; fdisk -l will list all the hard drives you have and the respective partitions, for example;

$ sudo fdisk -l Disk /dev/sda: 1000.2 GB, 1000204886016 bytes 255 heads, 63 sectors/track, 121601 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Disk identifier: 0x0001dfa3

Device Boot Start End Blocks Id System
/dev/sda1 * 1 33 265041 83 Linux
/dev/sda2 34 52251 419441085 8e Linux LVM
/dev/sda3 52252 55898 29294527+ 83 Linux
/dev/sda4 55899 121601 527759347+ 5 Extended
/dev/sda5 55899 56421 4200966 82 Linux swap / Solaris
/dev/sda6 56422 66865 83891398+ 83 Linux
/dev/sda7 66866 79920 104864256 83 Linux
/dev/sda8 79921 92975 104864256 83 Linux
/dev/sda9 92976 121601 229938313+ 83 Linux

Re; further problems - something on your machine is screwed or crashed … assuming a reboot has not fixed your problems;

Boot from the live CD, OR boot the machine single into single user mode.
(Press ESC while booting, then select Ubuntu recovery mode from the menu)

From the terminal prompt, do;

fsck -f /dev/sdxx

For each of your Linux partitions … it does sound rather like something had been corrupted. Failing this, boot up the machine proper and start a terminal session, enter ‘root’ user mode by typing “su” and entering the root password. Then do;

apt-get install smartmontools

When this completes do;

smartctl -a /dev/sda

And see what it says … specifically you’re looking at the lines numbered: 1, 5, 194, 195, 196, 197, 198, 199 and 200. Typically these numbers should be zero apart from 194 which should probably be in the 20-50 range. This is what a healthy disk looks like;

1 Raw_Read_Error_Rate 0x002f 100 100 051 Pre-fail Always - 0 2 Throughput_Performance 0x0026 252 252 000 Old_age Always - 0 3 Spin_Up_Time 0x0023 079 073 025 Pre-fail Always - 6395 4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 6 5 Reallocated_Sector_Ct 0x0033 252 252 010 Pre-fail Always - 0 7 Seek_Error_Rate 0x002e 252 252 051 Old_age Always - 0 8 Seek_Time_Performance 0x0024 252 252 015 Old_age Offline - 0 9 Power_On_Hours 0x0032 100 100 000 Old_age Always - 2241 10 Spin_Retry_Count 0x0032 252 252 051 Old_age Always - 0 11 Calibration_Retry_Count 0x0032 252 252 000 Old_age Always - 0 12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 7 191 G-Sense_Error_Rate 0x0022 252 252 000 Old_age Always - 0 192 Power-Off_Retract_Count 0x0022 252 252 000 Old_age Always - 0 194 Temperature_Celsius 0x0002 064 058 000 Old_age Always - 36 (Lifetime Min/Max 20/42) 195 Hardware_ECC_Recovered 0x003a 100 100 000 Old_age Always - 0 196 Reallocated_Event_Count 0x0032 252 252 000 Old_age Always - 0 197 Current_Pending_Sector 0x0032 252 252 000 Old_age Always - 0 198 Offline_Uncorrectable 0x0030 252 252 000 Old_age Offline - 0 199 UDMA_CRC_Error_Count 0x0036 200 200 000 Old_age Always - 0 200 Multi_Zone_Error_Rate 0x002a 100 100 000 Old_age Always - 0 223 Load_Retry_Count 0x0032 252 252 000 Old_age Always - 0 225 Load_Cycle_Count 0x0032 100 100 000 Old_age Always - 7

From a drive operating Ok, but under a little scrutiny;

1 Raw_Read_Error_Rate 0x002f 100 100 051 Pre-fail Always - 234

hth.

gimpfark46@gimpfark46-desktop:~$ apt-get install smartmontools
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
gimpfark46@gimpfark46-desktop:~$ sudo apt-get install smartmontools
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
ttf-mscorefonts-installer cabextract libmpg123-0 winbind
Use ‘apt-get autoremove’ to remove them.
The following extra packages will be installed:
bsd-mailx mailx postfix
Suggested packages:
procmail postfix-mysql postfix-pgsql postfix-ldap postfix-pcre sasl2-bin
resolvconf postfix-cdb
The following NEW packages will be installed
bsd-mailx mailx postfix smartmontools
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,804kB of archives.
After this operation, 4,411kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
postfix bsd-mailx mailx smartmontools
Install these packages without verification [y/N]? y
Err http://gb.archive.ubuntu.com karmic/main postfix 2.6.5-3
403 Forbidden
Err http://gb.archive.ubuntu.com karmic/main bsd-mailx 8.1.2-0.20081101cvs-2ubuntu1
403 Forbidden
Err http://gb.archive.ubuntu.com karmic/main mailx 1:20081101-2ubuntu1
403 Forbidden
Err http://gb.archive.ubuntu.com karmic/main smartmontools 5.38-3ubuntu2
403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/p/postfix/postfix_2.6.5-3_i386.deb 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/b/bsd-mailx/bsd-mailx_8.1.2-0.20081101cvs-2ubuntu1_i386.deb 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/b/bsd-mailx/mailx_20081101-2ubuntu1_all.deb 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/s/smartmontools/smartmontools_5.38-3ubuntu2_i386.deb 403 Forbidden
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
gimpfark46@gimpfark46-desktop:~$ ^C
gimpfark46@gimpfark46-desktop:~$

T~T

EDIT: And now Firefox & sound are working fine . . . wtf?
Took longer than usual to boot past the “UBUNTU STUDIO” screen (didn’t show that “filechecking…12%” thing it does sometimes, though), but . . . still . . . wtf?

EDIT2: Rawr! >;c

[spoiler]Update Manager

Could not download all repository indexes

The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.

Failed to fetch http://archive.canonical.com/ubuntu/dists/karmic/partner/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/dists/karmic/main/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/main/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/restricted/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/main/source/Sources.gz 403 Forbidden
Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/restricted/source/Sources.gz 403 Forbidden
Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/universe/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/universe/source/Sources.gz 403 Forbidden
Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/multiverse/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/multiverse/source/Sources.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic/main/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic/restricted/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic/main/source/Sources.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic/restricted/source/Sources.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic/universe/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic/universe/source/Sources.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic/multiverse/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic/multiverse/source/Sources.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic-updates/main/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic-updates/restricted/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic-updates/main/source/Sources.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic-updates/restricted/source/Sources.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic-updates/universe/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic-updates/universe/source/Sources.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic-updates/multiverse/binary-i386/Packages.gz 403 Forbidden
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/karmic-updates/multiverse/source/Sources.gz 403 Forbidden
Some index files failed to download, they have been ignored, or old ones used instead.
[/spoiler]

I should emphasis that I’ve been using Win7 for the past fortnight because I’ve been dipping into my games every 2 or so hours, and I have not had a single problem until I tried too write put some music into a score for a friend using some of this fancy-pants software that Studio came with.

I also cannot get any wine to install, not the stable or beta versions, not from Update Manager, Ubuntu Software Center Synaptic Package Manager, or by downloading straight from wineHQ. They simply refuse to install complaining about other versions being install and other things, but I’ve deleted my .wine folder from my Home folder and deleted two Steam related files from the desktop, yet there’s still an "Applications > Wine > Programs > Steam > Steam.exe / Steam Support.html

:x