My linux won't boot up

Sorry, but I find it confusing where to place my problem - for me, too many options. I am a novice with Linux. All has been fine until my battery power failed before I could connect to charger. Then,after I connected, I found that the boot up failed. I tried rebooting a number of times. I tried both normal and safe mode but it does not bring up the desk top. I would appreciate any help if it can be explained simply. Just remember your early days. Thanks

Which Linux distribution (Ubuntu, Linux Mint, Linpus Lite, Fedora, etc.)

How far does the boot process get ?

Are there any error messages ?

Have you got a LiveCD ?

Many thanks for your speedy response. However, I have just closed down my laptop as my eyes (and mind) can’t take any more tonight. It has been driving me crazy trying every whichway I could think of.

You ask
Which Linux distribution (Ubuntu, Linux Mint, Linpus Lite, Fedora, etc.) How do I find which? Where do I look?

How far does the boot process get ? Will get this for tomorrow

Are there any error messages ? Will give details tomorrow. I know at the bottom of boot window it said ‘failed’ against the last item But when I tried to boot in ‘safe mode’ there was a green ‘OK’ at the bottom. But I could still not move on from there and it just stays on that page.

Have you got a LiveCD ? No, I have no CD

Will have it all set out tomorrow if you let me know the answers to the above.

Thanks again

Is this an Acer Aspire One running Linpus Lite by any chance ?

Linpus Lite, as installed by default on the Acer Aspire One

http://linuxforums.org.uk/MGalleryItem.php?id=1421

Couldn’t sleep so here goes

I think it is PCLinux OS Gnome 2010

On normal boot it boots to UNEXPECTED INCONSISTENCY: Run fsck manually (ie without -a or-p options

then
An error occurred during the file system check
dropping you to a shell: The system will reboot when you leave shell
Give root password for maintenance or Control -D to continue

On the right of the window it says ‘failed’ in red.

If I click on Kernal at the bottom of the window where it has language etc., it drops Default, Safe settings, NoACPI, No local APIC

My laptop is a DELL Inspiron 1520

You really need to create a LiveCD or a LiveUSB, then boot to that so that no partitions on your hard drive are mounted.

Once booted to the LiveCD … you need to open a terminal and enter:

sudo fdisk -l

output will be similar to:-

Device Boot Start End Blocks Id System /dev/sda1 * 2048 387055615 193526784 83 Linux /dev/sda2 387057662 390721535 1831937 5 Extended /dev/sda5 387057664 390721535 1831936 82 Linux swap / Solaris

Once you know which is your Linux partition … /dev/sda1 … in above example

run:
sudo fsck /dev/sdan

where n is the actual drive assignment you got from the fdisk -l command

in the above example it would be
sudo fsck /dev/sda1


It may IS possible to run these from the root shell it’s dropping you to … but you MUST ensure the partitions are NOT mounted … or you will do more damage.

Booting from a LiveCD/LiveUSB will NOT automatically mount the hard drive partitions, so it’s always best to run the fsck command from a LiveCD/LiveUSB

BTW, when you boot from the LiveCD/LiveUSB … DO NOT go looking through the hard drive folders in the file manager as this will mount the partitions … just boot the LiveCD/LiveUSB, open a terminal and enter those commands.


It is ALWAYS a good idea to have a LiveCD or LiveUSB handy (preferably of the same distro/version as you have installed) :wink:

If you need instructions on creating a LiveCD or LiveUSB, just ask.

Well thanks BUT! Where do I start in responding? Had a feeling this would happen. I had Linux installed because I was told I would not have the problems you can get with Windows.

I have no idea what a ‘Live CD’ is. Also, you offer an option of Live CD or Live USB. How do I choose which one is best (easiest)? Then how do I create something when I can’t open my laptop to download anything? I am using another laptop with Windows to post this.

It appears that I need to complete this before querying other points you make such as ‘opening a terminal’ and entering something, and ‘Linux partitions’.

Thanks again for your attempt to help me, and I apologize for my ignorance. If you are able to help me resolve my issue - you get the ‘Linux geek award’ of the year.

Just thought I would mention. I do not have any other system on the laptop where I have Linux OS Globe 2010. I had windows removed. In other words it is not a dual system.

A LiveCD will be easier to create than a LiveUSB …

Download this file:
http://releases.ubuntu.com/lucid/ubuntu-10.04.3-desktop-i386.iso
and burn it to a CD or DVD.

If you’re unsure how to burn an ISO image to a CD or DVD … Ok, if you’re burning it in Windows… Download ImgBurn (it’s free) from here:
http://download.imgburn.com/SetupImgBurn_2.5.2.0.exe

Tutorial for burning an ISO image to CD/DVD with ImgBurn here:
http://neosmart.net/wiki/display/G/Burning+ISO+Images+with+ImgBurn

Hint - On the second picture, where it says
Write Speed: MAX
Change it to
Write Speed: X4

Once you’ve done that … give us a shout and we’ll go from there :slight_smile:

Many thanks - BUT! My other laptop is a mini type with no cd drive feature. The one with the Linux, the Dell Inspiron is the one with a CD drive. But as I cannot boot up, I cannot get on the internet, or access files.

Which is why I mentioned LiveUSB’s :wink:

Firstly, do you know if the Inspiron can boot from a USB stick ?

If unsure … How old is the Inspiron, and preferably give the Model Number

Is the working netbook running Windows ?

Yes, it will take a USB stick But whether it will boot from it I don’t know. It should, it is no more than about two years old.
It is an Inspiron 1520 It has about 4 USB ports.

My netbook has windows 7 Toshiba NB 250-107

AFAIK, the 1520 should be able to boot from a LiveUSB

OK, to create a LiveUSB stick

Download this file:
http://releases.ubuntu.com/lucid/ubuntu-10.04.3-desktop-i386.iso

Then go here:

and continue from step 2

Once you have the LiveUSB stick created, let us know and we’ll take it from there.

Thanks Mark

First I must purchase a USB stick - will do tomorrow.

Then, am I right in the understanding ? Do I insert it in the port, go to the link http://releases.ubuntu.com/lucid/ubuntu-10.04.3-desktop-i386.iso
and it will download onto the USB stick ?

Then do I leave the stick in and download on to it - http://www.pendrivelinux.com/put-ubuntu-10-04-on-flash-drive-using-windows/
Will it tell me what step 2 is from which I continue?

Sorry but I did say I am totally green on these kinds of operations, especially away from Windows.

I notice the link mentions UBUNTU yet my version is PCLinux OS Globe 2010. Is that OK? I am concerned I don’t screw things up any further by any misunderstanding that can’t be corrected.

Sorry, that last paragraph should read - PCLinux OS GNOME 2010

No … You can download the Ubuntu ISO iamge to you netbook hard drive tonight.

All you do is …

a) download the Ubuntu ISO to your Win7 netbooks hard drive

b) download the the Universal USB Installer from (step 2) at that link … also to the Win7 netbook.

c) Run the Universal USB Installer, and point it to the Ubuntu ISO image that you’ve already downloaded

d) Universal USB Creator will then use the Ubuntu ISO image to create a LiveUSB

[EDIT]

PCLinuxOS no longer seem to do a GNOME version … so I thought, if you can’t create a LiveUSB of your own distribution … Ubuntu would be my next choice, if for no other reason than I will know where to point you in Ubuntu … Ubuntu will be fine for running fsck on your hard drive.

[END EDIT]

Hi Mark,

Many thanks for the info. Unfortunately I am in great agony not computer generated. It’s a dental one. Have made an appointment for this afternoon. Meanwhile I cannot tackle anything that requires much concentration. Will get a USB Stick while I am out and get back after I have got rid of the dental pain.

I feel for you … I’ve been in that very same situation twice recently … whenever you’re ready :slight_smile: