My-Weather-Indicator Stoped working (Resolved)

I am using mint 64bit mate 17.3.

I have been using My-Weather-Indicator for the last 12 months and yesterday it just stopped working.

Tried stopping the program and restarting and it will not start. I tried uninstalling and reinstalling that did not work.
It is in my view the best weather app and so I do not want to change to another app I have tried many.

Any clues assistance.

What happens if you try to start it from the command line ? … does it return any clues ?

Ran the command in a terminal opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator

The only recorded errors are listed in the section below:

‘NoneType’ object has no attribute ‘decode’
****** Updated weather
**** New temperature: N/A°
Traceback (most recent call last):
File “/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator”, line 50, in
mwi=MWI()
File “/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py”, line 135, in init
self.load_preferences()
File “/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py”, line 376, in load_preferences
self.work()
File “/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py”, line 200, in work
self.set_menu()
File “/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py”, line 540, in set_menu
self.WW1.set_weather(weather)
File “/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/weatherwidget.py”, line 139, in set_weather
self.parse_data()
File “/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/weatherwidget.py”, line 344, in parse_data
fileimage = os.path.join(comun.IMAGESDIR,self.weather_data[‘current_conditions’][‘wind_icon’])
File “/usr/lib/python3.4/posixpath.py”, line 79, in join
if b.startswith(sep):
AttributeError: ‘NoneType’ object has no attribute ‘startswith’

Now I come to think about it this happened after a update for Java…

Nowt to do with Java…

Try this:

sudo killall my-weather-indicator

then

sudo apt-get remove --purge my-weather-indicator

then

sudo apt-get autoremove

then

sudo rm -rv /opt/extras.ubuntu.com/my-weather-indicator

then

rm -rv ~/.config/my-weather-indicator

then

sudo apt-get update

then

sudo apt-get install --reinstall gir1.2-gtk-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-appindicator3-0.1 gir1.2-notify-0.7 gir1.2-webkit-3.0 python3-tz python3-cairo python-lxml python-dateutil python3-requests python3-httplib2

then

cd ~/Downloads

then

wget http://ppa.launchpad.net/atareao/atareao/ubuntu/pool/main/m/my-weather-indicator/my-weather-indicator_0.7.5-0extras15.10.0_all.deb

then

sudo dpkg -i my-weather-indicator_0.7.5-0extras15.10.0_all.deb

now try starting it

Well that’s fixed it now working normally.

Would be interested to know what the problem was.

Many thanks.

Not 100% sure …

either:-

a) the config file(s) left in your home folder for it had become corrupt
or
b) some broken part of it was being left behind in /opt

So I just provided instructions to FULLY clean it from your system (including all configs, etc.) … then reinstall from scratch

Another issue has now surfaced, an update has been issued but after installing the update via the package manager it stopped working again.

As there is no change log it is not possible to see if I can miss the update. I followed your instructions and as before it is now working OK.

Is there a line of code in your instructions that can be changed so as to install the update to:- 0.7.4-0extras 15.10.0

instructions above updated for version 0.7.5 (my-weather-indicator_0.7.5-0extras15.10.0_all.deb)

Make sure you run ALL the commands … in particular make sure python3-httplib2 gets installed otherwise you’ll get an error stating:-

File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/yql/__init__.py", line 19, in from httplib2 import Http ImportError: No module named 'httplib2'

You have to wonder why they didn’t make that a dependency so it got installed automagically ???