Navigating to folders in terminal

This is probably going to sound a little stupid, and I know I should really know this by now, but… if I want to get somewhere like my downloads, documents, etc, what is the file path to get there?

I’ve tried:
/lucy/downloads
/home/lucy/downloads
/home/downloads
./lucy/downloads

Apparantly none of these places exist and I’m having trouble figuring out what I’m missing out. I usually put ‘nautilus’ before them but this is really all so I can install something…

You were there with /home/lucy/downloads … well nearly … Remember Linux commands/paths ARE case sensitive, so it should have been /home/lucy/Downloads

so /home/lucy/downloads, and /home/lucy/Downloads are 2 different places.

You can shorten this to ~/Downloads

As ~ means the current users home directory.

hth.

Ahh, of course… thanks! :slight_smile:

When I navigate to a folder in the Downloads it works, but not with ‘cd’ before it…

lucy@Lumae:~$ cd /home/lucy/Downlooads/rawstudio-1.1
bash: cd: /home/lucy/Downlooads/rawstudio-1.1: No such file or directory
lucy@Lumae:~$ nautilus /home/lucy/Downloads/rawstudio-1.1
(Works)

Any idea what’s going on? :frowning:

Yup … typo … you’ve got 2 oo’s in Downlooads :slight_smile:

…oh dear. Well, that makes sense >.> Oops… thanks for spotting that, lol.

Edit - it still does the same thing with it spelled correctly :confused:

if the nautilus /home/lucy/Downloads/rawstudio-1.1 command worked and opened nautilus in the rawstudio-1.1 directory …

so should:

cd /home/lucy/Downloads/rawstudio-1.1

or

cd ~/Downloads/rawstudio-1.1

and you should end up at this prompt:
lucy@Lumae:~/Downloads/rawstudio-1.1$

Try changing the current directory, one directory at a time…

cd ~

then

cd Downloads

then

cd rawstudio-1.1

at the very least you’ll see where it’s falling over.

It’s working now :slight_smile:

It got some of the way through configuring… then came up with this:
configure: error: *** Rawstudio requires libjpeg.

I looked on the Synaptic Package Manager, and it says I do have ‘libjpeg62’ installed, which is the latest version. Do I need ‘libjpeg62-dev’ or ‘libjpeg-dbg’ as well? I don’t know if this is specific to the program though, so if you don’t know what I’m talking about don’t worry about it :slight_smile:

You do realise rawstudio 1.2-5 is available in the repos don’t you?

Oh, I didn’t even consider it would be… that was easier… Thank you :slight_smile:

gimp-dcraw and/or gimp-ufraw may be easier to use… they’ll import RAW images directly into the GIMP.

both in the repos.

Ok, I’ve installed gimp-dcraw (only lets me install one or the other) - I really like this program so I’ll be using it for most of the editing, but it’ll definitely help to be able to edit them more in Gimp afterwards. :slight_smile: