Neither software or package manager working ! ?? (SOLVED)

Hi Folks, So, here’s a new one on me… neither SPM nor Software manager are working…

SPM, having asked for, and received my pwd, gives the following errors:-

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.

Sotware manager asks for my pwd, and is given it, and then closes the window (!!)

So…, I did a manual update:-

sim@sim-flaptop ~ $ sudo apt-get update
[sudo] password for sim:
Ign trusty InRelease
Hit trusty InRelease
Ign trusty InRelease
Get:1 trusty-updates InRelease [65.9 kB]
Ign trusty InRelease
Get:2 trusty Release.gpg [72 B]
Hit trusty/main amd64 Packages
Hit trusty Release
Get:3 trusty-security InRelease [65.9 kB]
Hit trusty/main i386 Packages
Hit trusty/main Sources
Get:4 trusty-backports InRelease [65.9 kB]
Hit trusty/main amd64 Packages
Hit trusty/main Translation-en
Hit trusty/main i386 Packages
Get:5 trusty Release.gpg [316 B]
Hit trusty Release
Ign trusty Release
Ign trusty/main amd64 Packages/DiffIndex
Ign trusty/main i386 Packages/DiffIndex
Hit trusty/main amd64 Packages
Get:6 trusty-security/main Sources [127 kB]
Hit trusty/main i386 Packages
Ign trusty/main Translation-en_GB
Ign trusty/main Translation-en
Get:7 trusty Release.gpg [933 B]
Get:8 trusty-updates/main Sources [393 kB]
Get:9 trusty-security/restricted Sources [4,637 B]
Ign trusty/main Translation-en_GB
Get:10 trusty-security/universe Sources [50.3 kB]
Ign trusty/main Translation-en
Get:11 trusty-security/multiverse Sources [3,203 B]
Get:12 trusty-security/main amd64 Packages [594 kB]
Get:13 trusty-updates/restricted Sources [5,911 B]
Get:14 trusty-updates/universe Sources [175 kB]
Get:15 trusty-updates/multiverse Sources [7,513 B]
Get:16 trusty-updates/main amd64 Packages [963 kB]
Get:17 trusty-security/restricted amd64 Packages [13.4 kB]
Get:18 trusty-updates/restricted amd64 Packages [16.4 kB]
Get:19 trusty-security/universe amd64 Packages [154 kB]
Get:20 trusty-updates/universe amd64 Packages [402 kB]
Get:21 trusty-security/multiverse amd64 Packages [4,143 B]
Get:22 trusty-security/main i386 Packages [553 kB]
Get:23 trusty-updates/multiverse amd64 Packages [14.0 kB]
Get:24 trusty-updates/main i386 Packages [924 kB]
Get:25 trusty-updates/restricted i386 Packages [16.2 kB]
Get:26 trusty-updates/universe i386 Packages [403 kB]
Get:27 trusty-security/restricted i386 Packages [13.1 kB]
Get:28 trusty-security/universe i386 Packages [155 kB]
Get:29 trusty-updates/multiverse i386 Packages [14.4 kB]
Get:30 trusty-updates/main Translation-en [474 kB]
Get:31 trusty-security/multiverse i386 Packages [4,292 B]
Get:32 trusty-security/main Translation-en [325 kB]
Get:33 trusty-updates/multiverse Translation-en [7,340 B]
Get:34 trusty-updates/restricted Translation-en [3,847 B]
Get:35 trusty-updates/universe Translation-en [212 kB]
Get:36 trusty-backports/main Sources [9,712 B]
Get:37 trusty-backports/restricted Sources [28 B]
Get:38 trusty-backports/universe Sources [35.3 kB]
Get:39 trusty-backports/multiverse Sources [1,898 B]
Get:40 trusty-backports/main amd64 Packages [13.3 kB]
Get:41 trusty-security/multiverse Translation-en [2,201 B]
Get:42 trusty-backports/restricted amd64 Packages [28 B]
Get:43 trusty-backports/universe amd64 Packages [43.2 kB]
Get:44 trusty-security/restricted Translation-en [3,357 B]
Get:45 trusty-backports/multiverse amd64 Packages [1,571 B]
Get:46 trusty-backports/main i386 Packages [13.3 kB]
Get:47 trusty-security/universe Translation-en [90.2 kB]
Get:48 trusty-backports/restricted i386 Packages [28 B]
Get:49 trusty-backports/universe i386 Packages [43.2 kB]
Get:50 trusty-backports/multiverse i386 Packages [1,552 B]
Get:51 trusty-backports/main Translation-en [7,503 B]
Get:52 trusty-backports/multiverse Translation-en [1,215 B]
Get:53 trusty-backports/restricted Translation-en [28 B]
Get:54 trusty-backports/universe Translation-en [36.8 kB]
Hit trusty Release
Ign trusty Release
Ign trusty/main Sources/DiffIndex
Ign trusty/restricted Sources/DiffIndex
Ign trusty/universe Sources/DiffIndex
Ign trusty/multiverse Sources/DiffIndex
Ign trusty/main amd64 Packages/DiffIndex
Ign trusty/restricted amd64 Packages/DiffIndex
Ign trusty/universe amd64 Packages/DiffIndex
Ign trusty/multiverse amd64 Packages/DiffIndex
Ign trusty/main i386 Packages/DiffIndex
Ign trusty/restricted i386 Packages/DiffIndex
Ign trusty/universe i386 Packages/DiffIndex
Ign trusty/multiverse i386 Packages/DiffIndex
Hit trusty/main Translation-en_GB
Hit trusty/main Translation-en
Hit trusty/multiverse Translation-en_GB
Hit trusty/multiverse Translation-en
Hit trusty/restricted Translation-en_GB
Hit trusty/restricted Translation-en
Hit trusty/universe Translation-en_GB
Hit trusty/universe Translation-en
Get:55 trusty/main Sources [1,064 kB]
Get:56 trusty/restricted Sources [5,433 B]
Get:57 trusty/universe Sources [6,399 kB]
Get:58 trusty/multiverse Sources [174 kB]
Get:59 trusty/main amd64 Packages [1,350 kB]
Get:60 trusty/restricted amd64 Packages [13.0 kB]
Get:61 trusty/universe amd64 Packages [5,859 kB]
Get:62 trusty/multiverse amd64 Packages [132 kB]
Get:63 trusty/main i386 Packages [1,348 kB]
Get:64 trusty/restricted i386 Packages [13.4 kB]
Get:65 trusty/universe i386 Packages [5,866 kB]
Get:66 trusty/multiverse i386 Packages [134 kB]
Fetched 28.9 MB in 58s (493 kB/s)
Reading package lists… Error!
W: GPG error: trusty Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 4DF9B28CA252A784
W: GPG error: trusty Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.
sim@sim-flaptop ~ $

??? any idea please ??? TIA

Does running:

sudo apt-key adv --keyserver --recv-keys 40976EAF437D05B5


sudo apt-key adv --keyserver --recv-keys 4DF9B28CA252A784


sudo mv -v /var/lib/apt/lists /var/lib/apt/lists-broken


sudo mkdir -p /var/lib/apt/lists/partial


sudo apt-get update

fix the issue ?

Hi mark, and Thanks for the reply :slight_smile:

EDIT:- I didn’t see your entire post - I’ll “do” the rest of the commands and come back to you. Sorry :-[


Well, it worked !! Thanks ever so much Mark. You’re a star :slight_smile:

triggered 138 Mb of updates too !

Of course I’ll spare you the details of how I typed in less than half of the commands and “all hell broke loose” … and how I felt a complete plonker when I scrolled down and saw the rest of your post ::slight_smile: - I mean, honestly I just can’t get the “staff” … oh, er…, wait… yeah - I am the “staff” ::slight_smile: ::slight_smile: ::slight_smile: ;D ;D

Thanks again :slight_smile:

I’ll mark this as solved :slight_smile:

You’re most welcome Sim :slight_smile:

BTW, it wasn’t necessarily you missing the commands … I added the last 3 as an edit, probably after you’d first seen the post.

Ah!! No worries - Thought I was losing the plot !!

Any idea what caused this? ( and does it matter ??! )

thanks again for your help.

No idea mate … a case of “sh*t happens” I guess.