Netbook lost volume

My Samsung NC10 has lost its volume. :frowning:

It has a valid Volume active applet and volume is on max and not ticked to mute. I have tried it with youtube, and every format I have including music MP3…nothing…at all.

Samsung NC 10 using Ubuntu 10.04

You haven’t been messing with the sound device in sound settings have you ?

Nothing unticked in alsamixer ?

Maybe time to consider a change to something like Peppermint ?

I do not know what alsamixer is and I have not messed with the settings. My only beef with putting on another distro is I have a nice setup with all my programs I like and Ubuntu 10.04 has a low resource demand. what would you suggest about which distro of Peppermint to use? I only have 1gb of ram the netbook is dual boot so I do not want to install on the wrong partition.


PS Have you got your broadband yet?

Yup, I’ve got broadband back … thank god, and thanks for asking :slight_smile:

alsamixer is a command line mixer for ALSA (Advanced Linux Sound Architecture), believe it or not :wink:

PeppermintOS (Two) is actually less resource hungry than 10.04 as it uses the LXDE desktop (which is why I love and recommend it on low resource systems) … it runs on an Acer Aspire One netbook perfectly, and the AA1 has less RAM than your NC10 (only 500mb) and the same CPU (Atom N270) … that said, if you’re happy with 10.04 lets try to fix that … PeppermintOS (Two) is based on Ubuntu 11.04 so support is likely to run out before support for 10.04 does (10.04 being an LTS release), but I would guess there will be a new version of Peppermint out before then.

Anywho … troubleshooting …

Did the sound stop working after installing anything, or after running a system update ?

Here’s the standard test for sound - with the volume on MAX and unmuted, open a terminal and enter:

aplay /usr/share/sounds/alsa/Front_Center.wav

hit enter … did you hear anything ?

Try creating a new user account … does sound work if you log on as the new user ?

What is the output from:

sudo aplay -l

Do you get a long listing of .ko files when you run:

find /lib/modules/`uname -r` | grep snd

What is the output from:

lspci -v | grep -A7 -i "audio"

Still no volume.

Here is the output from the first request

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

There are no .ko files

laptop:/$ find /lib/modules/uname -r | grep snd

And finally

laptop:/$ lspci -v | grep -A7 -i “audio”

I may consider Mint. I have this netbook as a dual boot but do not know why. I have not used Windoze on this since…I can’t remember.

Ok just booted into Windows partition ( now I need a shower ;)). No sound! Must be a fault on my netbook :-[

I have two possible conclusions here.

A) Your laptop speaks have popped from either being played loud for long periods of time, or something has been spilled on them. (Listen for the distorted sound. Wait you can’t… XD)

B) The wires connecting the speakers have melted, from a large burst of currents in the wires and lots of heat.

If you have headphones, test to see if the work in the jack sockets. If you get sound your sound card is dead yet.

First, check you haven’t somehow disabled the sound card in the BIOS.


lspci -v | grep -A7 -i "audio"

returned nothing … your sound hardware isn’t being seen by the OS

Also, are you SURE that:

find /lib/modules/`uname -r` | grep snd

returned nothing ?

If nothing is returned by the above command, run:

sudo apt-get install --reinstall linux-generic

Once that’s finished, REBOOT.

Now see if your sound works … if not, check that alsamixer is installed:


did alsamixer start ?

If so (in alsamixer), make sure “PCM” and “Front” are unmuted.

If not run:

sudo apt-get install alsa-utils gnome-alsamixer

REBOOT and test again.

Let me know how you get on.

Re-instaled the mixer as per Mark’s instructions, went into properties and found that the Analogue headphone was checked (no idea why!) Unchecked and hey presto!

Thanks Mark. :slight_smile: I still may upgrade to Peppermint as there are a few niggles that keep arising lately.

Let me know if you do, because I’m interested in peoples opinion of Peppermint as an every day workhorse … specially in comparison to Ubuntu/Mint.

Yes I will let you know Mark. I’m will be moving over to Peppermint on this Netbook and deleting the Windows partition. I will also look at Putting Peppermint onto my main laptop but I will have to keep the Windows partition on that as some of my photography programs will not work with Wine and 'The Gimp along with others has not kept up…yet!

What would be the best version of Peppermint for my netbook? Samsung NC10 1gb ram
also my Toshiba Equium 2gb ram?


If you’re talking about compatibility, I can’t say for sure, but I’d start by trying the latest PeppermintOS (Two) … if you run into problems, we’ll attempt to sort them out :slight_smile:

Meanwhile, I’ll have a look around the interweb and see if I can find out if anyone has any info on Peppermint on an NC10.

As PeppermintOS (Two) is based on Ubuntu 11.04 I doubt if there will be many problems, and if they’re fixable in Ubuntu, they’ll be fixable in Peppermint :slight_smile:

Something to bear in mind is that PeppermintOS (One) and PeppermintOS (Ice) were based on Ubuntu 10.04 LTS and therefore will receive updates until 10.04’s end of life (April 2013) … whereas PeppermintOS (Two) will only receive updates until 11.04’s end of life (Oct 2012) … Though I’m guessing that PeppermintOS (Three) will be out by then and will probably be based on Ubuntu 12.04, which as a Long Term Support (LTS) release will be supported for 3 years.

Ubuntu Release (and life) Cycle