Network share permissions (SOLVED)

Hi guys

I have a NAS connected to my network with 8 shared directories each mounted in fstab with full permissions which looks correct

See here

[spoiler]

# /etc/fstab: static file system information. # # Use 'blkid' to print the universally unique identifier for a # device; this may be used with UUID= as a more robust way to name devices # that works even if disks are added and removed. See fstab(5). # # # / was on /dev/sda5 during installation UUID=dfea22b1-7019-49bc-a5e2-5d740a33c257 / ext4 errors=remount-ro 0 1 # swap was on /dev/sda6 during installation UUID=92b14a2c-05b9-4119-b83d-41cb617bc529 none swap sw 0 0 # NAS shares //192.168.2.50/family-tree /mnt/NAS/family-tree cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0 //192.168.2.50/graeme /mnt/NAS/graeme cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0 //192.168.2.50/pat /mnt/NAS/pat cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0 //192.168.2.50/multimedia /mnt/NAS/multimedia cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0 //192.168.2.50/movies /mnt/NAS/movies cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0 //192.168.2.50/backups /mnt/NAS/backups cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0 //192.168.2.50/utilities /mnt/NAS/utilities cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0 //192.168.2.50/videos /mnt/NAS/videos cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0
[/spoiler]

the problem is if I want to write to any of these directories I’m told i don’t have permissions ie if i try to copy/paste a folder with images files it will copy the folder but not the contents but i can copy over everything if I “Open as root”, the thing is I don’t know if the problem is how the shares are set up in the NAS or if the problem is with the PC settings but I’ve set up the the shares in the NAS for full access or at least I think I have

http://imgur.com/2NB8eOD

from the screenshot it looks like the problem is obvious as the recursive checkbox isn’t ticked but believe me I’ve ticked that box a thousand times and applied it but each time I close it and reopen it the tick is gone so does that mean it isn’t recursive ? if so then I don’t have a clue how to make it recursive or if i can solve the problem at the PC end by changing something in /etc/fstab.

This maybe an issue I need to take to the OMV forums but I’m hoping there’s a simple solution and i can sort it out here

any help would be much appreciated

Graeme

Ok after months of trying to solve the problem and typing that long post i finally found the solution

There’s a setting in the Shares dialogue that says

Honor existing ACLs (This parameter can be used to ensure that if default acls exist on parent directories, they are always honored when creating a new file or subdirectory in these parent directories).

I’ve done this for each share and it’s working fine now

ticking that checkbox has fixed the problem

Sorry for time wasting

Graeme

Not a time waste, could be useful for someone in the future :slight_smile:
Mark it as solved though (even if you did solve it yourself!)

Cool … nice find, in what looks lke a million settings :o

yeah there is a million settings but I think the art is knowing what they mean and what they’re likely to do, a lot of the time for me it’s just trial and error and hope for the best, but it’s all part of the learning process I suppose

Anyway I’ll mark it solved

Many thanks

Graeme

Hint -

If you go to your IMGUR link:
http://imgur.com/2NB8eOD
then underneath the image, click the “Get embedded codes” link

then underneath the links that appear on the right, click the “Large thumbnail” link

then copy what’s in the “Linked BBcode (message boards)” field

[URL=http://imgur.com/2NB8eOD]
http://i.imgur.com/2NB8eODl.png
[/URL]

and copy it here.

You get an image that can be clicked to take you to the full sized image … as below:-

(Click image to see original on IMGUR)

http://i.imgur.com/2NB8eODl.png