Networking Two Sumvision Mkv Enclosures on the same network

Hi to all I’m new here so please be gentle.
I have two Sumvision media player enclosures with Samba installed (clones of Mvix and traxdata).
When i switch either of them on they announce themselves to the network (on Win 7 PC)as ‘Venus’ they both have fixed (different) IP addresses.
The problem is when they are both on only the one that connected to the network first is visible, the only way to see the other one is to switch both off start the other one and restart the Win 7 machine.
I have copies of the firmware old and the latest for Sumvision/Mvix Ultio/Traxdata.
I think that i need to go in via Telnet and some how change the log on name, I do not have a clue how to do this.
Any help would be greatly appreciated
Best regards
Thanks for reading
Andy

Is this the same as the Cyclone ?

See page 21 of this pdf for how to change the hostname:
http://www.sumvision.com.cn/ProductManuals/Cyclone%20LiVE%20Manual%20(V2.1).pdf

When i switch either of them on they announce themselves to the network (on Win 7 PC)as 'Venus' they both have fixed (different) IP addresses.

I take it that both machines are using the ‘Venus’ host name, but with different fixed IP addresses.
The easiest would be to give different host names to each of the machines.

Hi
Yes there are both named Venus the problem I’m asking about is how to change the host name i can not figure it out.
I’m sure it can be done via telnet but I do not know where to start.
Any guidance would be appreciated
Cheers
Andy

Hi
It is similar but not exactly the same. I have read the PDF that you kindly pointed too but cannot see anything about changing host name, I have also read the PDF about the actual machine I have and again can find no reference to host name change.
Thanks so far
Andy

Well in most Linux distros the hostname would be defined in

/etc/hostname

But I can’t guarantee that would be the case in the Sumvision.

Somewhere to start looking though I suppose.

If it has a hosts file you may also need to edit that … see here:
http://linuxforums.org.uk/index.php?topic=3832.msg27792#msg27792

I logged in via telnet and got the following response

Venus login: root
warning: cannot change to home directory

BusyBox v1.1.3 (2009.12.18-04:22+0000) Built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

/ # /etc/hostname
-sh: /etc/hostname: Permission denied
/ # /etc/hostname
-sh: /etc/hostname: Permission denied
/ #

Rely not sure were to go now
Help :frowning:
Andy

Once you’re logged in and at the Busybox prompt…

what’s trhe output from

ls /etc

and

cat /etc/hostname.conf

Hi Mark
here is the output from the Busybox prompt as requested

Venus login: root
warning: cannot change to home directory

BusyBox v1.1.3 (2009.12.18-04:22+0000) Built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

/ # ls /etc
dvdplayer init.d ppscdn_config.ini
fstab ld.so.cache profile
group ld.so.conf reexec_init
hostname mtab resolv.conf
hosts passwd services
httpd.conf passwd- system_svn_version
inetd.conf ppp udhcpc.script
/ # cat /etc/hostname.conf
cat: /etc/hostname.conf: No such file or directory
/ #

Thanks again
Andy

What’s the output from:

cat /etc/hostname

and

cat /etc/hosts

[EDIT]

Just a thought, but have the 2 sumvisions got static IP addresses ? … if so, what are they ?

If not, is there a way to give them static IP’s ?

Hi yes they both have static IP addresses which are

192.168.1.75
192.168.1.69
Andy

You know when you open a file manager (explorer) window in Win7 … there’s the address bar at the top ?

click in that address bar and enter
[b]\192.168.1.75[/b]
and hit enter

Can you see the shares on that sumvision ?

if so … try the same with the other IP

Effectively you’re connecting by IP rather than hostname

When you connect by hostname it would probably have read
\venus\

When I do that to either/both the IP address it does not show the shares it shows the built in torrent function and you can see both at the same time.
That can only be done when you are using Firefox/IE, the windows network facility shows icons for all connected items but does not show an address bar.
Andy

Turn just one of them on … navigate to the shares the way you normally would … click in the file-explorer (NOT a web browser) address bar so it turns to something like

\venus\sharename

and post back here exactly what the address is ?

really what you want to do is just replace “venus” with the IP


There IS an address bar in explorer … it’s to the left of the “Search Computer” box in this screenshot
(at the top of the window)

in the above screenshot it says

Computer

but if you click in there, it will change to the actual address … such as
c:\

just edit it so it says
\192.168.1.75
and hit enter

or
\192.168.1.75<sharename>
Where is the actual name of the shared directory if one’s necessary.

Hi Mark
sorry that i keep disappearing I a postie and work very awkward hours at the moment last night 02.00 to 14.00 so i can only look when i get home.

I tried what you suggested and got this when it tried edit address

\Venus\hdd

If I replace venus with 192.168.1.75

e.g
\192.168.1.75\hdd and then hit return it does not stick it just goes back to \venus\hdd after you navigate away and then back.

I’m not sure this will solve my problem if this was to stick, I think it would only be seen on the one win7 machine I’m working on not on the whole network. I believe I need to change the hostname stored on the sumvision.
Thanks again
Andy

OK, first we’ll need to check you have root access to the sumvision(s)

do you know how to use the vi editor ?

and don’t blame me if you brick one of them :wink:

I think have root access, I log into root I do not need a password good job because I do not know what it is.

I’m not sure about vi editor but willing to learn

I do have a third one that has faulty usb socket going to get it out does not matter if I brick it.
Thanks Andy

Busybox has a built in command for getting / setting the hostname.
You could try (when on command prompt)

hostname

This should return Venus so now do:

hostname Venus2

To set the hostname to Venus2 (or anything else)

Trying SeZo’s suggestion on the faulty one sounds like a plan :slight_smile:

Started to try your suggestion,
Found out 16 year old daughter was watching a film have to try again tomorrow after work
as SHMO’2 got a bit upset.
Cheers till then
Andy