New HP455 Only Prints via USB - No WiFi [SOLVED]

Hello printer problems, again :cry:

My new HP455 (Mint 17.3 Rosa) talks to the Canon Pixma 6100 via the USB and prints without a hitch, however, I can’t get it to detect the printer wirelessly. Any ideas please?

Where did you get the drivers ?

From you on a previous thread when you helped sort out the same problem I had with my old MSI. 17.6.14 - ’ Canon Pixma MG6150 doesn’t want to talk to Mint 17 mate! ’ ;D

Are the drivers unique to each computer?

No, but they may be to each printer … is this a 6100 or a 6150 ?

and what’s the output from:

uname -a

It’s an MG6150 and the output is:

graham@graham-HP-ProBook-455-G2 ~ $ uname -a
Linux graham-HP-ProBook-455-G2 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
graham@graham-HP-ProBook-455-G2 ~ $

So if you go to

Printers > Add > Network Printer > Find Network Printers

it’s not discovered ?

In ‘Printers - Local Host’ there are 2 icons, one titled ‘Canon MG6100-series’ the other, ’ MG6100 usb’. No mention of any wireless connection. I suppose these were detected when the printer was plugged into the computer.

On clicking ‘Find Printer’ the following list appears:
Internet printing protocol (ipps)
AppSocket/HP jetDirect
Internet Printing Protocol (ipp)
‘’ ‘’ (https}
‘’ ‘’ (ipp14)
LPD/LPR Host or Printer
Windows Printer via SAMBA

Not possible to connect via wifi, Mark?

No matter, this Canon has always been a bit of a problem - [a bit of a loose cannon you might say, sorry :frowning: ! ]

When the time comes i shall buy a compatible HP printer. Anyway thanks for trying.

ahead, I think this is possible but Mark might be a bit busy. I see Drivers for it so don’t see why you won’t be able to get it going.

I know, he’s been fantastic at sorting out my problems. TBH I am beginning to feel really guilty for bleating for help every 6 hours! The help I’ve had off him and others on this great forum is greatly appreciated…

As far as I can see all the drivers are in place but try as I do I just cannot get this computer to detect the printer. As a matter of fact the USB connection now seems to have gone tits up - >:(

Sorry I will get round to this as soon as I can, just sorting a few problems out with Peppermint development … hopefully later tonight.

OK, open a terminal and run these commands in sequence:

mkdir ~/canon-printer-drivers

then

cd ~/canon-printer-drivers

then

wget http://files.canon-europe.com/files/soft40261/Software/MG6100series-printer_driver.tar

then

tar xvf MG6100series-printer_driver.tar

then

tar xvf cnijfilter-mg6100series-3.40-1-deb.tar.gz

then

cd ~/canon-printer-drivers/cnijfilter-mg6100series-3.40-1-deb

then

sudo ./install.sh

at some point it should ask you if you want to connect “via network” or “via USB” … select “via network”


for my reference:
http://linuxforums.org.uk/index.php?topic=11902.0

Hello Mark, Terminal comes back with message:

‘Could not detect target printer’. Printer is switched on and WiFi light is on.

and was it switched on at the time ?

are you sure wireless is enabled on the printer ? … and that it’s set to get it’s IP from the oruter via DHCP … and that the printer is connected to the router with the correct password ?

have you given this printer a static IP by any chance ? … and if so, was it on this network (same router) at the time ?

Mark. thank you, again! working perfectly. I set up the printer again with the router that has sorted it.

Great to hear you’re all sorted … and you’re most welcome :slight_smile:
(thanks for marking the topic solved)