new to *linux

hi, i need some help

all my life ive using windows, i know it inside and out, i know every little detail about it,

but, its not doing it for me on a netbook,

so, i really am new to it, never used one, but planning to install on my netbook

i got this netbook for £50, its the acer aspire one, after a good clean and added 1gb of ram, im ready to go

but i dont have a clue about linux, im a php coder, so i need notepad and some kind of local host, (im guessing lampp?)

i have some memory sticks and some other stuff, now would i go about installing linux and running it, and what would you say the best linux build is?

Ok, try this page out for a start; AspireOne - Community Help Wiki

Which Distro is “best” is always debatable, however which distro will provide you with the most / best support is becoming a little more clear cut … :slight_smile:

You will find help/support much easier to come by for either Ubuntu, Ubuntu Netbook Edition, or Linux Mint.

At the moment we are suggesting that people should stick to Ubuntu 9.10 (karmic) or Linux Mint 8 (Helena)… rather than use the latest Ubuntu 10.04 or Mint 9… at least until the known issues have been ironed out.

Ubuntu 9.10 (karmic) 32bit ISO
Ubuntu 9.10 (karmic) Netbook Remix ISO
Linux Mint 8 (Helena) Main Edition ISO

Download the ISO image of whichever distribution you decide to go with from one of the links above, and then for ease of installation follow the instructions on one of these pages to create a LiveUSB stick for installation/testing.

And just in case you want a tutorial on installing LAMP in Ubuntu/Mint (Mint 8 is based on Ubuntu 9.10, so any help/tutorials will work for both):

If you must have notepad, install WINE, it comes with notepad, but you would be better off with gedit (default text editor in Ubuntu and Mint) or any number of other Linux text editors:
Linux Alternatives to Windows Software

As much as I personally do not like it, I too would recommend Ubuntu or Mint.

Mmm, my feelings exactly … :slight_smile:

I think in summary, the “better” stuff takes a lot more effort and technical expertise … Ubuntu is certainly the easiest to use and provides the best support, certainly at a ‘normal’ desktop level …

i installed 10.04, i had a look around, got used to the keys and that, where everyhing is, started to customize it,

i think i typed something into terminal, and totally f***ed it, im not going to try fixing, ill just reinstalled 9.XX, you all say so, so i am as well while it needs fixing,

the mic worked, the webcam worked, everything did, except my wireless dongle, its a 3 wireless dongle,

if anyone can help me with the wireless dongle, my m8 has one, ubunt with a 3 dongle, he just plugged in, diddent work, a few days later it started to work,

so, any help with that would be great :slight_smile:

~~
JMYEOM

I’ve found that some models of 3g dongles can be a bit awkward, and need to be unplugged and replugged a few times before they switch between CD and 3g Modem modes… sometimes right-clicking on the desktop icon and selecting “Eject” helps.

If you have problems with it after installing 9.10, post back and we’ll try to help.

Meanwhile you might want to take a look at this:
http://old.linux.co.uk//docs/center/how-to/recommended-3g-netbook-solution
Starting at Step 11

Ooooh!.. You just knew as a Mint user I’d have to disagree with that. :wink:

And you knew I’d just have to come back with “but MINT is just Ubuntu in a green wrapper!” :wink:

got version 9.XX (forgot the version, the link you gave me)

the proplems is still here, i know nothing of linux, so sending me to places with loads of info is not helping,

also, i have no internet connection, so telling me to dl something and run it is proving hard, i need a rundown on what to do,

thanks for you help, and sorry to be a pain

~~
JMYEOM

Mmm, I’m afraid you’re going to find it very slow going without an Internet connection … (!)

I’m not even sure exactly what your problem IS ?.. Ubuntu Installation, LAMP Installation, wireless or 3g dongle?

If we’re talking about a 3g dongle (and it’s on the 3 network)…

1.) Insert your modem into your Netbook … it should pop up a “New 3G Broadband” window … select the options you need and click next until the configuration is complete. Note that if you have a PIN set on your SIM card (which you REALLY should!) it will ask you for this when you come to connect… Continue from step 2

If nothing pops up, right click the “network Manager” icon in the system tray by your clock, and select “Edit Connections”, click the “Mobile Broadband” tab, click “Add”, select your device from the drop-down menu, click “Forward”, select “Britain (UK)”, click “Forward”, select “3”, click “Forward”, select “Internet” as your Plan and “3internet” as your APN, click “Forward”, click “Apply”… now in the window that opened… Continue from step 4.

2.) Now, before you try to connect (!) you will need to change a few settings … if you right click on the network manager icon in your tooltray (top right) and select Edit connections, the network connections box should appear.

3.) Now click on the Mobile Broadband tab, highlight “3” (or whatever you decided to call your connection when it was auto-added) and click on Edit. Note in the example below I called the connection “Three” rather than “3”.

4.) You should now see the screen shown below … make sure you enter your PIN if there is one set up on your SIM card.
Next you will need to click on the “PPP Settings”, this stage in particular is CRITICAL as to an extent, everything else we’ve done so far is common sense, whereas this is a show stopper unless you know it needs to be changed.

5.) You should now see the second screen as shown in the screenshots at the bottom of this post. First you need to limit the authentication methods to PAP, this is done by clicking on the ‘Configure Methods’ button and unticking the other unwanted methods.

6.) Next you need to turn off compression, in particular leaving boxes here ticked it likely to prevent the system from establishing a PPP connection with Three’s servers, so although you will see a nice clean blue 3G light on your modem, it won’t actually produce a working connection.

7.) Click on Apply and we should be ready to attempt a connection.

8.) Right click on the Network Manager icon in the tooltray and “3” should be listed under the connection name you chose. Select this option.

9.) Connecting will probably take around about a minute assuming it’s working properly.

[smg type=full id=682]

Troubleshooting

a) I’ve waited a minute but I still see a green flashing light and have no connection
- Check you’re actually within range of 3’s 3G service
- Check your PIN setting / make sure it’s clear if you have no PIN

b) I’ve waited a minute and have a blue 3G light, but no connection
- You’ve connected to 3, but PPP failed, so check you’ve turned of your compression settings.

c) I have a connection, but want to disconnection and clicking disconnect on the tooltray item doesn’t work
- yup, bug. Just pull the USB modem from it’s socket, works every time. :wink:

d) It worked once, but now when I try to reconnect it sits there
- it can get confused, try removing the modem, then reboot the netbook

i have tried that

done all that, and does nothing, just says disconnected when i try to connect

Has a 3internet Icon appeared on your desktop?.. if so, try right-clicking it and selecting “Eject”… then try to connect.

If that doesn’t work, unplug the dongle, wait 10 secs and replug it, open a terminal and enter:

lsusb

hit enter, and post back the results

files & folders > volumes
right click eject… nothing, no connection

lsusb

bus 1 device 1 :linux 2.0 root hub
bus 2-5 device 1 :linuz 1.1 root hub
bus 1 device 2 :webcam
bus 1 device 6 :Huawei Technologies co., Ltd. E620 USB Modem

You left out the bit I needed… the ID string for the Huawei modem… similar to this ID 12d1:1001

But as it’s mentioning E620 modem, I’m guessing it has switched to “modem” mode (can’t be sure without the ID string)

If this is the case, It should be working, so recheck your settings in network manager.

if you look at the pictures, i have it just like that, except this:

in the username box, it says three, if i dont have it in, it disconnects me without even thinking about it,
if i put it on “three”, my signal bar goes mad, does some sort of round loading thing, going that fast i cant tell what way its ment to be going…
i let this run how it is, left it, went for a cig, came back around 5 minutes later, nothing, still doing it
i was able to hover over it and it said something, but i cant remembers, ill edit this post with that info
ill also edit with the info from lsusb, ill do a copy and paste job

edit:
here is the info
http://img137.imageshack.us/img137/557/screenshot5w.png

the text changes with that info and “attempting to connect”
the hewlett-packard is my memory stick, so thats fine
hope this help

Is this a PAYG 3 UK dongle?.. if so, try this… go into the network manager and try changing the APN to three.co.uk

Right-Click the Network Manager icon by your clock… select Edit Connections… click the Mobile Broadband tab… highlight the connection and select Edit… change the APN: from 3internet to three.co.uk… click Apply… click Close.

Now try connecting.

same results, without putting “three” as username, it does nothing
put it as three, just makes the loader spin and say the same thing

Is there any way you can get this PC connected to the internet?.. wireless or ethernet cable?

is it s 3 UK dongle? (or orange/t-mobile/vodafone etc.)

is it PAYG or contract?

are you sure you can get a signal where you are? (has it connected from the same place in windows)