New update issue mint 13

I have the same problem in both 32bit and 64bit versions. When update manager runs I get the following warning “could not download all repository indexes” I presume that they are out of date how do I remove the out of date respository and leave the active ones in place.

Thanks in advance…

What’s the output from:

sudo apt-get update

64bit system first.

userone@office2 ~ $ sudo apt-get update
[sudo] password for userone:
Ign http://security.ubuntu.com precise-security InRelease
Ign http://ppa.launchpad.net precise InRelease
Ign http://ppa.launchpad.net precise InRelease
Hit http://packages.medibuntu.org precise InRelease
Ign http://archive.canonical.com precise InRelease
Hit http://deb.playonlinux.com precise InRelease
Get:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Ign http://download.bitdefender.com bitdefender InRelease
Hit http://ppa.launchpad.net precise Release.gpg
Ign http://archive.ubuntu.com precise InRelease
Ign http://archive.ubuntu.com precise-updates InRelease
Hit http://archive.canonical.com precise Release.gpg
Get:2 http://security.ubuntu.com precise-security Release [49.6 kB]
Hit http://download.bitdefender.com bitdefender Release.gpg
Hit http://deb.playonlinux.com precise/main amd64 Packages
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://archive.ubuntu.com precise Release.gpg
Hit http://archive.canonical.com precise Release
Hit http://packages.medibuntu.org precise/free amd64 Packages
Hit http://download.bitdefender.com bitdefender Release
Hit http://ppa.launchpad.net precise Release
Hit http://deb.playonlinux.com precise/main i386 Packages
Get:3 http://archive.ubuntu.com precise-updates Release.gpg [198 B]
Hit http://archive.canonical.com precise/partner amd64 Packages
Ign http://deb.playonlinux.com precise/main TranslationIndex
Hit http://ppa.launchpad.net precise Release
Hit http://download.bitdefender.com bitdefender/non-free Sources
Hit http://archive.ubuntu.com precise Release
Hit http://archive.canonical.com precise/partner i386 Packages
Hit http://packages.medibuntu.org precise/non-free amd64 Packages
Ign http://archive.canonical.com precise/partner TranslationIndex
Ign http://archive.getdeb.net precise-getdeb InRelease
Err http://archive.getdeb.net precise-getdeb Release.gpg
Unable to connect to archive.getdeb.net:http:
Ign http://archive.getdeb.net precise-getdeb Release
Ign http://archive.getdeb.net precise-getdeb/apps amd64 Packages/DiffIndex
Ign http://archive.getdeb.net precise-getdeb/games amd64 Packages/DiffIndex
Ign http://archive.getdeb.net precise-getdeb/apps i386 Packages/DiffIndex
Ign http://archive.getdeb.net precise-getdeb/games i386 Packages/DiffIndex
Ign http://archive.getdeb.net precise-getdeb/apps TranslationIndex
Ign http://archive.getdeb.net precise-getdeb/games TranslationIndex
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main amd64 Packages
Get:4 http://security.ubuntu.com precise-security/main amd64 Packages [208 kB]
Hit http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Err http://archive.getdeb.net precise-getdeb/apps amd64 Packages
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/games amd64 Packages
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/apps i386 Packages
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/games i386 Packages
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/apps Translation-en_GB
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/apps Translation-en
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/games Translation-en_GB
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/games Translation-en
Unable to connect to archive.getdeb.net:http:
Get:5 http://archive.ubuntu.com precise-updates Release [49.6 kB]
Hit http://download.bitdefender.com bitdefender/non-free amd64 Packages
Hit http://download.bitdefender.com bitdefender/non-free i386 Packages
Ign http://download.bitdefender.com bitdefender/non-free TranslationIndex
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main amd64 Packages
Hit http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Hit http://packages.medibuntu.org precise/free i386 Packages
Hit http://archive.ubuntu.com precise/main amd64 Packages
Hit http://archive.ubuntu.com precise/restricted amd64 Packages
Hit http://archive.ubuntu.com precise/universe amd64 Packages
Hit http://archive.ubuntu.com precise/multiverse amd64 Packages
Hit http://archive.ubuntu.com precise/main i386 Packages
Hit http://archive.ubuntu.com precise/restricted i386 Packages
Hit http://archive.ubuntu.com precise/universe i386 Packages
Hit http://archive.ubuntu.com precise/multiverse i386 Packages
Hit http://archive.ubuntu.com precise/main TranslationIndex
Hit http://archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://packages.medibuntu.org precise/non-free i386 Packages
Ign http://packages.linuxmint.com maya InRelease
Hit http://archive.ubuntu.com precise/restricted TranslationIndex
Hit http://archive.ubuntu.com precise/universe TranslationIndex
Get:6 http://archive.ubuntu.com precise-updates/main amd64 Packages [441 kB]
Ign http://packages.medibuntu.org precise/free TranslationIndex
Ign http://packages.medibuntu.org precise/non-free TranslationIndex
Ign http://archive.canonical.com precise/partner Translation-en_GB
Get:7 http://security.ubuntu.com precise-security/restricted amd64 Packages [3,969 B]
Get:8 http://security.ubuntu.com precise-security/universe amd64 Packages [58.4 kB]
Get:9 http://packages.linuxmint.com maya Release.gpg [197 B]
Ign http://archive.canonical.com precise/partner Translation-en
Get:10 http://security.ubuntu.com precise-security/multiverse amd64 Packages [2,189 B]
Get:11 http://security.ubuntu.com precise-security/main i386 Packages [215 kB]
Ign http://ppa.launchpad.net precise/main Translation-en_GB
Ign http://deb.playonlinux.com precise/main Translation-en_GB
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://download.bitdefender.com bitdefender/non-free Translation-en_GB
Ign http://deb.playonlinux.com precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en_GB
Ign http://ppa.launchpad.net precise/main Translation-en
Get:12 http://packages.linuxmint.com maya Release [17.7 kB]
Get:13 http://archive.ubuntu.com precise-updates/restricted amd64 Packages [8,366 B]
Get:14 http://archive.ubuntu.com precise-updates/universe amd64 Packages [161 kB]
Ign http://download.bitdefender.com bitdefender/non-free Translation-en
Get:15 http://security.ubuntu.com precise-security/restricted i386 Packages [3,968 B]
Get:16 http://security.ubuntu.com precise-security/universe i386 Packages [59.2 kB]
Get:17 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,388 B]
Hit http://security.ubuntu.com precise-security/main TranslationIndex
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
Hit http://security.ubuntu.com precise-security/universe TranslationIndex
Get:18 http://archive.ubuntu.com precise-updates/multiverse amd64 Packages [8,677 B]
Get:19 http://archive.ubuntu.com precise-updates/main i386 Packages [449 kB]
Hit http://security.ubuntu.com precise-security/main Translation-en
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Hit http://security.ubuntu.com precise-security/universe Translation-en
Get:20 http://archive.ubuntu.com precise-updates/restricted i386 Packages [8,374 B]
Get:21 http://archive.ubuntu.com precise-updates/universe i386 Packages [162 kB]
Get:22 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [9,661 B]
Hit http://archive.ubuntu.com precise-updates/main TranslationIndex
Hit http://archive.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://archive.ubuntu.com precise/main Translation-en_GB
Hit http://archive.ubuntu.com precise/main Translation-en
Hit http://archive.ubuntu.com precise/multiverse Translation-en_GB
Hit http://archive.ubuntu.com precise/multiverse Translation-en
Hit http://archive.ubuntu.com precise/restricted Translation-en_GB
Hit http://archive.ubuntu.com precise/restricted Translation-en
Hit http://archive.ubuntu.com precise/universe Translation-en_GB
Hit http://archive.ubuntu.com precise/universe Translation-en
Hit http://archive.ubuntu.com precise-updates/main Translation-en_GB
Hit http://archive.ubuntu.com precise-updates/main Translation-en
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en_GB
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en
Get:23 http://packages.linuxmint.com maya/main Sources [17.6 kB]
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en_GB
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://archive.ubuntu.com precise-updates/universe Translation-en_GB
Hit http://archive.ubuntu.com precise-updates/universe Translation-en
Ign http://packages.medibuntu.org precise/free Translation-en_GB
Ign http://packages.medibuntu.org precise/free Translation-en
Ign http://packages.medibuntu.org precise/non-free Translation-en_GB
Ign http://packages.medibuntu.org precise/non-free Translation-en
Get:24 http://packages.linuxmint.com maya/upstream Sources [6,099 B]
Get:25 http://packages.linuxmint.com maya/import Sources [22.5 kB]
Get:26 http://packages.linuxmint.com maya/main amd64 Packages [18.3 kB]
Get:27 http://packages.linuxmint.com maya/upstream amd64 Packages [10.6 kB]
Get:28 http://packages.linuxmint.com maya/import amd64 Packages [41.4 kB]
Get:29 http://packages.linuxmint.com maya/main i386 Packages [18.2 kB]
Get:30 http://packages.linuxmint.com maya/upstream i386 Packages [10.6 kB]
Get:31 http://packages.linuxmint.com maya/import i386 Packages [41.7 kB]
Ign http://packages.linuxmint.com maya/import TranslationIndex
Ign http://packages.linuxmint.com maya/main TranslationIndex
Ign http://packages.linuxmint.com maya/upstream TranslationIndex
Ign http://packages.linuxmint.com maya/import Translation-en_GB
Ign http://packages.linuxmint.com maya/import Translation-en
Ign http://packages.linuxmint.com maya/main Translation-en_GB
Ign http://packages.linuxmint.com maya/main Translation-en
Ign http://packages.linuxmint.com maya/upstream Translation-en_GB
Ign http://packages.linuxmint.com maya/upstream Translation-en
Fetched 2,105 kB in 7s (272 kB/s)
W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/Release.gpg Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/apps/binary-amd64/Packages Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/games/binary-amd64/Packages Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/apps/binary-i386/Packages Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/games/binary-i386/Packages Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/apps/i18n/Translation-en_GB Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/apps/i18n/Translation-en Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/games/i18n/Translation-en_GB Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/games/i18n/Translation-en Unable to connect to archive.getdeb.net:http:

E: Some index files failed to download. They have been ignored, or old ones used instead.
userone@office2 ~ $

32bit system.

usertwo@usertwo-FID2130 ~ $ sudo apt-get update
[sudo] password for usertwo:
Ign http://archive.ubuntu.com precise InRelease
Ign http://archive.ubuntu.com precise-updates InRelease
Ign http://security.ubuntu.com precise-security InRelease
Ign http://ppa.launchpad.net precise InRelease
Ign http://ppa.launchpad.net precise InRelease
Hit http://archive.ubuntu.com precise Release.gpg
Get:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Ign http://www.mirrorservice.org maya InRelease
Ign http://archive.canonical.com precise InRelease
Hit http://ppa.launchpad.net precise Release.gpg
Get:2 http://archive.ubuntu.com precise-updates Release.gpg [198 B]
Get:3 http://security.ubuntu.com precise-security Release [49.6 kB]
Hit http://packages.medibuntu.org precise InRelease
Hit http://www.mirrorservice.org maya Release.gpg
Hit http://archive.ubuntu.com precise Release
Hit http://archive.canonical.com precise Release.gpg
Hit http://ppa.launchpad.net precise Release.gpg
Get:4 http://archive.ubuntu.com precise-updates Release [49.6 kB]
Hit http://www.mirrorservice.org maya Release
Hit http://ppa.launchpad.net precise Release
Hit http://archive.canonical.com precise Release
Hit http://ppa.launchpad.net precise Release
Ign http://archive.getdeb.net precise-getdeb InRelease
Err http://archive.getdeb.net precise-getdeb Release.gpg
Unable to connect to archive.getdeb.net:http:
Ign http://archive.getdeb.net precise-getdeb Release
Ign http://archive.getdeb.net precise-getdeb/apps i386 Packages/DiffIndex
Ign http://archive.getdeb.net precise-getdeb/games i386 Packages/DiffIndex
Ign http://archive.getdeb.net precise-getdeb/apps TranslationIndex
Ign http://archive.getdeb.net precise-getdeb/games TranslationIndex
Err http://archive.getdeb.net precise-getdeb/apps i386 Packages
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/games i386 Packages
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/apps Translation-en_US
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/apps Translation-en
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/games Translation-en_US
Unable to connect to archive.getdeb.net:http:
Err http://archive.getdeb.net precise-getdeb/games Translation-en
Unable to connect to archive.getdeb.net:http:
Hit http://www.mirrorservice.org maya/main Sources
Hit http://packages.medibuntu.org precise/free i386 Packages
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Get:5 http://security.ubuntu.com precise-security/main i386 Packages [215 kB]
Hit http://www.mirrorservice.org maya/upstream Sources
Hit http://www.mirrorservice.org maya/import Sources
Hit http://www.mirrorservice.org maya/backport Sources
Hit http://www.mirrorservice.org maya/main i386 Packages
Hit http://www.mirrorservice.org maya/upstream i386 Packages
Hit http://www.mirrorservice.org maya/import i386 Packages
Hit http://www.mirrorservice.org maya/backport i386 Packages
Hit http://archive.canonical.com precise/partner i386 Packages
Hit http://archive.ubuntu.com precise/main i386 Packages
Hit http://archive.ubuntu.com precise/restricted i386 Packages
Hit http://archive.ubuntu.com precise/universe i386 Packages
Hit http://archive.ubuntu.com precise/multiverse i386 Packages
Hit http://archive.ubuntu.com precise/main TranslationIndex
Hit http://archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://archive.ubuntu.com precise/restricted TranslationIndex
Hit http://archive.ubuntu.com precise/universe TranslationIndex
Ign http://www.mirrorservice.org maya/backport TranslationIndex
Ign http://www.mirrorservice.org maya/import TranslationIndex
Ign http://www.mirrorservice.org maya/main TranslationIndex
Ign http://www.mirrorservice.org maya/upstream TranslationIndex
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Hit http://packages.medibuntu.org precise/non-free i386 Packages
Get:6 http://archive.ubuntu.com precise-updates/main i386 Packages [449 kB]
Ign http://archive.canonical.com precise/partner TranslationIndex
Ign http://packages.medibuntu.org precise/free TranslationIndex
Ign http://packages.medibuntu.org precise/non-free TranslationIndex
Get:7 http://security.ubuntu.com precise-security/restricted i386 Packages [3,968 B]
Get:8 http://security.ubuntu.com precise-security/universe i386 Packages [59.2 kB]
Ign http://ppa.launchpad.net precise/main Translation-en_US
Get:9 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,388 B]
Hit http://security.ubuntu.com precise-security/main TranslationIndex
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
Hit http://security.ubuntu.com precise-security/universe TranslationIndex
Ign http://ppa.launchpad.net precise/main Translation-en
Hit http://security.ubuntu.com precise-security/main Translation-en
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en_US
Ign http://ppa.launchpad.net precise/main Translation-en
Hit http://security.ubuntu.com precise-security/universe Translation-en
Get:10 http://archive.ubuntu.com precise-updates/restricted i386 Packages [8,374 B]
Ign http://archive.canonical.com precise/partner Translation-en_US
Get:11 http://archive.ubuntu.com precise-updates/universe i386 Packages [162 kB]
Ign http://archive.canonical.com precise/partner Translation-en
Ign http://www.mirrorservice.org maya/backport Translation-en_US
Ign http://www.mirrorservice.org maya/backport Translation-en
Ign http://www.mirrorservice.org maya/import Translation-en_US
Get:12 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [9,661 B]
Hit http://archive.ubuntu.com precise-updates/main TranslationIndex
Hit http://archive.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://archive.ubuntu.com precise/main Translation-en
Hit http://archive.ubuntu.com precise/multiverse Translation-en
Hit http://archive.ubuntu.com precise/restricted Translation-en
Hit http://archive.ubuntu.com precise/universe Translation-en
Ign http://www.mirrorservice.org maya/import Translation-en
Ign http://www.mirrorservice.org maya/main Translation-en_US
Ign http://www.mirrorservice.org maya/main Translation-en
Hit http://archive.ubuntu.com precise-updates/main Translation-en
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://archive.ubuntu.com precise-updates/universe Translation-en
Ign http://www.mirrorservice.org maya/upstream Translation-en_US
Ign http://www.mirrorservice.org maya/upstream Translation-en
Ign http://packages.medibuntu.org precise/free Translation-en_US
Ign http://packages.medibuntu.org precise/free Translation-en
Ign http://packages.medibuntu.org precise/non-free Translation-en_US
Ign http://packages.medibuntu.org precise/non-free Translation-en
Fetched 1,008 kB in 1s (567 kB/s)
W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/Release.gpg Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/apps/binary-i386/Packages Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/games/binary-i386/Packages Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/apps/i18n/Translation-en_US Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/apps/i18n/Translation-en Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/games/i18n/Translation-en_US Unable to connect to archive.getdeb.net:http:

W: Failed to fetch http://archive.getdeb.net/ubuntu/dists/precise-getdeb/games/i18n/Translation-en Unable to connect to archive.getdeb.net:http:

E: Some index files failed to download. They have been ignored, or old ones used instead.
usertwo@usertwo-FID2130 ~ $

First of all DON’T PANIC

Seems the getdeb/playdeb repositories are currently down.

Probably due to this:
http://blog.getdeb.net/2012/12/server-downtime.html

Don’t worry about those errors (they’ll go away when the getdeb servers come back up) … or disable the getdeb repos for a day or two.

Keep an eye on their blog for news:

if you want.

.

Noted will see if it clears when servers are up.

Thanks.

The problem still exists with no update since December 9th on a restoration date.

If you mean getdeb … AFAIK they’re still down, what makes you think otherwise ?

.

Yes they are still down some 12 days if not more of no service to jo public, is making a big hole in the ability to update programs that are stored by them.

getdeb … AFAIK they’re still down this is makes update manager unhappy are there other places to get these updates from?

It must pose a problem if this is the only place and they have still not restored the service.

Thanks as always for members input.

There is a mirror for GetDeb and PlayDeb … but it will be frozen at the time GetDeb went down … so will not be receiving updates.

Should be fine for installing stuff though.

But why not just either ignore the messages from update manager, or disable the getdeb repos in Synaptic.

Personally that’s what I do anyway … if I need something from getdeb, I enable the repo, install what I need, then disable the repo … there is far to much stuff in the getdeb repo, so when you run an update it updates stuff you didn’t intend, so you’re slowly diverging from the “proper” main repos.


If you want instructions for adding the getdeb/playdeb mirror … see here:
http://peppermintos.net/viewtopic.php?p=31634#p31634
those instructions are for distro’s based on Ubuntu 12.04 (such as Mint 13 and Peppermint 3) … but are easily modified for other versions.
(you’d still need to disable the “real” getdeb repos if you want rid of those update manager messages)

.

As suggested have removed from my update manager.

This is a big problem for Linux as it shows unreliability to people who want to leave windows and Microsoft.

They have not kept users informed and I see some people are not going to come back.

Whilst I agree GetDeb should be putting more info on why its taking so long on their blog … I’d disagree that this is a Linux problem.

If the Adobe update site went down … would you blame Windows ?

Hell nobody blames Windows when the Windows update site goes down, simply because they don’t realise it happened … would you rather Linux behaved the same and hid the fact there was a problem from you ?

Remember, this is a software repository YOU added, it’s not a default one (which would be more of an issue) :wink:

And beyond some (granted) cryptic messages, it won’t actually do any harm.

For sure, a LOT of Windows users try Linux (on the desktop) then go back … usually because they can’t be bothered to learn it, or expected a free windows clone, which is fine … they’re Windows users that end up back with Windows which is no loss to Linux … but some stay with Linux, and that most certainly IS a loss to Windows :slight_smile:

Then there’s the fact that ALL of them are already using Linux quite happily (routers, phones, google, indeed most of the internet) … they just aren’t aware of the fact :slight_smile:

Yup, desktop Linux isn’t for everyone … it never will be … but neither is Windows or OS X or any other OS for that matter … but thank god you have the choice if/when you’re ready :slight_smile:

[EDIT]

Can I also add that anyone that jumps ship because a third party repository goes down that they themselves must have added, IMHO probably isn’t ready for Linux and the user control that comes with it just yet :wink:

That’s not a criticism … it’s just my opinion.

.

Hi I fully agree with what you say but if Linux is to be considered by equipment suppliers as worth providing drivers for then it has to work for Joe public.

The average user is not concerned with why there car has broken down but that it is not working and they haven’t a clue what’s happening under the hood.

If you installed some software that is only updated from this location you have a problem and you have not been given any info as to a solution or a time-frame to restore service.

I have built and upgraded my own Desk top computers for 20 years so I have an interest but average computer user has not.

Yes my phone uses a Linux based operating system but they do not provide interface software for Linux only Windows and Mac.

No it is not the fault of Linux but until I took an interest in replacing Windows I thought Linux was the operating system. I did not know there were lots of different versions.

My big issue is lack of info it is not customer friendly.

I love Linux and would not return to Windows.

Thanks for all the work that you do on this site.

Remember Linux was designed by enthusiasts for enthusiasts and is only now (some distros) starting to be dumbed down for the “joe average” consumer market.

Joe average would most likely stick to the default software repositories.

“User Friendly” is a matter of perspective … and greatly depends on your point of view …

There are (at least) 2 types of user friendliness

a) The Windows way … If there’s a minor problem, hide it from the user, and only show him there’s a problem when it’s a catastrophic (blue scrren) problem … when he’ll phone someone else to fix it

or

b) The Linux way … Show the user the information he needs to fix the issue for all errors … where he can decide for himself if he wants to take corrective measures, be that calling someone else or working it out himself.

To my way of thinking, Linux is more “user” friendly … Windows just hides stuff from me, and gives me no control.

Certain distros are now going down the dumbed down path … which is fine, and makes them more Windows like, if that’s the users measure of “user friendliness” all well and good … it’s just not mine.

I have no doubt update managers will appear that hide the fact that a repo is down.

But as I said, the issue with the GetDeb repo was not a Linux or a Linux distro problem … it was a third party problem that could only have occurred due to the user adding that repo … and blaming your distro or Linux as a whole is akin to blaming Microsoft when some third party software doesn’t work as expected … but at least your Linux update manager told you there was a problem and offered the info you needed to troubleshoot it, which to me is it being “user” friendly.

Personally I think Windows only appears to be user friendly because users have learned to use it … if you learn Linux, it will provide you with MUCH more information to allow you to fix issues as they occur.

That issue with the repo being down … it didn’t break your Linux distro, you could easily have ignored it and continued to use your computer … the only difference was Linux gave you an opportunity to do something about it before it (possibly) became a bigger issue, whereas Windows would have just told you nothing until you needed an engineer … I ask, which is the more “user” friendly approach ?

.

Read ths:
http://linuxforums.org.uk/index.php?topic=10652.msg80683#msg80683

GetDeb and PlayDeb are now discontinued.