No flash on my mint netbook

I am well pissed off- was prompted to update Firefox, so did so, now adobe not working. Went into package manager and chose it but still not working. It is FREEZING downstairs and wanted to watch iplayer under the duvet- please help Mark! Now I have to go sit in freezing lounge and eat my supper there and watch prog there.

Can you post the output from:

dpkg -l | grep flash

and

uname -a

arij@karij-Inspiron-1011 ~ $ dpkg -l | grep flash
iU flashplugin-downloader 11.2.202.442ubuntu0.12.04.1 Adobe Flash Player plugin installer (transitional package)
iU flashplugin-installer 11.2.202.442ubuntu0.12.04.1 Adobe Flash Player plugin installer
ii mint-flashplugin-11 11.0.1.152 Adobe Flash plugin 11
karij@karij-Inspiron-1011 ~ $ uname -a
Linux karij-Inspiron-1011 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:41:14 UTC 2012 i686 i686 i386 GNU/Linux
karij@karij-Inspiron-1011 ~ $

Checked firefox plug in page and it was deactivated- god knows why. I ticked it reebooted and it works but says its vulnerable. At least I can have my supper up here under duvet and watch it. Will be back later Mark!

OK, I think it’s picking up thee older version from mint-flashplugin-11 … run:

sudo apt-get remove --purge flashplugin-installer flashplugin-downloader mint-flashplugin-11

then

sudo apt-get install flashplugin-installer

then run:

sudo updatedb

then post the output from:

dpkg -l | grep flash

and

locate libflashplayer.so

karij@karij-Inspiron-1011 ~ $ sudo apt-get remove --purge flashplugin-installer flashplugin-downloader mint
[sudo] password for karij:
Sorry, try again.
[sudo] password for karij:
Sorry, try again.
[sudo] password for karij:
E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.
karij@karij-Inspiron-1011 ~ $ sudo apt-get install flashplugin-installer
E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.
karij@karij-Inspiron-1011 ~ $ sudo updatedb
karij@karij-Inspiron-1011 ~ $ dpkg -l | grep flash
iU flashplugin-downloader 11.2.202.442ubuntu0.12.04.1 Adobe Flash Player plugin installer (transitional package)
iU flashplugin-installer 11.2.202.442ubuntu0.12.04.1 Adobe Flash Player plugin installer
ii mint-flashplugin-11 11.0.1.152 Adobe Flash plugin 11
karij@karij-Inspiron-1011 ~ $ locate libflashplayer.so
/etc/alternatives/libflashplayer.so
/home/karij/usr/lib/flash-plugin/libflashplayer.so
/opt/mint-flashplugin-11/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
/var/lib/dpkg/alternatives/libflashplayer.so
karij@karij-Inspiron-1011 ~ $

See above for the sudo stuff! Thanks Mark- I thought too that it was still trying to recognise the older version. I had the caps on hence the p/w problem. I wish the netbook had a caps lock- I can’t tell if it’s on - no light as the laptop has.

run:

sudo dpkg --configure -a

and if that completes without errors, try the instructions in my last posting again

arij@karij-Inspiron-1011 ~ $ sudo dpkg --configure -a
[sudo] password for karij:
Processing triggers for libc-bin …
ldconfig deferred processing now taking place
Setting up libnspr4-0d (4.10.7-0ubuntu0.12.04.1) …
Setting up update-notifier-common (0.119ubuntu8.7) …

Configuration file `/etc/apt/apt.conf.d/10periodic’
==> File on system created by you or by a script.
==> File also in package provided by package maintainer.
What would you like to do about it ? Your options are:
Y or I : install the package maintainer’s version
N or O : keep your currently-installed version
D : show the differences between the versions
Z : start a shell to examine the situation
The default action is to keep your current version.
*** 10periodic (Y/I/N/O/D/Z) [default=N] ?

Type
N
then hit enter.

I am getting this message:

See attachment! Low disk space.

Have you had a look at your screenshot … it doesn’t show the message.

Oh dang! My hands are so cold I hit y by accident- sorry Mark. It’s only 40 f here… :cry:

Yeahhh…sorry it didn’t grab the message and now the disk space box vanished. Next time it pops up I will post what it says.

Yeah Y is okay too … in fact it was probably a better idea :slight_smile:

What’s the output from:

df -h

Phew…thought you were gonna tell me off for being a right doofus!

karij@karij-Inspiron-1011 ~ $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 6.5G 6.0G 224M 97% /
udev 490M 4.0K 490M 1% /dev
tmpfs 199M 940K 198M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 497M 1.6M 495M 1% /run/shm
karij@karij-Inspiron-1011 ~ $

You need to free up some space on your had drive

a) if possible move some of your saved files from your home folder off to something like a USB stick

b) empty your recycle bin

d) run these 2 commands

sudo apt-get clean

then

sudo apt-get autoremove -y

then post the output from:

df -h

again

karij@karij-Inspiron-1011 ~ $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 6.5G 6.0G 224M 97% /
udev 490M 4.0K 490M 1% /dev
tmpfs 199M 940K 198M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 497M 1.6M 495M 1% /run/shm
karij@karij-Inspiron-1011 ~ $ sudo apt-get clean
[sudo] password for karij:
karij@karij-Inspiron-1011 ~ $ sudo apt-get autoremove -y
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be REMOVED
icoutils kate-data katepart kde-runtime kde-runtime-data kdelibs-bin
kdelibs5-data kdelibs5-plugins kdoctools kubuntu-debug-installer
libattica0.3 libclucene0ldbl libdlrestrictions1 libkatepartinterfaces4
libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5
libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5
libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4
libkpty4 libkrosscore4 libktexteditor4 libkutils4 libnepomuk4
libnepomukdatamanagement4 libnepomukquery4a libnepomuksync4 libnepomukutils4
libntrack-qt4-1 libntrack0 libphonon4 libplasma3 libpolkit-qt-1-1
libqapt-runtime libqapt1 libqca2 libqt4-designer libqt4-qt3support libsolid4
libsoprano4 libstreamanalyzer0 libstreams0 libthreadweaver4 libvirtodbc0
ntrack-module-libnl-0 odbcinst odbcinst1debian2 oxygen-icon-theme phonon
phonon-backend-gstreamer plasma-scriptengine-javascript qapt-batch
shared-desktop-ontologies soprano-daemon virtuoso-minimal
virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common
0 upgraded, 0 newly installed, 73 to remove and 496 not upgraded.
After this operation, 145 MB disk space will be freed.
(Reading database … 189492 files and directories currently installed.)
Removing icoutils …
Removing kubuntu-debug-installer …
Removing qapt-batch …
Removing kde-runtime …
Removing kdelibs5-plugins …
Removing katepart …
Removing kate-data …
Removing kde-runtime-data …
Removing kdelibs-bin …
Removing kdelibs5-data …
Removing kdoctools …
Removing plasma-scriptengine-javascript …
Removing libplasma3 …
Removing libknewstuff3-4 …
Removing libkhtml5 …
Removing libkatepartinterfaces4 …
Removing libktexteditor4 …
Removing libkutils4 …
Removing libkprintutils4 …
Removing libkmediaplayer4 …
Removing libkdewebkit5 …
Removing libkde3support4 …
Removing libkparts4 …
Removing libnepomukutils4 …
Removing libnepomuksync4 …
Removing libnepomukquery4a …
Removing libnepomukdatamanagement4 …
Removing libknotifyconfig4 …
Removing libkfile4 …
Removing libkemoticons4 …
Removing libkio5 …
Removing libnepomuk4 …
Removing libkrosscore4 …
Removing libkidletime4 …
Removing libkdnssd4 …
Removing libkdeclarative5 …
Removing libkcmutils4 …
Removing libkdeui5 …
Removing libattica0.3 …
Removing libstreamanalyzer0 …
Removing libsoprano4 …
Removing libclucene0ldbl …
Removing libkdesu5 …
Removing libkpty4 …
Removing libkntlm4 …
Removing libkjsembed4 …
Removing libkjsapi4 …
Removing libkdecore5 …
Removing libdlrestrictions1 …
Removing libntrack-qt4-1 …
Removing phonon …
Removing phonon-backend-gstreamer …
Removing libphonon4 …
Removing libqapt-runtime …
Removing libpolkit-qt-1-1 …
Removing libqapt1 …
Removing libqca2 …
Removing libqt4-qt3support …
Removing libqt4-designer …
Removing libsolid4 …
Removing libstreams0 …
Removing libthreadweaver4 …
Removing virtuoso-minimal …
Removing soprano-daemon …
Removing libvirtodbc0 …
Virtuoso has been deleted (if it existed at all) because its usage count became zero
Removing oxygen-icon-theme …
Removing shared-desktop-ontologies …
Removing virtuoso-opensource-6.1-bin …
Removing virtuoso-opensource-6.1-common …
Removing odbcinst1debian2 …
Removing libntrack0 …
Removing ntrack-module-libnl-0 …
Removing odbcinst …
Processing triggers for man-db …
Processing triggers for bamfdaemon …
Rebuilding /usr/share/applications/bamf.index…
Processing triggers for gnome-menus …
Processing triggers for desktop-file-utils …
Processing triggers for libc-bin …
ldconfig deferred processing now taking place
Processing triggers for hicolor-icon-theme …
Processing triggers for shared-mime-info …
karij@karij-Inspiron-1011 ~ $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 6.5G 5.0G 1.2G 82% /
udev 490M 4.0K 490M 1% /dev
tmpfs 199M 940K 198M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 497M 1.3M 495M 1% /run/shm
karij@karij-Inspiron-1011 ~ $

Yeah, it’s small SSD. Got another HD to be pout in it it- 2 years’ now, but need to persuade someone from LUG group to put it in for me and then help me load Mint back on!

Rubbish bin is empty and got very little files on it.

Most of my files are on my Maxtor portable HD.

Run:

sudo apt-get remove --purge flashplugin-installer flashplugin-downloader mint-flashplugin-11

then

sudo apt-get install flashplugin-installer

then run:

sudo updatedb

then post the output from:

dpkg -l | grep flash

and

locate libflashplayer.so

karij@karij-Inspiron-1011 ~ $ sudo apt-get remove --purge flashplugin-installer flashplugin-downloader mint-flashplugin-11
[sudo] password for karij:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be REMOVED
flashplugin-downloader* flashplugin-installer* mint-flashplugin-11*
0 upgraded, 0 newly installed, 3 to remove and 495 not upgraded.
After this operation, 17.2 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database … 178496 files and directories currently installed.)
Removing flashplugin-downloader …
Removing flashplugin-installer …
Purging configuration files for flashplugin-installer …
Removing mint-flashplugin-11 …
Processing triggers for update-notifier-common …
karij@karij-Inspiron-1011 ~ $ sudo apt-get install flashplugin-installer
Reading package lists… Done
Building dependency tree
Reading state information… Done
Suggested packages:
x-ttcidfont-conf ttf-mscorefonts-installer ttf-xfree86-nonfree xfs
The following NEW packages will be installed
flashplugin-installer
0 upgraded, 1 newly installed, 0 to remove and 495 not upgraded.
Need to get 6,988 B of archives.
After this operation, 140 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ precise-updates/multiverse flashplugin-installer i386 11.2.202.442ubuntu0.12.04.1 [6,988 B]
Fetched 6,988 B in 0s (27.0 kB/s)
Preconfiguring packages …
Selecting previously unselected package flashplugin-installer.
(Reading database … 178472 files and directories currently installed.)
Unpacking flashplugin-installer (from …/flashplugin-installer_11.2.202.442ubuntu0.12.04.1_i386.deb) …
Processing triggers for update-notifier-common …
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.442.orig.tar.gz
Installing from local file /tmp/tmpg1miVo.gz
Flash Plugin installed.
Setting up flashplugin-installer (11.2.202.442ubuntu0.12.04.1) …
karij@karij-Inspiron-1011 ~ $ sudo updatedb
karij@karij-Inspiron-1011 ~ $ dpkg -l | grep flash
ii flashplugin-installer 11.2.202.442ubuntu0.12.04.1 Adobe Flash Player plugin installer
karij@karij-Inspiron-1011 ~ $
karij@karij-Inspiron-1011 ~ $
karij@karij-Inspiron-1011 ~ $ locate libflashplayer.so
/home/karij/usr/lib/flash-plugin/libflashplayer.so
/usr/lib/flashplugin-installer/libflashplayer.so
karij@karij-Inspiron-1011 ~ $