No flash

Hi Guys

I’ve just installed Peppermint 4 on a PC for the missus and i made kinda hard work of it because I installed without an internet connection, I finally got everything working and up to date (or at least I think I have), the only problem i’m left with is i can,t get flash to work, I’ve checked in synaptic and it’s saying it’s installed, under Chromium plugins Adobe flash player version 11.2 r202 is listed and enabled, but when I try to run any you tube video I’m told shockwave flash could not load, when I try to install flash-plugin from the terminal I get this output

pat@Linux4 ~ $ sudo apt-get install flash-plugin
[sudo] password for pat: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package flash-plugin
pat@Linux4 ~ $ sudo apt-get install flashplugin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package flashplugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  flashplugin-installer

E: Package 'flashplugin' has no installation candidate
pat@Linux4 ~ $

Any help would be much appreciated

graeme

OK, first thing to try …

sudo apt-get remove --purge flashplugin-installer

then

sudo apt-get install adobe-flashplugin

Now close ALL web browsers, and restart Chromium.

Does flash work ?

if not, we’ll have to try putting it elsewhere … peppermint 32bit or 64bit ?

Hi Mark

thanks for your input, it’s been manic at work today but I’ll try your suggestions when I get home

Many thanks

Graeme

pat@Linux4 ~ $ sudo apt-get remove --purge flashplugin-installer
[sudo] password for pat: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  python-gdata python-httplib2 python-oauth2 python-twitter
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  flashplugin-installer*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 139 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 145304 files and directories currently installed.)
Removing flashplugin-installer ...
Purging configuration files for flashplugin-installer ...
Processing triggers for update-notifier-common ...
pat@Linux4 ~ $ sudo apt-get install adobe-flashplugin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package adobe-flashplugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'adobe-flashplugin' has no installation candidate
pat@Linux4 ~ $ 

This is Peppermint 4 right ?

Go to

menu>Preferences>Software & Updates>Other Software (tab)

and make sure

Canonical Partners
and
Indepenent

are both ticked

Then click “Close”

Now back in the terminal run:

sudo apt-get update

then

sudo apt-get install adobe-flashplugin

Both Cannonical Partners & Independent were unchecked but still no luck I’m afraid

This is Peppermint 4 right ?

Yes

So have you got flash (in any form) installed?
Is it the case that it is installed but not able to use it?

Hi SeZo

Is it the case that it is installed but not able to use it?

It appears to be installed but when I open you tube a message at the top of the page says “could not load Shockwave Flash”

pat@Linux4 ~ $ sudo apt-get install adobe-flashplugin
[sudo] password for pat: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
adobe-flashplugin is already the newest version.
The following packages were automatically installed and are no longer required:
  python-gdata python-httplib2 python-oauth2 python-twitter
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pat@Linux4 ~ $ 

They are meant to be CHECKED not unchecked.

run:

sudo updatedb

now what’s the output from:

dpkg -l | grep flash

and

locate libflashplayer

?

[EDIT]

Also, as I’m betting this is one of those cases where the flashplayer crashes because hardware acceleration is enabled by default … what’s the output from:

sudo lshw -C display

I was looking at this too:

Try disabling it.

They are meant to be CHECKED not unchecked.

I did check them I was only pointing that they were originally unchecked

pat@Linux4 ~ $ sudo apt-get install adobe-flashplugin
[sudo] password for pat: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
adobe-flashplugin is already the newest version.
The following packages were automatically installed and are no longer required:
  python-gdata python-httplib2 python-oauth2 python-twitter
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pat@Linux4 ~ $ clear
pat@Linux4 ~ $ sudo updatedb
[sudo] password for pat: 
pat@Linux4 ~ $ dpkg -l | grep flash
ii  adobe-flash-properties-gtk           11.2.202.291-0raring1               i386         GTK+ control panel for Adobe Flash Player plugin version 11
ii  adobe-flashplugin                    11.2.202.291-0raring1               i386         Adobe Flash Player plugin version 11
pat@Linux4 ~ $ sudo lshw -C display
  *-display               
       description: VGA compatible controller
       product: RV280 [Radeon 9200 PRO]
       vendor: Advanced Micro Devices [AMD] nee ATI
       physical id: 5
       bus info: pci@0000:01:05.0
       version: 01
       width: 32 bits
       clock: 66MHz
       capabilities: agp agp-2.0 pm vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=32 mingnt=8
       resources: irq:16 memory:d0000000-dfffffff ioport:c000(size=256) memory:e5000000-e500ffff memory:e4000000-e401ffff
pat@Linux4 ~ $ 

Ok following the instructions from SeZos link I navigated to “Find Flash Player version type and capabilities (Flash developers only)” but when I click in the box to choose my version it says couldn’t load plugin ???

Yeh adobe don’t seem to understand "it’s impossible to disable it if you have to right-click a flash video … AND THE FEKIN THING CRASHES … catch 22.

Lemme try something

I have a feeling that, version 11.101 works with most hardware, but is out of date so keeps throwing up security warnings … the warnings can be dismissed, and it then works.

What I’m wondering is if you install BOTH … disable the newest … untick the hardware acceleration in the old one … then switch to the new one, if it will stick.

Or … is “Additional Drivers” offering you any other drivers ?

Yeh adobe don't seem to understand "it's impossible to disable it if you have to right-click a flash video .. AND THE FEKIN THING CRASHES .. catch 22.

Are you saying adobe use a Flash video to help people correct issues with Flash ?

Or .. is "Additional Drivers" offering you any other drivers ?

There are no Additional drivers being offered

You could try the methods in this link:

I have just checked on mine is 11,01,98 (from older LMDE install) Me too having problems with later versions.

Are you saying adobe use a Flash video to help people correct issues with Flash ?

that’s EXACTLY what I’m saying , yoyu have to start flashplayer to change the setttings

OK, I think I may have cracked this (at least this appears to work in Firefox)…
(ignore the fact that it says “mozilla” in these instructions … chromium also looks in that directory for a flashplayer)

Uninstall adobe-flashplugin (so you have NO flashplayer):

sudo apt-get remove adobe-flashplugin

Create a directory ~/.mozilla/plugins:

mkdir -p ~/.mozilla/plugins

Change to that directory:

cd ~/.mozilla/plugins

downloadthe 11.1 flashplayer from my dropbox:

if running 32bit:-

wget https://dl.dropboxusercontent.com/u/11876059/flashplayer-11.1-32bit.tar.gz

then

tar -xvf flashplayer-11.1-32bit.tar.gz

if running 64bit:-

wget https://dl.dropboxusercontent.com/u/11876059/flashplayer-11.1-64bit.tar.gz

then

tar -xvf flashplayer-11.1-64bit.tar.gz

Now close ALL web browser instances … this is important, to remove any flashplayer from memory.

Re-open a browser, and go to youtube and attempt to play a video.

Youtube will bitch that your flashplayer is out of date, and prompt you to upgrade … DO NOT select to upgrade.

instead, clck they writing where it says “Activate Flashplayer”, and click whatever the next window says that allows you to watch the video.

Now, whilst the video is playing, right click anywhere on the video, and select “Settings” (not global settings) … now take the tick OUT of “Enable hardware acceleration”, and click the “Close” button.

back in a terminal, reinstall adobe-flashplugin:

sudo apt-get install adobe-flashplugin

Close ALL web browser windows, and re-open one.

Go to Youtube and try watch a video … the newer version of flashplayer seems to override the old one, but keep its settings … so hardware acceleration should still be disabled.

A lot of faffing around, but I’d be VERY interested to know if this helps, because you are NOT the only one with this issue … so if it works, it could help a lot of other people.

If you’re unsure about any of the steps, just ask :slight_smile:

Ok Mark your plan worked perfectly, however flash did not bitch about flash player being out of date or prompt me to upgrade it just worked, so I didn’t go as far as your last instruction to re-install adobe-flashplugin

right clicking on a flash video and selecting settings shows hardware acceleration is enabled I tried unchecking it and it works just the same so I’ve left it enabled

Thank you

Graeme

You can ignore this posting if you wish … I’ve figured out how to shut up the warnings in firefox for flashplayer 11.1
(see the bottom section)

Hmm, maybe it’s only in firefox that it bitches about being out of date and a security issue.

If I were you, I’d disable hardware acceleration … just in case flashplayer somehow gets reinstalled.

Plus I would REALLY have liked to know if this full solution worked … so I could help others with it where necessary.

If you feel like trying it … just install adobe-flashplugin, and if necessary disable 11.1 in chromium @

chrome://plugins

and see if hardware acceleration is still switched off in the new version

if anything goes wrong … just uninstall adobe-flashpluggin again:

sudo apt-get remove adobe-flashplugin

then make sure 11.1 is re-enabled in chrome://plugins
and you’re back to where you are now.


I think I’ve found out how to shut up the warnings in Firefox -

Enter
about:config
into the address bar, and confirm the “I’ll be careful” warning
then search for the preference named
plugins.hide_infobar_for_outdated_plugin
and double-click it in order to toggle it to
true

Ok Mark I’ll try out the full plan later this evening when I get home

Once again thanks for sorting this out for me

Graeme