No internet connection any more

Hello folks,

Recently our internet connection stopped working in both windows and Ubuntu 14.04. I assumed I’d broken it while fiddling about with the router’s wi-fi settings.

I returned the router to factory settings. No luck. So I turned off the router (and everything else) for several hours. Now Windows can access the internet again, but not Ubuntu.

It appears to connect (green lights on the router etc), and our ISP confirms that the connection has been made, but pages just won’t load.

Anyone got any ideas please?

This could be down to number of things but you could try:

sudo route -n

then

ping -n -c5 linux.co.uk

if that fails then try:

ping -n -c5 130.193.92.18

Post what you get

Thanks SeZo,

Will do.

Got to reboot to try it (I’m on a dual boot PC).

This is what I got… double Dutch to me! I hope you can make something of it…

mike@mike-abit:~$ sudo route -n
[sudo] password for mike:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth1
192.168.0.0 0.0.0.0 255.255.255.0 U 1 0 0 eth1
mike@mike-abit:~$ ping -n -c5 linux.co.uk
ping: unknown host linux.co.uk
mike@mike-abit:~$ ping -n -c5 130.193.92.18
PING 130.193.92.18 (130.193.92.18) 56(84) bytes of data.
64 bytes from 130.193.92.18: icmp_seq=1 ttl=56 time=388 ms
64 bytes from 130.193.92.18: icmp_seq=2 ttl=56 time=334 ms
64 bytes from 130.193.92.18: icmp_seq=3 ttl=56 time=426 ms
64 bytes from 130.193.92.18: icmp_seq=4 ttl=56 time=344 ms
64 bytes from 130.193.92.18: icmp_seq=5 ttl=56 time=466 ms

— 130.193.92.18 ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4004ms
rtt min/avg/max/mdev = 334.332/392.233/466.642/49.748 ms
mike@mike-abit:~$

The ip address 130.193.92.18 is linux.co.uk
The fact that you received 5 replies from 130.193.92.18 means that you have access to the internet but have no DNS server available.
You could put OpenDNS as a DNS resolver manually in your Ubuntu network settings for that connection.
208.67.222.222
208.67.220.220

Thanks SeZo,

I may be back asking for instructions on exactly how to do that. I’ll try to figure it out first though.

But why do I suddenly have no DNS server? I’m prepared to believe that I messed up the router, but I’ve restored the factory defaults?

Thanks again SeZo,

Using OpenDNS has got us back online, albeit more slowly than before. I assume that’s because the router is starting from scratch and building up to the maximum speed possible.

I’m still baffled as to how we lost the DNS server though…

I’ll watch this for a couple of days before marking it solved.

Regards,

M

If Windows is accessing the web properly it’s not a problem with the router, it’s likely a problem with Ubuntu’s network settings.

What was set as the DNS server in network manager … was it the routers IP ?

Hello Mark,

Sorry for the delayed reply.

DNS in Ubuntu’s network manager is 192.168.0.1, which I believe is the router…

Still online, albeit a bit slower than before. I’ll talk to our ISP about it - we used to leave the DNS to them and things were fine. No idea why that changed.

do you mean DNS “was” set to the routers IP in networkmanager … or DNS “is now” set to the routers IP in networkmanager

In which case, where did you set the opendns servers ? … in the router itself ?

DNS was set to ‘automatically from the ISP’

Then set to the openDNS ones suggested by sezo, which got us back online, albeit slower.

Now, infuriatingly, still set to the openDNS ones suggested by sezo, but as of tonight, no longer online in Ubuntu (although we are in XP).

Grrrrr…

Yeah but WHERE are you applying those DNS settings … in networkmanager, or in the router ?

In the router…

Ahh, right … (IN THE ROUTER) set it back to the DNS from your ISP.

Then run:

nm-connection-editor

highlight your connection, and click the “Edit” button.

On the IPv4 tab, set:-

Method: Automatic (DHCP) addresses only

and

DNS Servers: <IP.address.of.router>

eg.
DNS Servers: 192.168.1.1

Then click the “Save” button.

at this point you may need to log off/on to restart the network.

You might also want to set the IPv6
Method: Ignore


If it doesn’t work … just set it back the way it was.

No luck Mark.

Tried every combination of your suggestions, but still offline in Ubuntu and online in Windows…

With the setup I described do you get ping returns from:

ping -c 5 216.58.213.174

but not from:

ping -c 5 google.com

?


If so, what happens if (in networkmanager NOT in the router) on the IPv4 tab you set:-

Method: Automatic (DHCP) addresses only

DNS Servers: 8.8.8.8, 8.8.4.4
(that’s a comma and space between the 2 DNS IP’s)

SAVE the settings … then restart the network by either clicking on the networkmanager icon, then your network name in the list … or by logging off/on.

Yes I do Mark, although even using the IP address I get anything between 0% and 100% packet loss. With the domain name I get nothing.

Same thing with DNS Servers: 8.8.8.8, 8.8.4.4

There’s inconsistency though. The router diagnostics allow a DNS lookup. Also, if I switch between openDNS and getting a dns from the ISP, sometimes I actually see the netgear website, although no other sites load, and in fact the netgear one doesn’t next time I try. Something to do with caching?

Could this be as simple as a failing router? Actually probably not, as Windows is consistently online, albeit 75% as fast as previously…

I’m fighting the urge to kick some expensive monitors now!

So you’re getting packet loss even with

ping -c 5 216.58.213.174

how are you connected again . wireless or cable ?

Yes. And cable.

Thanks for your help Mark. Got to sleep now. I’ll check in later today…

Have you tried replacing the
8.8.8.8, 8.8.4.4
in networkmanager, with your ISP’s DNS addresses ?