No login screen (SOLVED)

Hi guys

I’ve just upgraded my Grand-Daughters PC to Peppermint 5 and during installation I selected it to login without a password, then as an afterthought I decided it would be a good idea to add an Admin account because lately she’s discovered the file manager and become a little more adventurous navigating through the file system.

I thought once I added the new account I would be presented with a login screen on reboot but it still loads straight into Chloes account so I have no way of logging into the Admin account

in Users & Groups I’ve set both accounts to ask for password on login but it’s still logging straight into Chloes account

Any help would be much appreciated



sudo gedit /etc/lightdm/lightdm.conf

find the line that reads:-


and change it to either:-

# autologin-user=

Then SAVE the file.

Have you added the “Admin” account to the “sudo” group ? … it would be a good idea to :wink:

Once you’ve done that, you might want to use that Admin account to remove your grand daughters account from the sudo group … your call :slight_smile:

Thank you for that Mark it worked a treat,

I also did as you suggested and added Admin and removed Chloe from the sudo group

I also installed Timeshift and took a snapshot of the system so she’s good to go :slight_smile:

Many thanks


As always … you’re most welcome :slight_smile:

I have similar problem to Graeme, but the other way round.

I have just built up a desktop with Peppermint 5 and set it to auto login - but it always requests a password. I’ve checked the lightdm.conf file and I am set to log in automatically. Any ideas?

As an aside, I used your gedit command out of laziness just to inspect the file and, although it worked, I received this error as well:
[i]keith@dt0 ~ $ sudo gedit /etc/lightdm/lightdm.conf
[sudo] password for keith:

** (gedit:1805): WARNING **: Could not load Gedit repository: Typelib file for namespace ‘GtkSource’, version ‘3.0’ not found

(gedit:1805): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Is that important?

They’re only Gtk warnings for gedit and can be safely ignored :slight_smile:

The first is about a missing package for the gedit “syntax highlighting” plugin … If you really want to get rid of it (but there’s no need) you can install gir1.2-gtksource-3.0

sudo apt install gir1.2-gtksource-3.0

The other one you can do little about … it’s where GD is trying to access the org.gnome.SessionManager dbus directive, but that directive is not provided. That directive does not exist in Peppermint as we don’t use the Gnome session manager … as I said this is quite normal and can be safely ignored, they’re warnings not errors :wink:

When does it ask for a password ?

are you saying you still get the login screen ?

Did you elect to have an encrypted /home folder during the install ?

Hi Mark.
Thank you for the detailed explanation for the “errors” - I’m not bothered about their appearance if it’s not important, as you indicate.

When does it ask for a password ? at initial login and whenever the screen saver goes black and I press a key to get back in.
Are you saying you still get the login screen ? Yep! despite what it says in the lightdm.conf file.
Did you elect to have an encrypted /home folder during the install ? No, I remembered your previous comments about encryption and made sure that nothing was encrypted.

Can you post the contents of:

gedit /etc/lightdm/lightdm.conf

and output from:


keith@dt0 ~ $ sudo gedit /etc/lightdm/lightdm.conf

keith@dt0 ~ $ whoami

(It’s encouraging to discover that I am who I thought I was)

Has it always done this … or is this new behaviour ?

can you run:

sudo tar czvf ~/Desktop/keith-logs.tar.gz /var/log/syslog /var/log/lightdm/lightdm.log /home/keith/.xsession-errors


sudo chown -v keith:keith ~/Desktop/logs.tar.gz

You’ll then find a file called “keith-logs.tar.gz” on your desktop … can you host that online somewhere and provide a download link

I rebuilt the system today and it persisted in demanding a password each time I rebooted or the screen saver activated. However…

Before noticing your post, I installed gnome-session-fallback and when rebooting it went straight to autologin! Just to add some mystery, my user account is now showing that a password is required to login but lightdm.conf still shows auto login is set:

keith@dt0 /etc/lightdm $ more lightdm.conf

I shall try changing my user account to auto login and see what happens…
[EDIT] changing the login method in “Users & Groups” has no effect. The only way to change the auto/password login is via lightdm.conf.
[EDIT 2] I attempted to try classic view (gnome fallback) to see if there was any difference in behaviour but the login screen doesn’t offer a choice of desktop.

Sorry, Mark - I missed your post. Here is the result:
sudo chown -v keith:keith ~/Desktop/logs.tar.gz
chown: cannot access ‘/home/keith/Desktop/logs.tar.gz’: No such file or directory
failed to change ownership of ‘/home/keith/Desktop/logs.tar.gz’ to keith:keith

The file does appear on my desktop but I shall have to use another PC to put it on Dropbox - I’ll let you know when done.

Here is a link to the file:

This’ll have to wait until tomorrow keith … I need to reinstall lightdm-gtk-greeter so I can compare your logs with mine.

Mine’s somewhat different, but then I’m currently using a different greeter.

BTW, you can delete that file and link now if you’d like … they’re not a security risk, but I have it now anyway.

No problem, Mark.
Since this PC is just for playing with, a solution is not really necessary for me, but in view of the similar enquiries found on the web I’m guessing that there will be many readers who might find it useful if you succeed in finding a solution. But please don’t spend too much of your valuable time on it.


Please ignore this posting, just bumping it to keep it on the forum front page … I’ll get around to it eventually :slight_smile:

No problem, Mark - it’s kind of you to remember.

I probably wouldn’t if it wasn’t on the front page … memory like a … erm, what’s that thing with holes in called again :wink:

String vest?

Polo … so this topic has something to do with Mint ?