No sound in 16.04 [Solved]

Finally upgraded from 14.04 to 16.04 and the sound has gone awol.

In settings~sound the only option is Digital Output (S/PDIF).

I can’t find any option to use analogue sound.

Grrrr!

Update: I plugged the speakers into the rear jack instead of the front one and analogue sound kicked in. The front jack no longer seems to work (it did under 14.04).

Oddly, the right channel doesn’t work with the speakers plugged into it directly, but it does with the headphones or with the speakers on an extension cable, as long as I wiggle the plug a bit. That trick just doesn’t work with the speakers alone. I suppose it’s a physical thing, to do with cables and plugs. Doesn’t half annoy me though.

No idea why the front jack has stopped working. Any clues appreciated.

I am assuming this is a desktop, so have you installed a sound card or are you using the sound system built in to the motherboard?

Keith

Yes, desktop. Onboard sound only.

Having realised that the method of wiggling the jack introduces a horrible buzz, I’ve given up on the rear panel - I think the sound on the motherboard is shot.

This is a dual-boot box with Windows. In XP I have got the front panel sound working nicely (oddly, by disabling the front panel jack detection in Realtek Audio Manager. A known problem). If I can just achieve the same thing in Ubuntu, that will do, but I can’t find the equivalent settings…

Next thing will be to install a soundcard, but the box is a bit full so I would have to remove some other card. Not ideal.

M

I’m out of my depth here, Mike, but it does sound as though you have serious motherboard problems.
In my own experience, using a separate board has always solved any difficulties - but then I always had spare slots available!
Do you have PulseAudio Volume Control installed? Not sure it will help fix anything but it might give you some clues about what’s going on. I’ve found it useful when trying to get sound out of Audacity and Bluetooth.

Sorry I can’t make any more useful suggestions.

Keith

Do you know the make and model of the motherboard ?

and can you post the output from:

aplay -l

and

cat /proc/asound/card0/codec* | grep Codec

and if any

cat /proc/asound/card1/codec* | grep Codec

Thanks for your help Keith, I’ll look into PulseAudio (never heard of it before…). I can free up a slot if need be for a sound card.

Mark, It’s an Abit IP35 Pro motherboard. Outputs below. The HDMI device must be the video card as no sound card is installed.

To run a command as administrator (user “root”), use “sudo ”.
See “man sudo_root” for details.

mike@mike-ubuntu:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
mike@mike-ubuntu:~$ cat /proc/asound/card0/codec* | grep Codec
Codec: Realtek ALC888
mike@mike-ubuntu:~$ cat /proc/asound/card1/codec* | grep Codec
Codec: ATI R6xx HDMI
mike@mike-ubuntu:~$

Can you check if audio works if you log onto the “Guest” session ?

Hello Mark,

Same story in the guest session…

However, I’ve just noticed that in Settings~Sound, there are 2 options in the Output tab, S/PDIF and Line Out, but I can’t select Line Out. If I do, the system just reverts to S/PDIF.

Does running

mv -v ~/.config/pulse ~/.config/pulse-broken

make any difference ?

The command line is still largely a mystery to me, Mark, but this is what I got.

mike@mike-ubuntu:~$ mv -v ~/.config/pulse ~/.config/pulse-broken
mv: cannot stat ‘/home/mike/.config/pulse’: No such file or directory
mike@mike-ubuntu:~$

I know I need to get to grips with the command line. Finding time is the main problem.

Okay, try this:

sudo apt-get remove --purge pulseaudio pulseaudio-utils pavucontrol

then

killall pulseaudio ; rm -r ~/.config/pulse ; rm -r ~/.pulse*

then

mkdir ~/.config/pulse

then

sudo apt-get install pulseaudio pulseaudio-utils pavucontrol

do you have sound now … you may need to reboot.

Before I run those commands, maybe I should say that I have left channel sound from the rear jack. If I use an extension cable and wiggle it, I get both channels, but with a background buzz, so I’m guessing it’s a problem with the connector on the motherboard. Front panel audio has disappeared in Ubuntu after the upgrade to 16.04, although it still works in XP.

Shall I still try the commands?

Can’t hurt…

It’s not going to fix things if this is a hardware problem, but give it a shot anyway … if it makes no difference we’ll go from there.

Hello Mark,

I got fed up with crawling under the desk, wiggling jacks, and dug out a dusty old Soundblaster card.

Luckily it’s small enough that I could cram it into a PCI slot without removing another card. Now I have decent stereo sound in both Ubuntu and Windows. So it looks like a hardware problem, as we suspected.

No sound from the front panel in Ubuntu (haven’t tried it in Windows), but that’s no problem. I very rarely use headphones anyway.

I’m going to mark this solved now. Thanks to you and Keith for your help

I don’t think I helped much but I’m pleased that you have sorted it out. As always I found Mark’s suggestions interesting and useful for the future.

Keith

Your time and your suggestions were welcome, Keith.

You helped nudge me towards a separate sound card, which ultimately fixed the problem…

Also, I will look into PulseAudio when I get time.

Thanks again.

Good to hear you have sound again mike :slight_smile:

Yes. Celebrating with a bit of Sandy Denny and R & L Thompson on Spotify…

TVM, that just prompted me to revisit Fairport Convention who I haven’t listened to for years :slight_smile:

Saw them live a couple of times in a small venue. Once with Sandy, and once after she passed.

Two of the best gigs I ever attended… The atmosphere was fantastic. From up on a balcony all I could see was the band and a sea of jigging people. Swarbrick was like a force of nature!

I lived (briefly) just up the road from the house which gave them their name.