No sound on start up (sometimes)

Ok, very annoying problem, that has got worse.

It used to be every once in a while id start up and everything would work fine apart from no sound. I have external logitech speakers.
Then it started becoming a coin flip, but again a restart or too and the problem is gone.

Until today. Tried 30 (yes three zero) restarts and still it does not seem to pick up my speakers.

Another side point, sometimes when I log in it says that the power management is not responding. After 10-20 seconds it then logs in. Not sure if the problems are connected.

A solution to this would be amazing :slight_smile:

Do you have 2 sound cards by any chance… ie. an installed sound card and a sound card integrated into the motherboard?

If you’re unsure, post the output from:

cat /proc/asound/cards


aplay -l

When you say “no sound”, do you mean that it doesn’t recognise your sound card, or just that everything looks fine but nothing comes out of your speakers?

Mark, this is what came back,

matthew@matthew-desktop:~$ cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfeaf8000 irq 20
matthew@matthew-desktop:~$ aplay -l
aplay: device_list:223: no soundcards found…

Mad, it can’t be recognising my sound card. Everything else it fine. On the top panel where it has the speaker icon it just has three — next to it.

Can you enter this command:

lspci -v

look for a sections about your “Multimedia audio controller”, and post back that whole section.

Here’s mine… yours will be similar

00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02) Subsystem: ASUSTeK Computer Inc. Device 8195 Flags: bus master, 66MHz, slow devsel, latency 64, IRQ 17 Memory at fe02a000 (32-bit, non-prefetchable) [size=256] Capabilities: Kernel driver in use: ATI IXP AC97 controller Kernel modules: snd-atiixp

Ok, “–” either means it can’t see an audio device, OR the audio device is muted. For a start, just click on the speaker icon and make sure there isn’t an “unmute” button.

If it’s not seeing your device, that’s a bit of a problem, especially if it “was” seeing the device.

Next, try rebooting your machine and interrupt the boot process with ESC (or is it TAB now?) and add the kernel parameters;
noapic, nolapic

See if that makes any difference …

It’s Esc or Shift now :slight_smile:

00:09.0 Audio device: nVidia Corporation MCP73 High Definition Audio (rev a1)
Subsystem: Packard Bell B.V. Device e038
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
Memory at feaf8000 (32-bit, non-prefetchable) [size=16K]
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

Dont really understand kernel parameters, so I dont want to try this just yet. What does it actually involve?

I will try to post back the terminal results when it is working so you can see the difference.

Thanks again guys

Now its working again,
The result of aplay -l:

matthew@matthew-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

So thats different from before.

lspci -v brings back the same as posted before.

Any ideas?

next time it doesn’t work, try

modprobe snd-hda-intel

and let me know if this fixes the sound… it won’t survive a reboot, but if it works I’ll tell you how to make it permanent.

Also, try this:

sudo gedit /etc/modprobe.d/alsa-base.conf

create a new line at the end of the file, and put:

options snd-hda-intel model=6stack-dig probe_mask=1
on it... save... reboot.

if it doesn’t work, you can always remove the line:

sudo gedit /etc/modprobe.d/alsa-base.conf

remove that line, and save.