No Terminal Steamos desktop

desktop@steamos:~$ sudo apt-get install libpango1.0-0 libvte9 synapticReading package lists... Done
Building dependency tree       
Reading state information... Done
Package synaptic is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

# deb cdrom:[SteamOS GNU/Linux 2.0 _Brewmaster_ - Unofficial Multi-architecture$

#deb cdrom:[SteamOS GNU/Linux 2.0 _Brewmaster_ - Unofficial Multi-architecture $

## internal SteamOS repo
deb brewmaster main contrib non-free
deb-src brewmaster main contrib non-free

## deb wheezy main contrib non-free
## deb-src wheezy main contrib non-free

deb wheezy main contrib non-free
deb-src wheezy main contrib non-free

# Debian Main
## deb wheezy main
## deb-src wheezy main
# Debian Update
deb wheezy-updates main
deb-src wheezy-updates main
# Debian Security
deb wheezy/updates main
deb-src wheezy/updates main
# Debian Multimedia Repo (for XBMC 12.*)
deb wheezy main non-free
and try to get it all this time ;)

What did I miss ?

This actually very awkward because universal access is set to large text and it wont change so everything is oversize


There’s something weird going on here as it’s definitely in the repos.

Have you tried using the ftp protocol for the sources list … the one I posted a link to on pastebin ?

what happens if you run:

sudo apt-get clean


sudo mv -v /var/lib/apt/lists /var/lib/apt/lists-old


sudo mkdir -p /var/lib/apt/lists/partial


sudo apt-get update


sudo apt-get install libpango1.0-0 libvte9 synaptic
Have you tried using the ftp protocol for the sources list .. the one I posted a link to on pastebin ?

I just tried that and it made no difference I also tried it with your last series of commands still no joy

I then put the sources.list back to the http type and run the series of commands again still didn’t work each time I try to install synaptic it reports no installation candidate


This installation of Steamos is on a seperate 640gb hdd inside my own PC which I’ve set up as a test, other than the issue I’m having installing software the test has been successful, and I now have another PC that I’m gonna use to build the Steambox so I need to move the HDD into the other PC and hope it boots if not I may have to reinstall Steamos again in the other PC.

So I’m gonna do that next and when/if I get it up and running again come back to this

Is that ok ?


Ok I have it set up in the other PC and all seems well except I still can’t install software :frowning:

Ok I found the problem

according to instructions here Installing Applications From The Wheezy Repo In SteamOS · ValveSoftware/SteamOS Wiki · GitHub
after adding the Debian repos I created a /etc/apt/preferences file giving the Steam repos priority like this

Package: *
Pin: release l=SteamOS
Pin-Priority: 900

Package: *
Pin: release l=Debian
Pin-Priority: -10

But according to this thread i found on a Steam forum setting the debian Pin-Priority to -10 will prevent apt from installing anything from the Debian repos so I set it to 100 and it’s installing software ok,


I guess peeps are still having dificulty understanding Apt-Pinning. If you give a branch/distribution/whatever a negative value, it will not install anything from that pin unless you specify that that package must come from that pin.

So with debian on -10:
sudo apt-get install xbmc
will show no installation candidates as its not in the SteamOS repo.

You can attempt to install it with:
sudo apt-get install xbmc/wheezy
This will attempt to install xbmc, but if there are any dependencies that are not the SteamOS repo then the installation again will fail due to dependency errors. In this situation can can also be specific and specify any missing dependencies too.
sudo apt-get install xbmc/wheezy xbmc-dependency/wheezy
However this may get a bit painful if there’s a lot of dependencies. So you can instead use:
sudo apt-get -t wheezy install xbmc
This will instruct apt to solve any dependencies from the wheezy before steamos.

Alternatively you can also give the Debian archives a non negative number, but lower than the SteamOS archives. So you can install from the OK Debian repo, but SteamOS gets priority.
So setting Debian from -10 to 100 would allow the use of:
sudo apt-get install xbmc
This is a more relaxed way of pinning, however, this put you in danger of accidentally installing unwanted packages from the wrong repo. Particularly if Debian requires packages that are newer than the ones in SteamOS.

Non-negative priorities also allow packages to update, where negative priorities will no receive updates unless you update them.

As we are bring pages from a OS with a more uptodate base, its recommended to use negative priorities.

Also, do NOT specify priorities higher than 990. Prioities 1000+ have a special meaning and and used to force downgrades


apparantely this can cause issues but it’s not clear to me what but it works
It may be a good idea to put it back to -10 after installing the software I want, what do you think ?

Many thanks


It all depends if you’re going to want to install other stuff from the debiian repos now doesn’t it :wink:

I can see why steam do this … SteamOS is not designed for them to have to support it as a complete PC operating system, it’s meant for one purpose, so by limiting its ability to install other stuff they’re limiting what they’re going to need to support.