Noob with multiple issues -Just installed LinuxMint 17.3 with Win8

Hi all, since the Mint forums are down, I thought I’d post here. My laptop running Win8 lost the use of the USB ports and the WebCam a long while back. I have 300gigs of files that I want to save with no real way to back them up as I’m out in the woods on DIAL-UP.
My thought was to install Linux along side windows and copy files to that partition then maybe format the C: drive in hopes of whatever was causing my USBs to fail would be gone.

Does that make sense?

It makes sense, but there’s probably no need to install Mint if you don’t want to … the files could be copied whilst booted to the LiveCD/LiveUSB.

Can I ask when you downloaded the Mint ISO image … the reason I ask is their server was recently hacked and for a day their server was offering a hacked version of mint that contained malicious software … the hacked version was only on their site for a day (20th Feb).

I’m NOT trying to talk you out of using Mint which is a great distro … if you have an original (unhacked) ISO image Mint is a solid and secure OS, but they cannot secure a version that comes with pre-installed malicious code.

Oh, and welcome to the forum :slight_smile:

If you’re unsure when you downloaded the Mint ISO and it was “around” the 20th … I’d suggest you download it again.


Just a thought, but have you tried removing the USB hubs/drivers from within the Windows device manager … then letting Windows rediscover them ? … that might solve the problem in Windows.

Thanks! I d/l’d the ISO on the 19th, but I still checked the MD5. I hope that was enough to be sure I had a good ISO.
I am done with windows. The more I fool around with Mint, the more I like it.

I didn’t make the partition big enough to copy all my files. I deleted enough on C: to have room, but not sure how or what I need to do to enlarge the Mint volume. If I get Gparted can I resize the partitions to make room?

Is there a way in Linux to scan for hardware changes? I mean once I format the windows partitions, how do I (or can I) get the USB ports to be recognized? If it is a hardware problem then I’m done and this will be just a fancy music player. I just don’t see how the camera and usb’s all quit working near the same time. There’s got to be some bad stuff in the windows files…how’s that for good geek lingo? :slight_smile:

Linux (just like Windows) talks direct with the hardware. Any changes are automatically detected and the appropriate drivers are loaded.
Unlike in Windows, this is done silently. If you have Mint already installed then all you need is to plug in a USB stick and the drive will be automatically available in the File Manager. That is if it is not a hardware failure. :wink:
If it does not automatically show up then you could launch the Terminal (CTRL+T) and enter (that is a lowercase L):

sudo fdisk -l 

That would also list all other partitions including the USB
So if you could post the result of the above command that would would give us an idea of what to suggest in case you want to increase the Mint install partition size.

Oh and yes I tried to uninstall the usb hubs in windows several times.

Can you post the specs for your laptop (chapter and verse if poss)? There are different remedies for different makes and models depending on hardware/software combinations… :wink:

Rich

Can you post the specs for your laptop (chapter and verse if poss)? There are different remedies for different makes and models depending on hardware/software combinations… :wink:

Rich
[/quote]

@SierraDave … can you not attach images please, unless they’re specifically requested for by the forum admin :wink:

Instead, either

a) whenever possible copy/paste terminal output directly into your posting … it allows people to copy/paste parts if it in their responses
or
b) host the mage on a site like
http://imgur.com
and post a link to it.


As I’ve had to delete a couple of images…

For anyone wondering … it appears SierraDave already has Mint installed, and the spec for his PC can be found here:
http://www.samsung.com/us/computer/pcs/NP300E4C-A01US-specs


First let’s check the USB ports are working … in Mint, plug something into a USB port and post the output from:

lsusb

Yes, sorry about the attachments. My laptop is offline. I’m on my home pc making it difficult to get info from it to post here. I’ll see what I can do.

First let’s check the USB ports are working … in Mint, plug something into a USB port and post the output from:

lsusb

dave@dave-300E4C-300E5C-300E7C ~ $ lsusb

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I plugged a stick in and also a camera turned on. Same result.

Ok, uplug your USB stick

wait 10 seconds

replug your USB stick back in

run:

dmesg | tail -n 40

and post the output back here

dave@dave-300E4C-300E5C-300E7C ~ $ dmesg | tail -n 40
[ 14.289208] sound hdaudioC0D0: inputs:
[ 14.289211] sound hdaudioC0D0: Internal Mic=0x19
[ 14.289214] sound hdaudioC0D0: Mic=0x18
[ 14.329677] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
[ 14.329918] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
[ 14.330319] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
[ 14.483670] cfg80211: World regulatory domain updated:
[ 14.483674] cfg80211: DFS Master region: unset
[ 14.483676] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 14.483678] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 14.483680] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 14.483682] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 14.483684] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 14.483685] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 16.778694] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
[ 17.518754] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[ 18.075957] EXT4-fs (sda7): mounted filesystem with ordered data mode. Opts: (null)
[ 18.594281] init: failsafe main process (728) killed by TERM signal
[ 19.147162] Bluetooth: Core ver 2.20
[ 19.147184] NET: Registered protocol family 31
[ 19.147186] Bluetooth: HCI device and connection manager initialized
[ 19.147191] Bluetooth: HCI socket layer initialized
[ 19.147194] Bluetooth: L2CAP socket layer initialized
[ 19.147202] Bluetooth: SCO socket layer initialized
[ 19.151017] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 19.151022] Bluetooth: BNEP filters: protocol multicast
[ 19.151027] Bluetooth: BNEP socket layer initialized
[ 19.151060] Bluetooth: RFCOMM TTY layer initialized
[ 19.151066] Bluetooth: RFCOMM socket layer initialized
[ 19.151072] Bluetooth: RFCOMM ver 1.11
[ 20.090886] init: cups main process (811) killed by HUP signal
[ 20.090897] init: cups main process ended, respawning
[ 21.398959] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 21.678610] r8169 0000:02:00.0 eth0: link down
[ 21.678657] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 21.771700] init: samba-ad-dc main process (1069) terminated with status 1
[ 23.994635] init: plymouth-upstart-bridge main process ended, respawning
[ 23.999310] init: plymouth-upstart-bridge main process (1409) terminated with status 1
[ 23.999321] init: plymouth-upstart-bridge main process ended, respawning
[17506.075318] systemd-hostnamed[2968]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!

Okay, it’s not detecting anything being plugged in … either your USB controller is dead, or you’ve disable USB in the BIOS

That is not good news. Thank you very much for youe time and help, Mark!

As Mark suggested, you could poke around in the bios and see if it is disabled there.

I’m fairly certain that is not the case.