Not Impressed so Far

Well I had heard good things about Linux, so thought I would try it out using my oldest Computer an IBM P3 laptop with 500MB of Ram ( Runs XP home OK).

So Far I am not impressed, I have downloaded 12 different versions of Linux and only found one that works on my computer (SliTaz V.3.0) and this release is the pits. It is not even possible to change the screen resolution from the desk-top and it looks like I will have problems when I want to use my PEAK PCMCIA Wi-fi card.

If Linux wants to take on Windows (Please Please Please) it needs to get much more focused on the end user and make installation easy for those who do not even know what a Command Line Prompt is.

I build my own PC’s so I have some understanding of how a computer works. If you think you know a version of Linux that will get me hooked then please let me know. :cry:

It might help if you told us which distros you’ve tried, and what the problems were exactly :wink:

Laptop model wouldn’t hurt either.

Sorry about this, but I’m getting a bit tired of telling people that most Linux distro’s these days are “as easy”, or “easier” than Windows to install on the VAST majority of systems… and nearly never require the command line for installation, or at any other time… there are GUI tools for just about everything (like Windows), you just need to learn where to look (like you did in Windows, you weren’t born knowing how to use Windows either :wink: ), unless there is a problem with some non-mainstream piece of hardware.
(there is nothing strange about this… try loading XP onto an SATA hard drive, if you don’t understand how to install something like the ICH9 SATA drivers… even harder if you don’t have a floppy drive… for harder, read impossible unless you slipstream the drivers into the CD).

How much easier can it be than boot from the CD, answer a few questions… done.
http://linux.co.uk/index.php/pages/installation/
even Dual boot setups are quite easy… and don’t require the command line… try that in Windows :wink:

The ONLY reason you see CLI command used in forums, is because it is MUCH eassier to type, leaves less room for interpretation, and can be copy/pasted.

Windows forums would give responses in CLI format too… if the Windows CLI actually did much.

Slitaz is VERY small and runs directly from RAM, which is why its interface is simple… but it IS fast.

500mb RAM is enough to run most Linux distro’s, though 1gb would be better for the full GNOME or KDE desktops.

Let us know what you’ve tried, and what the problems were and we’ll be more than happy to help.

If you’re new to Linux, can I suggest Ubuntu 10.10, or Linux Mint 10 (main edition)… pick one of those, attempt to install it, and if you run into problems, tell us what they are.

Hi, Thanks for your reply, Laptop is an IBM Thinkpad T22 P3 with 500MB of Ram (max for this machine).

It came with Windows 98 but has been running windows XP Home for 3years now with no problems.

I have installed SliTaz on the computer on 2 partitions. This is the only operating system on the computer as windows XP has been completely removed and a Linux file system installed.

Here is a list of the distros I have tried:
VL5.8-std-LIVE.iso
ubuntu-10.10-desktop-i386.iso
slitaz-3.0.iso (installed and working)
pclinuxos-lxde-mini-2010.12.iso
lunar-1.6.5-i686.iso
Fedora-14-i686-Live-Desktop.iso
enlisy-07.1-live.iso
DL3.5_20092802.iso

Some get to an installation or multi-choice screen

Others start to install Linux

All find some reason to stop the installation, I have downloaded each one from different down load mirrors and used two different CD burning programs.

All to no avail, have not given up but if I am having this much trouble then people who want it working out of the box could be discouraged.

It DOES work “out of the box” for the VAST majority, but occasionally there are problems with specific hardware, as with ANY OS… I’m afraid you are just one of the unlucky ones.

Please stop drawing conclusions about Linux as a whole, based on one PC having issues that (at this point) could be due to anything.

Anywho…

I’m having problems finding a common thread between the distro’s you’ve mentioned that doesn’t apply to Slitaz too, but have a feeling it might be graphics related…

Can you boot to Slitaz, open a terminal, and send the output from these 3 commands:

uname -a
Xorg -version

(remember Linux commands ARE case sensitive, so that’s a capital X)

lsmod

As it’s probably graphics related, you could also try this…

Boot from your 10.10 LiveCD, and as soon as you see:

http://linuxforums.org.uk/MGalleryItem.php?id=1122

displayed at the bottom of your screen… keep hitting the Space Bar until…

A screen similar to this will appear and ask you to select a language… select English and hit Enter:
(if you get to the purple Ubuntu screen with the 5 or 6 dots, you missed it and will have to try again)

http://linuxforums.org.uk/MGalleryItem.php?id=1132

Press the F6 key, and a menu will open as in the above picture.

Hit the Esc key to exit the F6 menu (you MUST enter F6 then exit the menu, or the White text won’t appear)

You will now see some WHITE text just above the F1 through F6 options, that looks like this:

http://linuxforums.org.uk/MGalleryItem.php?id=1082

Now replace the:
quiet splash
with
xforcevesa

Press Enter to “Try Ubuntu without installing”

now see if you can boot and install.

At the very least, removing the quiet splash option may allow you to see where in the boot process the system is hanging.


IF you manage to get Ubuntu installed, you will have to enter thiis setting once more, when it tells you to reboot… but you’ll only have to do it once.

After you finish installing Ubuntu from the CD, (when you first boot from the hard drive) you will need to enter the xforcevesa option again, but the way you edit the boot options is now slightly different…

As soon as your BIOS POST screen disappears, and you see:

http://linuxforums.org.uk/MGalleryItem.php?id=1122

Press SHIFT key, you will be presented with the GRUB menu

Select the ‘default’ Ubuntu kernel (usually the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen like this:

http://linuxforums.org.uk/MGalleryItem.php?id=1152

Press DOWN ARROW until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now you can enter additional kernel boot options… the nomodeset option has been added in the above screenshot… but you don’t need to add that, you just need to replace quiet splash with xforcevesa

Now hit Ctrl+X to boot.

Once booted, go to System>Administration>Additional Drivers, and see if you are offered any drivers to install.

One thing I HAVE noticed is that there are a fair few pages about people having a sound issue with Ubuntu 10.04 on an IBM T22… the sound issue will probably be easy to fix, and at least 10.04 installed for them… maybe you should give that a go.

Slitaz 3 seems to be using an earlier kernel (2.6.30) than Ubuntu 10.10/PCLinuxOS 2010/Fedora 14, so it may be a kernel regression (so far I haven’t spotted any reported bugs though)… Ubuntu 10.04 uses a kernel version (2.6.32) closer to Slitaz 3’s than 10.10 does, so you never know :slight_smile:

While I wait for the output from those 3 commands, I’ll keep digging and see if I can come up with anything concrete.

Stick with it. I’ts a bit like driving a different vehicle for the first time.

I had a few (not many ) teething troubles but, now after a lot of help from this site (particularly Mark) I now have a virus free and resistant operating system that can do virtually everything a Windows or Mac can. It’s slick modern and free! If you really want a great operating system embrace the changes and learn from experienced people who (thankfully) are offering their knowledgeable advice totally free.
Welome to Linux…enjoy. :slight_smile:

Hi, the answers to the readout questions are below:

uname -a

Linux Small 2.6.30.6-slitaz #1 SMP Sun Mar 28 16:39:51 CEST 2010 i686 unknown

Xorg -version

X.Org X Server 1.5.2
Release Date 10 October 2008
X Protococol version 11, Revision 0
Build Operating System SliTaz GNU/Linux
Current Operating System: Linux Small 2.6.30 #1 SMP Sun Mar 28 16:39:51 CEST 2010 i686
Build Date: 02 March 2010 02:38:08AM

lsmod

Module size used by
snd_cs46xx 70540 1
gameport 9348 2 snd_cs46xx
snd_rawmidi 16920 1 snd_cs46xx
snd_seq_device 5544 1 snd_rawmidi
snd_ac97_codec 88736 1 snd_cs46xx
ac97_bus 1308 1 snd_ac97_codec
snd_pcm 51780 2 snd_cs46xx, snd_ac97_codec
snd_timer 16344 1 snd_pcm
snd 43584 8 snd_cs46xx, snd_rawmidi,snd_seq_device, snd_ac97_codec, snd_pcm, snd_timer
soundcore 5180 1 snd
snd_page_alloc 7256 2 snd_cs46xx, snd_pcm
yenta_socket 20988 0
rsrc_nonstatic 9136 1 yenta_socket
pcmcia_core 27628 2 yenta_socket, rsrc_nonstatic

Will also try the other things you suggested.

Many Thanks.

Yup, at a guess I’d still say it’s related to the S3 savage drivers, which Slitaz doesn’t appear to be loading… though could still be a kernel regression.

If I were you, I’d try Ubuntu 10.04, and if necessary try the xforcevesa kernel boot parameter.

Have also tried what you sad with Ubuntu 10.10 and it failed with the following report:

BusyBox v1.15.3 (Ubuntu 1:1.15.3-lubuntu5) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

(initramfs) mount: mounting /dev/loop0 on //filesystem,squashfs failed: input/output error
Can not mount /dev/loop0 (/cdrom/casper/filesystem,squashfs) on //filesystem.squashfs

Open to suggestions.

Thanks.

OK, I/O error = input/output error

If this is when you attempt to boot from the LiveCD…

Either the CDROM is corrupt, the CD drive is having problems reading it, or you have memory problems

Boot to the GRUB screen by hitting any key, and select “Check disc for defects”… if that is OK, try “Test Memory” (Memtest86+) to check the RAM… if both check out OK, let me know.
(unlikely to be RAM if Slitaz works, but still possible)

If the “Check disc for defects” fails, you’ll need to burn again at a slower speed, also check the MD5 checksum of the ISO you burned the disk from, to make sure the ISO image wasn’t corrupt.

[EDIT]

See here, onwards:
http://linuxforums.org.uk/general-help-advice/advice-on-setting-up/msg40482/#msg40482

If it turns out to be the CD/DVD drive, have you either got an external one, or can your system boot from a USB pendrive (memory stick) ?

Hi,

Passed memory test OK but disk test failed with same report -
(initramfs) mount: mounting /dev/loop0 on //filesystem,squashfs failed: input/output error
Can not mount /dev/loop0 (/cdrom/casper/filesystem,squashfs) on //filesystem.squashfs

I tried the CD on a P4 laptop with the same problem so would seem to be a problem with the burning or the image file.

However I have managed to load a Linux version called Peppermint-One so will take a look at this.

So it is strange that there is no problem with this version yet I have had loading problems with 8 other iso image files. I can not believe that all these files are corrupt or failed to burn even at 4x speed.

Will let you know how I get on with Peppermint-One.

Will also try putting one of the image files on to a USB stick.

Thanks for your help so far.

You might want to try burning one to a DVD instead of a CD… sometimes old drives have an easier time reading DVD’s than CD’s… sounds strange, but it’s true.

Your system may or may not be able to boot from a USB Stick, only newer systems are pretty much guaranteed to, most older systems have problems, but worth a go… good luck :slight_smile:

I’ve read some good things about Peppermint One/Ice, and it’s Ubuntu/Mint based and uses the Ubuntu repos, so there should be plenty of software available in the package manager.

As I said it’s based on Ubuntu/Mint and AFAIK uses the same Ubiquity installer, so I’d be “fairly” sure that if Peppermint works, so should Ubuntu and Mint… although It is based on the 10.04 version of Ubuntu… maybe give that version a go if Peppermint isn’t for you… or Mint 9 (also based on Ubuntu 10.04).

It also uses the LXDE desktop so should be quite light on system resources.

I hope it suits your needs but if not, and you still need help, just ask… have fun :slight_smile:

Thanks for all your help on this subject.

Peppermint seems to be a good option for me, getting to grips with it after only 30 mins.