Novatech laptop Driver CD only for Windows. [SOLVED]

I have recently bought a Novatech laptop with no OS, I have installed Mint 17.3.

The driver installation disc is only supported by Windows. I have just spoken to Novatech I told them that the reason I bought this machine with no OS was to avoid using Windows. Their tech guy says that he doesn’t know how to install compatible drivers to Clevo as used on this computer by way of Linux. At the moment most, not all, of the Fn buttons don’t work i.e. the screen brightness and so called ‘airplane’ functions are inoperative.

The drivers he says are needed are Clevo model W950JN. Is there a way round this, do you think?

Advice as to how to get the function keys working would really be appreciated - Very Happy New Year and thanks!!

Do any of the keys that need the Fn key pressing work ?

Is there anything in the BIOS about changing the function/action key mode ?

Hello mark - I went into the BIOS at boot up looking for any mention of Fn/action and couldn’t find anything, however, i must have pressed a key because the laptop won’t boot up at all now. I just get a black screen saying:

‘Reboot and select proper boot device or insert boot media in selected boot device and press a key’

When I get back into the BIOS, under Boot heading it says:

UEFI Boot [enabled] - (this is highlighted)
Network Stack [Disabled] - (this is not highlighted)

What have I done? :cry:

Did you change the boot order, or disable booting from the hard drive ?

There’s normally a setting in there somewhere called something like “reset BIOS defaults” or similar … try that.

I don’t know what has happened, the black screen says reboot and select proper boot device but when I reboot and open the BIOS no option for booting is shown. The manual says that f7 is supposed to reset the BIOS defaults but nothing changes when I press it. I don’t know what I pressed in error this morning but the machine is not responding to anything.

when you say there are NO boot options ? … is there a key you can press to access the boot device selection screen ? … and if you plug in a LiveUSB is that listed ?

No, there are no boot options. Under the Boot Heading it says: ;Boot Option Priorities’ under that is ‘UEFI Setting’.

Click on that I get: ‘UEFI Enabled’ under that 'Network Stack Disabled,

Live USB is not detected but I can boot of the installation CD.

I can’t find a key to access boot device selection screen.

The boot device selection screen is usually accessed via an “F” key immediately after the POST (power on self test) screen

On my HP, I turn ON the laptop, and immediately hit the F9 key … I’m then presented with a list of boot options


But on your system, what is displayed if you use the arrow keys to highlight “Boot Option Priorities”, then hit the enter key ?

.

When I boot up the only response I get is from F2 that takes me straight into the set up utility. When I scroll across to ‘Boot’ heading the page is headed with ‘Boot Option Priorities’ this is not highlighted and I can’t click it. Under this is a highlighted ‘> UEFI Setting’ if I hit return I get the option of ‘Enabled’ or Not Enabled’ To the right there is a comment: ‘If UEFI Boot set Enable, it’s in UEFI Mode with secure boot.’

At no stage have I been presented with a list of boot options. The closest I get to that is the heading I described, above.

[b]EDIT: On boot up with the Linux disc in the CD drive on pressing F2 and entering ‘Setup’ under the ‘BOOT’ heading I now get:

'Boot Option #1 [UEFI: TSSTcorp CDDVDW SU-")*HB]
[/b]
There is no mention of a boot option from the HDD.

Is it possible that your machine came with the UEFI disabled (as it came with no OS) and you installed Linux using that mode?
If so then the grub was installed onto the MBR and in UEFI that is not read.
Try switching the UEFI boot to disabled.
As for boot options try all the F? keys (not just the F2, except F7) to see which takes you to the boot device selection.

Bingo! That works - UEFI now disabled - many thanks to you and Mark for all your input. I feel a bit awkward always asking for help, can I revert to the original problem of the non-functioning fn buttons?

I am unable to operate the screen brightness. There is no sound, though the fn button shows the volume control is working. Some others work some don’t, I can itemise these if required.

On my Novatech the Fn+F8 makes the screen darker, and Fn+F9 makes the screen brighter. These correspond with the symbols on the keys.
If I turn on the laptop and immediately hold the F12 key it shows the boot options.
This boot option only works ONCE. The next startup will revert to the BIOS setup.
Try looking up the threads I started as I am sure I have had all these problems before and got them sorted on this forum :wink:

PS I use the loudspeaker icon in the toolbar to raise/lower the volume

Thanks donwatson, I know what fn keys to use, it’s just some of them don’t work as the driver/setup disc supplied with the machine is not recognised by the OS I’ve installed. Ironically the sound volume fn key works but I have to install a sound driver.

Yeah, I got 3 disks from Novatech 2 were for Windross (0ne of them for Win 8.1) and a Generic grivers disc for the Novatech computer.
With Marks help I have what I want running now. ;D

Getting back to your original question I found nothing in the BIOS about changing the keys. In addition, as I said, there is no sound but the volume slider works via a fn key in the absence of sound.

Is the sound issue new, or has it never worked ?

It has never worked, same with the screen brightness. Everything is working OK in the sound preferences - nothing muted.

what’s the output from:

sudo lshw -C multimedia

and

aplay -l

Thanks Mark:

EDIT: Sorry, I sent you the info incorrectly, will resend shortly.

Mark, here is the correct reply to your last question.

graham@graham ~ $ sudo lshw -C multimedia
[sudo] password for graham:
PCI (sysfs)
*-multimedia
description: Audio device
product: Intel Corporation
vendor: Intel Corporation
physical id: 1f.3
bus info: pci@0000:00:1f.3
version: 21
width: 64 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list
configuration: driver=snd_hda_intel latency=32
resources: irq:143 memory:df220000-df223fff memory:df200000-df20ffff
graham@graham ~ $
graham@graham ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269VC Analog [ALC269VC Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: ID 2809 Digital [ID 2809 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
graham@graham ~ $