Novice: Is it me, Linux or my laptop thats the problem? Bit long winded...


Iv been using Linux for about a year but I still really struggle to learn it.
I have a Samsung NC110P that appears to run LXLE (originally with windows 7 starter) with little issue, with 64bit iso’s.

But when it comes to installing and using Linux on my Samsung P510 business netbook (originally Windows Vista, ‘32bit with 64bit capability’) it seems there are never ending problems. I have tried a few distros now within the last year, the latest versions, all MD5 sum checked, from live USB:
Ubuntu 32bit (installed but booting temperamental)
Linux Mint 32 bit and 64 bit (all failed to boot even from live image)
Lubuntu 64bit (failed to boot / install)
Kubuntu 32 bit (installed but failed to save any changes, temperamental whether it would boot)
LXLE 64bit (boots live but fails to install)
Manjaro 64bit (tried this today- fails to boot from live usb, says there is no EFI there).
The NC110P will boot these other distros.

Usual case with boot failure is the ‘no video mode found; booting in blind mode’ - tried many workarounds in each distro related forums without success.
Have tried figuring out whats the deal with this netbook - if any use the specs are: Intel core 2 duo CPU P7350 2GHZ (capable of 64bit); 4GB RAM DDR2 SODIMM (2x2GB); Intel GM45/PM45+ chipset Intel ICH9M; Graphics Mobile Intel 45 express chipset (internal); NVIDIA NB9m-GE (external); seagate SSHD 1tb; BIOS 2008 Pheonix Tech version 06… No idea how it is meant to go from 32 bit to 64bit either.

I’m totally lost now, does anyone have this laptop or see something I am blind to?


Ubuntu, Kubuntu, Lubuntu are much the same thing — with either Unity, KDE or LXDE desktops.

Linux Mint and LXDE are based on Ubuntu.

When you say that Ubuntu has temperamental booting what do you mean?

I wonder why the others should be different?

Have you come across

There is an old suggestion that Debian Wheezy works. Wheezy is now outdated.

I would try a Debian netinstall. Go for the amd64. If it says you need firmware (drivers) and you can connect by cable, ignore that (but take a note). You can install it later.

Or try the Debian install with firmware (drivers)