NTFS Failing to mount - SOLVED -

Its not very often this happens.
To narrow the problem down, I switch the PC off then unplug the HD cables and give them a quick clean.
That doesn’t solve it.
At boot-up it still says unable to mount.
When booted up I try and open the HD but get this;

http://img189.imageshack.us/img189/4923/failtomount.th.jpg

Something is not loading up properly at boot-up.

Is this an intermittent problem?
Are you mounting it on boot with fstab?
What is the output from below?

cat /etc/fstab

Is ntfs-3g installed?

Heres the result

[spoiler]root@Petes-ubuntu-pc:/home/peter# cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

proc /proc proc nodev,noexec,nosuid 0 0

/ was on /dev/sda1 during installation

UUID=959cb526-06f8-4d5d-bec2-a6b42f438b07 / ext4 errors=remount-ro 0 1

swap was on /dev/sda5 during installation

UUID=e56dad6b-358f-4948-b51f-4abce81f50b1 none swap sw 0 0
/dev/sdb1 /media/Win-Storage ntfs-3g defaults,user,locale=en_GB.utf8 0 0

/dev/sdc1 /media/Win-MyDocs vfat defaults,user,locale=en_GB.utf8 0 0

/dev/sdc1 /media/Win-MyDocs ext4 rw,user,exec 0 0

/dev/sdc1 /media/Win-MyDocs ntfs-3g defaults,user,locale=en_GB.utf8 0 0

/dev/sdd1 /media/Win-Video ntfs-3g defaults,user,locale=en_GB.utf8 0 0

root@Petes-ubuntu-pc:/home/peter# [/spoiler]

Is ntfs-3g installed?
I think so

Mark Greaves (PCNetSpec) has helped me with it in the past (I switched to Ubuntu days after the last release from Windows)

You can check the output of

dpkg -l ntfs*

If you see something like rc for the package, then you have uninstalled it.

If you have installed ntfsprogs that would have automatically removed ntfs-3g

Anyway, I will leave you in Mark’s capable hands

You have 3 ntfs-3g mounts … is it only one of them that fails ?

I’m a bit baffled why the error dialog refers to it as “Storage” when fstab mounts it at /media/Win-Storage

Can you see its contents if you run:

nautilus /media/Win-Storage

?

Can you send the output from:

mount

I get;
root@Petes-ubuntu-pc:/home/peter# dpkg -l ntfs*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
++±==============-==============-============================================
rc ntfs-3g 1:2011.4.12AR. read/write NTFS driver for FUSE
ii ntfsprogs 2.0.0-1ubuntu4 tools for doing neat things in NTFS partitio
root@Petes-ubuntu-pc:/home/peter#

Yes, 2 fail as they’re NTFS
The first one gives; (The window is empty showing no files?)
root@Petes-ubuntu-pc:/home/peter# nautilus /media/Win-Storage
Initializing nautilus-open-terminal extension
Initializing nautilus-gdu extension

— Hash table keys for warning below:
→ l2049
→ root
→ inode/directory

(nautilus:5883): Eel-WARNING **: “unique eel_ref_str” hash table still has 3 elements at quit time (keys above)

— Hash table keys for warning below:
→ file:///media

(nautilus:5883): Eel-WARNING **: “nautilus-directory.c: directories” hash table still has 1 element at quit time (keys above)
Shutting down nautilus-gdu extension
Shutting down nautilus-open-terminal extension
root@Petes-ubuntu-pc:/home/peter#

The second one gives;
root@Petes-ubuntu-pc:/home/peter# mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/sdc1 on /media/Win-MyDocs type ext4 (rw,nosuid,nodev,commit=0)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/peter/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=peter)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev)
root@Petes-ubuntu-pc:/home/peter#

As Sezo pointed out …

[b]rc[/b] ntfs-3g 1:2011.4.12AR. read/write NTFS driver for FUSE

says that ntfs-3g has been removed.

a dpkg status of “rc” means the package has been removed but the config files were not

The fact that NEITHER of the partitions that should be being mounted as ntfs-3g by fstab (Win-Storage & Win-Video), are actually being mounted … would also support this.

reinstall ntfs-3g

sudo apt-get install --reinstall ntfs-3g

and reboot.

Thanks for that Sezo & Mark, it’s fixed it.
This does my head in, I hate being a noob and not knowing how to sort simple problems out. It’s like going back 30 years to when I first started on computers.
I can sort out problems with windows but this is a whole new scenario. I don’t want to go back to Windows as I didn’t like the way it was going.

The only way to learn is to do! At least you’re not giving up :wink:

I’ve just got a LOT of reading to do.
This OS can literally be taken to pieces unlike Windows which is very user unfriendly and Gatsey wont allow it.
Ubuntu (Linux) is the BEST OS there is.

Though some will dispute (and sometimes with a vengeance) that “Ubuntu” is the best, and indeed even that Ubuntu is an “OS” (more a Linux distribution) … you won’t find many around here that will dispute “Linux” is the best OS :slight_smile:

Or for those that will moan about “Linux” being an OS, GNU/Linux :wink:

This OS can literally be taken to pieces unlike Windows which is very user unfriendly

You’ve hit the nail squarely on the head there … Linux is YOURS to do with what you like, and is happy to provide you with the tools (and source code) to modify it.

Previously (in Windows) it would never have crossed my mind to do things like “tweak” drivers to add vendor:product ID strings … even if it were possible … and Linux seems to have “tweakable” config files for everything.

I think that be fighting talk laddie!! :wink:

Hehehe … told you :wink:

Well, after using Windows since Win 95 I beg to differ. When I got XP on a new system I used to have to reinstall the ocmplete OS almost every WEEK due to crashes and system failures.
Since installing Ubuntu 11.10 (I got it just DAYS after it was released) I have not had to reinstall ONCE.

The point being made is that Ubuntu does NOT = Linux.

There are MANY Linux distributions, and some will argue Ubuntu is most definitely NOT the best of them.

Nobody was suggesting Windows was better :o

The problem was that you stated “Ubuntu (Linux) is the BEST OS there is” … how many other Linux distributions have you tried ?

If there’s one thing you’ll notice about Linux users, it’ll be that they can be VERY (shall we say) “protective” of their chosen distro :wink:

Sorry, I meant it in a broad sense. meaning in a way, Linux was the engine.

Yes, Linux is the best OS (not counting BSD or Solaris).

Penguin eats Apple then smashes Window(s)!!