Odd thing going on with ITV player- won't play on my Peppermint netbook

Something weird is going on with ITV player guys. It asks for me to tick some setting in my browser ( I use Chrome but also have Firefox on it) so it will stream. I did it in Chrome and it still said to tick that setting, so I tried it in Firefox, ticked the setting but it did the same thing as well. Yet it works on my Chromebook.

I had the netbook/notebook on all day yesterday as my Mum came for lunch and I thought she might wanna watch something , so set it up as I have the large Dell monitor for it now. She didn’t, but I kept it running anyway for music, and decided to leave it on after she went, instead of using the Chromebook. I fancied watching that new period drama Sanditon, but ITV player has gone odd with this new setting.

I won’t use the monitor/netbook that much for watching things ( it’s more for me using it to do online tutoring and to do photo editing) but it’s nice to have the option if I want to watch something on a bigger screen. BBC iplayer works on the netbook fine.

I went here
https://www.itv.com/hub/sanditon
and it worked for me in Firefox and Chrome.

So what exactly is it asking you for ?

Here is the page asking for new settings to be checked.

https://help.itv.com/hc/en-us/articles/360004308253-How-do-I-update-my-browser-settings-to-be-able-to-play-content-

I’ve done all that but would not work on the Peppermint netbook.

okay, open firefox

click Edit > Preferences

on the ‘General’ tab, scroll down to

Digital Rights Management (DRM) Content

and put a tick in the box labelled “Play DRM-controlled content

Close Firefox

Re-open Firefox

go to:-
https://www.itv.com/hub/sanditon

and see if it works ?


If not, what’s the output from:

dpkg -l | grep "google-chrome\|firefox"

Sorry for very late reply Mark, been that busy and not using netbook. I’ll try that later as I have it on sleep mode. My Chromebook went to white screen and had to google what to do ( reset)- it’s working now, phew.

I can’t even try and see if it works as there is no arrow to click onto the videos on either Firefox or Chrome. I already had done the settings in the preferences.

matildaw@ASUS-X102BA ~ $ dpkg -l | grep “google-chrome|firefox”
ii firefox 66.0.4+build3-0ubuntu0.18.04.1 amd64 Safe and easy web browser from Mozilla
ii firefox-locale-an 66.0.4+build3-0ubuntu0.18.04.1 amd64 Aragonese language pack for Firefox
ii firefox-locale-en 66.0.4+build3-0ubuntu0.18.04.1 amd64 English language pack for Firefox
ii google-chrome-stable 74.0.3729.131-1 amd64 The web browser from Google
ii peppermint-firefox-themer 9.0.0.1 all Peppermint Firefox theme locker.
matildaw@ASUS-X102BA ~ $

Are you running system updates ? … because Firefox should now be at version 69 not 66, and Chrome should be at 79 not 74

Er no, thought the netbook/Linux would just do it automatically or at the very least an update box come up. Maybe I’ve been using the Chromebook that much I’ve forgotten about updates lol. What’s the best way to update?

If this is Peppermint, look in the system tray (bottom-right of screen by the clock), and you’ll see a shield shaped icon (probably with a blue circle in it at the moment, signifying you have updates waiting) … click that icon.

In the resulting window, click the “Refresh” button.

When it’s finished refreshing, click the “Install Updates” button.
(enter your password when prompted, and click “OK”)

When updates have finished (indicated by the window closing and the shield icon in the system tray now having a green tick), REBOOT.
(you don’t normally need to reboot after updates, only if you got an updated kernel … but you probably did, so reboot now)

Once rebooted, try ITV Player (works for me in Firefox).


And from now on, run updates every now and again (weekly, or whenever you see the blue circle in the shield icon would be good) :wink:

.

Thanks will try that later. I think that explains why ITV.com works on the Chromebook as it was recently updated ( its last one as I mentioned in another thread).

Oh, I have another enquiry for you Mark. I mentioned I gave Dave the Mint Dell netbook. I couldn’t get it to connect to my wi fi ( the last time I did I was on Talk Talk but I switched to EE a few months ago) and I went to the network manager but EE did not automatically get scanned, so I couldn’t figure out what to put into the boxes to make it connect. What would I do to make it connect? Secondly, the sound doesn’t work ( and it isn’t set to mute).

Neither of these additional problems really fall under the title “Odd thing going on with ITV player- won’t play on my Peppermint netbook” … new topics with descriptive titles please.

True lol. I’ll ask him if he’s got those things to work then start topics if he hasn’t.