[ON-HOLD] System Freezing Up Regularly

For the past week (possibly 2), my OS has been freezing up and taking a while to recover itself.
I have had the same couple of programs run at start and not installed any extra programs and only installed what the system wanted to install as updates.
The CPU History in the System Monitor shows the CPU’s, either one or all 4 spiking at 100% and the system then locks up with me unable to do anything until the CPU usage drops back to normal.
I have added another tab to show the temp of the CPU and MoBo and they were high, spiking at 80C. I have since cleaned all the dust out and the temp has lowered to a high of 45C and the system still freezes.
I can be simply clicking on another program to bring its window to the front and the system will freeze, sometimes the clock will still show as normal with the seconds cycling though 00 - 59 and sometimes the clock will also freeze.
I have just done a system update and the system is still freezing.


The screenshot above shows the CPU’s at 100% and all I had done was to select the System Monitor to show itself.

Have you run


to get a handle on which process is eating your RAM when it locks ?

and have you tried booting an earlier kernel ?

I checked with ‘top’ and my browser and baloo are the highest users

I’ve not yet tried an earlier kernel, however, I googled to see if there’s a problem with my specific MoBo (M5a78L-M USB3) having any problems shutting down or locking up and found that an earlier version had the problem. The solution was to tweak the LLC setting. I’ve gone into my OC settings and set it to manual with the first switch set to it’s lowest possible (200). As I write this post, I am still having ‘freezes’.

I will give an earlier kernel a try (if I still have any old ones that I have not cleaned out), then if that does not work, I will reset the BIOS.

Baloo is a file search indexer in KDE … try disabling it (at least temporarily) and see if that stops the freezing.

If it does, it might indicate a corrupt (or possibly full) file system.

What’s the output from

df -h
df -h

Filesystem Size Used Avail Use% Mounted on
udev 16G 0 16G 0% /dev
tmpfs 3.2G 9.5M 3.2G 1% /run
/dev/sda1 80G 53G 24G 69% /
tmpfs 16G 84M 16G 1% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 16G 0 16G 0% /sys/fs/cgroup
tmpfs 3.2G 16K 3.2G 1% /run/user/1000
/dev/sdc1 1.8T 691G 1.1T 40% /media/pooky2483/INT-01
/dev/sdb1 459G 562M 435G 1% /media/pooky2483/INT-02
/dev/sdf1 7.3T 5.9T 1.1T 85% /media/pooky2483/EXT-05-8Tb
/dev/sdh1 2.7T 1.9T 746G 72% /media/pooky2483/EXT-03-3Tb
/dev/sde1 7.3T 4.2T 2.7T 61% /media/pooky2483/EXT-06-8Tb
/dev/sdd1 3.6T 2.7T 725G 80% /media/pooky2483/EXT-02-4Tb

I’ve turned off indexing and I’m still getting freezes, both where the clock continues and stops.
How do I empty or wipe the file system! (baloo)

I’ve just discovered that I don’t need to reset the BIOS as the system does that itself upon a ‘hang’ by just rebooting.

C.P.R.(CPU Parameter Recall)

The BIOS C.P.R. feature automatically restores the CPU default settings when the system hangs due to overclocking failure. C.P.R. eliminates the need to open the system chassis and clear the RTC data. Simply shut down and reboot the system, and the BIOS automatically restores the CPU parameters to their default settings.

So, that’s that option gone…

Leave top running … then when the system freezes, what was the top process in top at the time the system froze ?

It seems to have fixed itself as it’s not lagging any way as bad as it was.
The system has had quite a few updates, something in there could have sorted the problem out.
I’m leaving this open as the problem could re-appear.

The system had completely frozen again, Saturday, I was unable to see the usage in top as I only have one monitor, I hope to be able to rectify this and will be able to keep an eye on the results of top.

So is this system overclocked ?

If so, does it freeze when it isn’t ?

No, I’ve re-set the settings back to default and if you read one of my previous posts here, you can read one of the specs of the system is that upon a freeze due to overclocking, the syetm re-sets the OC settings upon a reboot. And as for the system freezing when not overclocked, yes it does, but not very often. The last time it did that was actually a couple of days ago but I forgot to have terminal on-screen showing the results of ‘top’ (which I now do, but it’s not frozen since).