Open Office and network folders (Resolved)

Dear All,

I am looking to see if Open Office can replace MS Office 7 and I have a problem.

Open Office can not see any of the other computers on my network. I am using Open Office 3.2 on Peppermint-one.

Thanks in advance.

Do you mean the shared folders on the other PC’s isn’t available/visible in OpenOfice’s “Open” dialog ?

Are they available from within the File Manager > Go > Network Drives ?

If so, you can either

  1. Open any documents from there.

or

  1. Start OpenOffice, go to File > Open > File name …and enter: ~/.gvfs/ and hit the “Enter” key to display the contents of the hidden ~/.gvfs/ directory… you should now be able to browse any available network shares.

(you can do the same thing in a “Save” or “Save As” dialog)

There are probably better ways round this, like mounting the shares as visible folders in your home directory.

Hi and thanks for the reply.

Yes I am referring to the sheared folders on other computers on the system.

They are available in File Manager > Go > Network Drives but this option is not available from Open Office.

Your tip works OK but requires operator input. It must be possible for Open Office to see sheared folders without having to enter this code each time you wont to access or save a file on another computer.

I have heard of a program called smb4k that may help in this matter has anyone get experience of using this program and would it solve the problem.

smb4K is for the KDE desktop, and is just a network browser, but you can already browse the shares… also I have no idea how it will behave in LXDE… and it will require loads of dependencies… DON’T BOTHER, I’m pretty sure it wouldn’t solve your problem anyway.

The problem is that the ~/.gvfs directory is hidden…

Note: All files and directories that start with a “.” are hidden by default… the problem seems to be that OpenOffice has no option to UN-hide them, and the LXDE file manager (PackmanFM) has no “easy” way to mount them.

So create a link to ~/.gvfs that isn’t hidden :wink:

cd ~
ln -s .gvfs Shares

The above 2 commands will make your home folder the current directory, then create a link there to the hidden .gvfs directory called Shares … the new “Shares” directory will be visible from within OpenOffice.

You can then rename the new “Shares” directory in the normal way if you want.

Is that what you want ?

I put the commands in a terminal and the shares Dir is visible. However it only contains the following items - 2 zero byte files nothing else. If I try to access the Dir I get an error message (input/out put error).

OK, you need to automount the Windows shares, then they will become available in the new “Shares” folder.

To do this you are going to need to install the gigolo package, set it to run at startup, then set it to mount/remount the shares every 60 seconds…

  1. Install Gigolo:
sudo apt-get install gigolo
  1. Set it to start at bootup:
cp /usr/share/applications/gigolo.desktop ~/.config/autostart/gigolo.desktop
  1. Configuring Gigolo:
    Launch Gigolo (Menu > System Tools > Gigolo) then go to Edit > Preferences

General Tab:
File Manager = gvfs-open
Bookmark Auto-connect Interval = 60

Interface Tab:
Enable - Start minimized in the Notification Area
(this will make sure Gigolo starts minimized at bootup and and place a small icon on the panel)
Disable - Show auto-connect error messages

Toolbar Tab:
Enable - Show Toolbar

Close Preferences and select the View menu:
Enable - Toolbar
Enable - Side Panel
Enable - Status Icon

  1. Using Gigolo as a Network Browser:
    When you open up gigolo click on the Network tab on the very left side panel and it will eventually show all your workgroups and all the hosts within those workgroups… Once you find the share you’re looking for, double click to mount it. A dialog box will open asking for the following information:

Service type = Windows Share
Server =
Share =
Username =

The remote share should be displayed in the right hand panel of Gigolo and double-clicking the share will open a file manager so you can access it’s contents.

  1. Settting Gigolo to mount/remount the remote shares automatically:
    In the left hand panel of gigolo right-click the remote share and select Create Bookmark

Bookmark name = <Give it a name, or accept the default>
Auto-Connect = <—IMPORTANT, make sure you tick this box
Service Type = Windows Share

Ticking “Auto-Connect” will connect to the remote share if it is not up at the time you boot and reconnect to the share if the connection is interrupted for some reason.
“Auto-Connect” will probe the network at the interval specified by the “Bookmark Auto-Connect Interval” you set in step 3) and then mount/remount the share.

Now reboot… the “Shares” folder you created earlier, should contain your shares (within 60 seconds of the desktop, or them becoming available on the network), and they should be available in OpenOffice.

Tested on PeppermintICE running in a VM, so should work :slight_smile:

Thanks for the information, it’s working well now.

Strange that Open Office dose not do this by default and work out of the box in this respect.

I am all in favor of not using Microsoft products whenever possible but if they do not work out of the box they will never be main-stream.

Item is resolved, Thanks yet again.

I don’t think it’s so much a problem with OpenOffice… more a Linux security feature (network shares not being mounted automatically unless specifically told to do so, to stop the potential spread of viruses etc.) coupled with the fact that the LXDE desktop does not make mounting of network shares as easy as some others.

It’s a difference in philosophies…

Windows = Make everything easy at the expense of security.

Linux = Make everything possible, but don’t enable features by default if they could pose a potential security risk… leave it to the user/admin to decide.