Operating system not found - DVD Issue

Hi,

I’m trying to use an older laptop, but I’m getting a “Operating system not found” error message when I try to use the DVD. In fact I can’t even seem to read from it using an old Linux distro (Lite 1) that was on it (I installed it some time ago). I’ve tried replacing the DVD with other DVD drives that I know work, but still get the same issue. It’s an Acer TravelMate 4062LCi. I know the DVD did work. but suddenly stopped. I don’t want the OS that is on there, but I can’t install anything else as it is the only way to install - no USB support in the BIOS. Any ideas as to what’s wrong?

Hi Matt.

Excuse me being a bit slow, but it’s not quite clear whether you are always using the term DVD to mean the DVD reader is not working or the machine is not booting from a Live DVD or you simply can’t read a conventional DVD disc. Or perhaps all three. Let us know and someone will have a go at helping.

Keith

My apologies. It’s accessing the drive that’s the problem not the DVDs themselves. The DVDs work fine in other systems. The system, here, seems to have trouble accessing anything in the drive - or with any other drive I exchange it with.

Hi Matt
I’m not sure how far I can help you with this, but lets see if your system is seeing the DVD drive,
can you put a disk in the DVD drive then post the following terminal output

blkid

Graeme

Hi,

I get:

/dev/sda1: UUID=“…” TYPE=“ext2” PARTUUID=“a65cfa01-01”
/dev/sda5: UUID=“…” TYPE=“LVM2_mamber” PARTUUID=“a65cfa01-01”
/dev/mapper/linux–vg-root: UUID=“…” TYPE=“ext4”

The file manager and gparted show no CD ROM drive either.

Matt

Ok Matt

With a DVD in the drive (ensure there’s something written on the disc) can you post the output of the following


ls /media 

Graeme

cdrom guest matt

Ok this is looking like a hardware issue. but just to clarify can you post the output of the following

ls /media/cdrom
ls /media/guest
ls /media/matt

Graeme

OK! The HDD’s not working now. >:( So I can’t answer your questions. I’ll wait a while and see if it works.

The fact you’re HDD is not working could be significant

can you you tell me if the drives are connected by IDE or SATA ?

Graeme

Honestly - no.

If I’m correct, the DVD drive seems to have a port on the back that can be seen on the back of this item in Amazon (B082XDSPNV - type this into Amazon uk/us and this item should come up. The item displayed is only to illustrate the connector.) It’s not one of the 'double “L” shaped connectors - SATA? The HDD is one of the older male multi-pin connectors - IDE, I think. This probably means that the system is IDE not SATA. Hopefully this isn’t too confusing.

Ok Matt

I think the problem here is hardware

from the link you gave me it looks like your DVD drive is IDE, and the reason I think this is significant is because of the possibility your HDD and DVD is configured as a master/slave set up, which means they both share the same cable and if the cable is faulty then either or both will fail.

The way to find out is to boot into the BIOS and check if your DVD is listed as a slave ( or not listed at all) if so I suspect the problem is the IDE cable but we need to be sure what cable you have

This is what an IDE cable looks like

https://i.imgur.com/zhAEsZm.jpg

This is what a SATA cable looks like

https://i.imgur.com/iAXt5UW.jpg

Graeme

You may have missed the description in the earlier posts. The unit is a laptop. The DVD and HDD are integral. Although I will check the BIOS.

Edit: removing the DVD drive allows the HDD to load. The Boot order is correct - HDD, DVD, so the problem is causing the DVD to take over even though it’s second. The result is Operating system not found. It doesn’t refer then to the HDD.

Ok Matt

Judging from the product number you posted the DVD drive you have is IDE, so the problem could be the drive itself even though you’ve tried other drives unsuccessfully, because with IDE if it’s configured Master/Slave (and assuming the DVD was the slave drive) you would need to set the the jumpers on the DVD drive to slave for it to work IDE is old technology and not necessarily plug and play.

So going back to the beginning, can you access the BIOS and tell me if the DVD drive is listed and if so is it listed as master or slave ?

Graeme

The BIOS is very basic, and only shows the very basic information. The DVD drive only shows in the boot order. Other than that, there is no indication.

Please note also that there are no Master/Slave jumpers on either of the drives.

The DVD drive only shows in the boot order

Well if it shows in the boot order then the system must be seeing it

can you make it first boot device then try booting a live DVD again ?

Graeme

Not really. At present, I have removed the DVD drive in order to allow the HDD to boot up. The DVD drive is still showing in the boot order. I think it’s a standard setting.

I believe you are right, Matt: depending on the age of a computer, the BIOS may show boot orders for floppy-disc, USB-stick, CD/DVD and HDD even if floppy/USB/DVD drives don’t exist.

Not really. At present, I have removed the DVD drive in order to allow the HDD to boot up. The DVD drive is still showing in the boot order. I think it's a standard setting.

yeah you’re probably right

So am I right in thinking that when you reconnect the DVD drive it just slots inside a bay, you don’t have to physically connect any cables ?

Graeme

emegra, that’s correct.