Operating system not found - DVD Issue

According to this Acer TravelMate 4062LCi - Laptops Direct the 4062lci doesn’t have a DVD it comes with a CD Rewriter, it’s sister model (4062lmi) has a DVD.

Can you confirm for me the drive is DVD and not CD

also according to the same page you should have 3x usb2 ports, but you said there’s no usb bios support, so can you confirm if you do have usb ports and what you mean by no bios support ?

also if connecting the drive stops the HDD booting can you confirm if the drive has a disc in the tray, if so have you tried connecting with the tray empty ?

Graeme

The sticker on the back states that the unit is a LCi. The drive is a DVD reader/CD rewriter.

There are three USB ports, but the BIOS does not allow the USB in the boot order - either through setup or F12. According to the BIOS it is possible to boot from a FDD, which it doesn’t have, and a network. Plugging in a bootable USB (which I know works) into the USB port and starting the computer and pressing F12 doesn’t bring up a USB bootable, either.

Both. With and without a disc in place.

ok well if the HDD isn’t booting only when the DVD drive is connected, then that would suggest the DVD drive is faulty or worse so if you have another DVD drive you can connect it would be worth the effort to confirm that, it would be helpful to know for certain that the drive is ok.

alternatively you can try completely powering down the laptop, remove the battery for 30 secs or so reconnect the DVD drive and try booting up ( I know that sounds crazy but stranger things have happened)

otherwise I don’t know what else to suggest at this point.

RE the USB
it’s possible that it’s capable of USB boot but turned off by default and there may be some setting hidden away in the BIOS you can change to allow it, I had this issue a long time ago where I had to change something in the BIOS to allow USB boot but it’s so long ago I can’t remember and I’ve trawled the internet and can’t find anything regarding your machine

Graeme

I have nothing else I can try the drive in, but I have two other drives of the same type that I’m pretty certain work. Neither of them alleviate the problem.

I’ll try the battery removal, but I’m sure I’ve done this before.

I can’t find anything to turn the USB on or off. The BIOS is so simple, I’m sure I’d find it somewhere. If I can, I’ll try to take a pic of the screens.

but I have two other drives of the same type that I'm pretty certain work. Neither of them alleviate the problem.

Do both these drives kill the HDD in the same way ?

Can you tell me the current boot order in the BIOS ?

Graeme

Just tried putting the drive back in and booting up. Guess what? The HDD booted. It did seem to try to access the DVD drive first, though, which has a film DVD in. The boot order is HDD, DVD/CD, FDD. Going back to the question that was asked several posts ago (ls /media/…) as I can now access the OS with the DVD drive in:

from matt account:

/cdrom : no result
/guest : permission denied
/matt : no result

I’ve attached the screen shots of the BIOS. Note: the info is basic.

When you ran

ls /media/matt

did you have a DVD with files written on it in the tray ?

if not can you please do that and post the output ?

Graeme

After, again, problems getting the HDD to load with the DVD drive installed, the results of a data disc show the same as before: no results bar the guest’s.

there’s still a possibility the DVD drive is faulty but if you’ve tried 2 others with the same results is kinda unlikely, it seems to me the DVD isn’t being activated at start up which points to a bios/motherboard issue, but I’m no expert and I’m rapidly running out of ideas, I’ve been trawling the internet looking for clues, the closest I could find was this guy who had a very similar problem and found a solution here

https://forums.tomshardware.com/threads/boot-options-replaced-with-fdd.2113695/

If all else fails the only way I can suggest to get a new operating system on the machine is to remove the drive and install it into another machine, install the OS then put it back but that might be more hassle than it’s worth

Just a thought have you tried to see if the drive will read a CD ?

OK! Now here’s the thing. :-[

It’s fixed! Let me explain.

Right at the start I tried another two DVD drives. Neither of them worked. Or at least, so I thought/remembered. Taking another laptop apart and pulling out a compatible drive, I have just tried that one. It works fine - the HDD boots up and the OS reads the drive. I retried all the other drives and found that the original one and one of the other spares caused the problem, but the third one of the original ones I tried also works fine. (Not sure why I thought it didn’t work originally - maybe I hadn’t quite put it in correctly.) This third one I have properly installed and tried several times. It still works fine. Conclusion: the original one and one of the spares are faulty - just like you stated. ::slight_smile:

There is one unanswered question, though. Why was the problem drive causing the BIOS to ignore the HDD, despite it being first in line?

Whether this question is answered or not, please let me ‘voice’ my appreciation for all the help and patience offered.

Matt

Great news
Glad you got it working Matt I applaud your perseverance :slight_smile:

Why was the problem drive causing the BIOS to ignore the HDD, despite it being first in line?

Wish I could answer that, but my guess is the DVD & HDD are connected to the same IDE channel in a Master/Slave configuration and the faulty DVD was probably taking out the whole channel

Does that make sense ? :slight_smile:

Anyway all’s well that ends well

Graeme

When you put it like that, it makes perfect sense.

Thanks again.

Matt