Partial Upgrade

My PC did a ‘partial upgrade’ last night and removed a few programs (which I want to keep)
They were VLC, Transmission Xscreensaver.
I took a screenshot of the libs that it said it was removing, I have also included the other screenshot of another p’partialupgrade’ a few days ago…

I am also trying to install LibreOffice 3.6.4 (Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft) but I’m not getting anywhere as I have noticed another program missing, the GUI Deb Installer, I have had a look in the Ubuntu Software Centre and it says it’s installed but it’s not showing in the drop-down menu when selecting files in nautilus, how can I get it back?

Is there a way I can stop these ‘partial upgrades’ from removing programs and other things I want to keep?

I am following the instructions but when I type;

sudo dpkg -i *.deb

I get this;
dpkg: regarding libreoffice3.6-debian-menus_3.6.4-3_all.deb containing libreoffice-debian-menus:
libreoffice-debian-menus conflicts with libreoffice-bundled
libreoffice-core provides libreoffice-bundled and is present and installed.
dpkg: error processing libreoffice3.6-debian-menus_3.6.4-3_all.deb (–install):
conflicting packages - not installing libreoffice-debian-menus
Errors were encountered while processing:

I have tried the best I can to remove anything to do with the previous install of LO by searching through Synaptic Package Manager but being carefull not to remove anything that would harm the system. There must be something I am missing but just can’t see it…

To remove all traces of your previous LO installation, including config files … run:

sudo apt-get remove --purge libreoffice*

then try installing the new LO again.

I have noticed another program missing, the GUI Deb Installer, I have had a look in the Ubuntu Software Centre and it says it's installed but it's not showing in the drop-down menu when selecting files in nautilus, how can I get it back?

The Ubuntu Software Centre is now supposed to be the GUI installer for .deb files, but if you mean gdebi … try uninstalling it, then reinstalling it:

sudo apt-get remove --purge gdebi


sudo apt-get install gdebi
sudo apt-get remove --purge libreoffice*

I was going to try that command but didn’t know to include the ‘*’ and when I tried removing it in Synaptic Package Manager it said it was going to remove some important stuff so I stopped.

I have noticed the .Deb installer is also now hidden away (see screenshot)… Don’t know why there’s two though…

I’ve installed and got this, is it anything that needs fixing?
pooky2483@pooky2483-ubuntu12:~/Downloads/LibO_3.6.4.3_Linux_x86-64_install-deb_en-US/DEBS/desktop-integration$ sudo dpkg -i *.deb
(Reading database … 444008 files and directories currently installed.)
Unpacking libreoffice-debian-menus (from libreoffice3.6-debian-menus_3.6.4-3_all.deb) …
Setting up libreoffice-debian-menus (3.6.4-3) …
gtk-update-icon-cache: Cache file created successfully.
gtk-update-icon-cache: Cache file created successfully.
Processing triggers for shared-mime-info …
Unknown media type in type ‘all/all’
Unknown media type in type ‘all/allfiles’
Unknown media type in type ‘uri/mms’
Unknown media type in type ‘uri/mmst’
Unknown media type in type ‘uri/mmsu’
Unknown media type in type ‘uri/pnm’
Unknown media type in type ‘uri/rtspt’
Unknown media type in type ‘uri/rtspu’
Processing triggers for bamfdaemon …
Rebuilding /usr/share/applications/bamf.index…
Processing triggers for desktop-file-utils …
Processing triggers for gnome-menus …
Processing triggers for gnome-icon-theme …
Processing triggers for hicolor-icon-theme …
Processing triggers for menu …

Nope, as long as it opens it’s own mime types (.odt, etc.) that’s not a problem.

I have noticed the .Deb installer is also now hidden away (see screenshot)... Don't know why there’s two though....

As I said, the Ubuntu Software Centre is now the default .deb installer, and I don’t know why it’s listed twice either … I suppose that’s fixable (removing the second entry), but why bother.


Thats ok then :slight_smile:

Just one more question… Why is the version in the repo still the old version and not updated to the new version as I posted a question/bug in Bugzilla and was told to update to the new version of LibreOffice…

Sometimes it takes a while for the new version to be packaged and included in the repos … and sometimes they don’t bother at all unless the new version addresses some kind of major issue.

Sometimes it’s easier to stick with a known version than to add a new version that may introduce a raft of new issues … they can’t win, either way they’ll upset some people.

LTS versions of Ubuntu, tend not to update to the latest versions, and stick with a known “good” versions, even if they have minor issues (at least the minor issues will be known) … they don’t want to bung a new version in the repo’s and risk it breaking other stuff or creating MAJOR new issues when the LTS releases are liable to be used more in production environments.

non-LTS versions tend to be a bit more experimental … indeed that’s the whole point of non-LTS versions … they are to test stuff out.


Heck… take a while, they are way behind in the version.
One of the reasons why I wanted to change was since updating to the version now in the repo, the date function where, when you type a date such as 23rd, the ‘rd’ is turned into superscript (I know it’s nothing much but it’s something I liked) and in the version before the version I have just removed, that function worked perfectly.
This is/was a known bug which many people reported and had since been fixed in the new version.

See above … I may have been adding “why” they don’t update “software” so much in LTS releases :wink:

Point is … there’s nothing stopping YOU from updating … but if THEY do it automatically, it could introduce a bunch of new issues that will really p*ss people off, particularly in a production environment.

Security updates will be automatically added

Software updates will only be added if they either fix MAJOR bugs, or add MAJOR new features that enough people seem to want.

Other than that, software updates will be left for the next release.

Better the devil you know :wink:


On a different matter, check out the screenshot… what’s with the ‘squiggly writing’?
Could that be one of 1 things, you were hacked or it’s to do with my end and I need to re-install something?

That’s your end … the Fekbook “Like” buttons display correctly for me.


What makes you think we were “hacked” ?

Dunno really, just one option!

Try clearing your web browser cache … then restarting your browser.

It’s not any of the ideas I had, it’s Ubuntu. I have just been helping Mrs pooky on her laptop and have noticed the same writing there too.
I’m thinking it’s something to do with recent updates…

Will be interesting to know if anyone else is getting foreign text in the Facebook “Like” buttons ?

I’ve removed every unused locale with “localepurge” on my system … maybe it’s that that has kept my Fekbook buttons in English.

I’ve noticed there are 3 languages in the “Facebook Slide Like Box” plugin (as used on this forum) … English, Persian, and Polish.

At a guess yours is displaying Persian for some reason.

I’ll see if Mad Penguin knows more.


Here’s the proof it’s displaying correctly on my system (attached image).


It’s not just the ‘Like’ button

In that case it’s definitely something local to your PC’s

Have you been messing with the default fonts and character encoding in your web browser ?

Is it ONLY stuff from Facebook ?



Is it ONLY stuff from Facebook ?


It’s your language selection in Facebook … bottom left of screen on your facebook page, it should read something like:-

Facebook © 2013 · English (UK)