Partitioning SSD

Hi All - I’ve got my new build up and running and I’m ready to install a new version of Mint. But before I do, I could do with some advice re partitioning the SSD, both for optimum speed and wear.

Specs are Crucial MX500 500GB SSD, 8GB (2x4) RAM. I don’t envisage having a separate HDD for storage as I’ll never fill up this one with the type of computing I do.

I want to keep it simple - my thoughts are say, 80GB for / and the rest for /home. I’ve read that SSD’s don’t get on with swap so would I need a swap partition at all with 8GB RAM?

Thanks in advance


Which version of Mint ?

Personally I’d just accept the defaults and let Mint decide on the partitioning scheme (likely not to have a separate /home, but I honestly can’t see the point in them).

Depending on the Mint version it may have a swap FILE rather than partition … but you can always turn off swap if you’re worried about it (though personally I don’t think you’ve needed to worry about swap on an SSD for some years now).


Thinking about it, a swap FILE is probably a much better idea than a swap PARTITION on a siingle large / partition SSD . wear levelling in the firmware will be able to reallocate it (move it around on the drive) more.

So my advice (on Mint 19 at least) would be to just accept the defaults … which should result in one large / partition and a swap FILE.

Hi Mark - thanks for the reply.

Version is Mint 19.1

I went for the 2 partition scheme (as a hangover from my old system where I had problems with re-installs) so the new set up is 500GB SSD - / =80GB - /home the rest - no swap partition. I did it this way to avoid possible data losses if a re-install was needed. (This is my 1st experience with a SSD so playing it safe!) Where do the bulk of re-writes come from? Is it the system itself or from User created files? If the system, there would only be 80GB for the firmware to ‘play with’ as it were, or does this not apply?

To go with your suggestion of 1 partition, if I wanted to alter it, can those partitions I created be merged ‘in situ’ seamlessly without disruption to data or would it mean a fresh re-install?



In general operation (without swap) I’d expect the majority of writes to probably go to /temp files (which is in /) and web caches (which’ll be in /home).

It can be done in situ … but it won’t be easy.

You’re worrying too much … most of the info out there on the web about making sure you minimise writes is either old info or people perpetuating old info … modern SSD’s will generally outlast an HDD so stop worrying.

LOL! Ok, I’ll relax then!

I’m pleased with my efforts for a 1st build - just over £300 for a system with 500GB SSD and 8GB Ram, new case with PSU fitted, Gigabyte motherboard, Intel i3-8100 CPU and DVD writer. (Saved £200+ on having it built for me). Took about 2hrs to assemble and worked first time. Installed Mint 19.1 Cinnamon originally but after updating and a bit of fettling, Cinnamon played up and no desktop appeared (this has happened before) so re-installed with Mate. No issues this time and boots to login in under 20 secs. Happy days! Now looking to do a clone of the system as a precaution - any thoughts on the best (ie: easiest) method?

Thanks for the help so far :wink:




Just use “Disks” to create a disk image somewhere.

Ok, thanks - have used Clonezilla which seems to have worked ok, but… I can’t see the partition on the target drive where the cloned image is stored.

In preparation, I partitioned a 500Gb Seagate external HDD into 2 equal partitions - both as Primary partitions ext4. The 1st (sdb1) is for the cloned system files, the 2nd (sdb2) is for the User content. Clonezilla reported it had cloned the system files successfully from sda1 to sdb1 but when I reconnect the Seagate, I can only see the User partition (sdb2). I’m wondering if I set up the Seagate incorrectly as when I try to open the 1st partition it says ‘cannot be mounted’? The 2nd partition opens ok and the User files are intact. Any idea what I did wrong?

Also - and I don’t know if this is connected in any way - after cloning, I rebooted but the LAN connection failed. The info in network manager is all there as set up but it won’t connect. I’ve put in a wifi dongle as a temporary measure to get online but am stumped as to where to go from here?

I’ve no problem in starting again with cloning as I can wipe the target drive and redo the partitions if necessary.


EDIT: Boot failure!

I tried to reboot after a break and I just get a grub rescue prompt. Attempting to re-install from the clone gives an error that the target partition (sda1) is too small. I think it’s finding the boot sector (500MB) but there’s nothing I can see to change to sda1 itself. (sda is 80GB) I definitely set cloning from sdb1 to sda1 so I’ve no idea what’s happened here…

I’ve tried re-intalling grub as per your advice here - [b][/b] - but get this - mint@mint:~$ sudo mount /dev/sda1/ /mnt/boot
mount: /mnt/boot: mount point does not exist.

From the live disk, GParted shows this -
File system unknown
Status Unmounted
Unable to detect file system! Possible reasons are:

  • The file system is damaged
  • The file system is unknown to GParted
  • There is no file system available (unformatted)
  • The device entry /dev/sda1 is missing ???

How could this have got screwed up when only being copied? I would assume Clonezilla wouldn’t alter anything? Well I’m stuck! I think the files are all there but aren’t being seen… Can you advise please - I’d really rather not reinstall the system as I’ve done a lot of configuring…

Thanks in advance


Update: Had to go for reinstall after all as computer was needed urgently. Less painful than I thought as most config files were in separate /home so only had a bit of system fettling to do and all seems ok. Still no idea why Clonezilla acted up but possibly my inexpert use! ::slight_smile:

Thanks again


Sorry Rich, I’m just super busy with the upcoming Peppermint 10 at the moment, so didn’t have time to respond :frowning:

No worries! It was probably the easiest way to get up and running anyway - the install only took 5mins or so from the disk and a matter of seconds with sudo update. All my personal settings were preserved on my separate /home partition. I still wonder what happened with Clonezilla but it doesn’t really matter now - with reinstall being this easy I’ll probably do the same again if needed and backup personal files periodically. Is there a good incremental backup that does the job?


Just a thought. It sounds like your data is important to you (as it should be - data is really the whole point of a computer).

The safest way to protect data is by backing up to a different physical drive/cd/dvd.

I’ve lost count of the HDDs that have failed on me, but backups have preserved my data. I even keep a couple in my locker at work, in case of burglary/fire.

And I’ve given up installing more than one drive in a computer because I got fed up with expensive, branded PSUs failing and killing disks. These days, my data lives on external drives, each with it’s own power supply.

Call me Mr Paranoid, but I’ve come to realise that PSUs and HDDs are unreliable, and the only really important component in a computer is data. Everything else can be recreated…

Solid policy … you’d get my vote :slight_smile: