Password Issue - Unable to login (SOLVED)

Hi Everyone and apologies in advance for this long(ish) first post,

I just found this forum on a Google search and really hope someone can help me. I bought a Desktop cased Mini-ITX PC (4GB 250GB) from eBay recently which has Debian 7 on it and the seller didn’t tell me was password protected. I contacted him afterwards and because he wasn’t able to help, he refunded my money and said I could keep it - which was good of him. I have been on YouTube and found videos about how to reset the root password by typing in init=/bin/bash in the appropriate place, which I understand and am able to do without difficulty. However, I’ve never been able to attempt the next step (typing in mount -rw -o remount) because at that point, my keyboard stops working completely as if the PC no longer recognises that it’s attached via USB

I’ve ordered a USB/PS2 converter (stupidly didn’t realise it’s coming from China so it hasn’t been delivered yet) and hope maybe that will help but if that doesn’t solve my problems does anyone have any other ideas please that I could try or is there another way entirely to get round this password issue?

Thanks so much :slight_smile:

Yes …

a) boot to a Debian LiveCD/LiveUSB

b) mount your Debian partition with something like:

mount /dev/sda1 /mnt

(where /dev/sda1 is the Debian / partition on the HDD)

c) chroot into it

chroot /mnt

d) change your password

passwd <username>

(where is the username of the account who’s password you want to change)

e) exit chroot (Ctrl+D)

f) reboot to the HDD.

Hi Mark - thanks for the reply.
I have another few issues - first of which is that I’m not really that familiar with Linux additionally, the PC doesn’t have a disk drive at all. I’ve already tried booting it from the USB to install W7 but it won’t and now that option is no longer even showing in the boot options menu.
I think I’m starting to understand why the seller was glad to see the back of it and didn’t demand it’s return!

You’ve lost me there…

Do you mean it has no CD/DVD drive ?

And do you mean you mean you had created a Win7 USB stick with something like:
http://www.microsoftstore.com/store/msusa/html/pbPage.Help_Win7_usbdvd_dwnTool
but it no longer shows as a bootable device in the boot device selection screen ?

Have you changed any BIOS settings ?

No, yes and no :frowning:

Do you know how to add e kernel boot parameter ?

If so, try adding

acpi=off

and see if your keyboard works now when you run:

mount -o rw remount /

Thanks for trying to help me Mark - really appreciated. But as I feared, it’s all a bit too involved for someone like me who doesn’t really understand Linux so I think I’m going to just give it to a charity shop. I’m sure someone with the requisite skills etc will enjoy bringing it back to life.

Thanks again :slight_smile:

Okey dokey … all the best :slight_smile:

Can you follow instructions?
If yes, then somebody will walk you through (step by step). No need to give up just yet.
What is your target?
a) Get the existing Debian 7 going
b) Install a Linux distro over the existing OS
c) Install Win 7 & a Linux OS (dual boot)
d) Install Win 7 only

As for the fail to boot from the Win7 USB, is it actually bootable?
How are you trying to boot from USB, please describe.

Hi SeZo :slight_smile:
Oh I follow instructions just fine and can flash roms on android devices etc (I’ve done about 7 so far) so not a complete tech newbie :wink:
I really wanted to put W7 on it but dual boot sounds cool and I keep thinking my android hacking life would be made easier if I were to learn more about Linux…this could be the answer.
It’s no problem at all for me to follow step-by-step guides as I do it all the time and if someone was kind enough to do that with me, I’d be over the moon!

Have you got access to another Windows PC (to create a Debian LiveUSB if necessary) ?

If so, have you checked to see if the WIn7 USB stick is bootable on that PC ?
(just to check it’s not corrupt)

Does the USB stick show up in the BIOS of the Debian PC ?

Has the USB stick EVER shown up in the boot device selection screen of the Debian PC ?

Can you get access to a USB CD/DVD drive … even if it’s only to borrow ?


Earlier, you said your keyboard dies when you attempt to enter the “remount” command … is it dead BEFORE you enter that command, or does it die WHILST entering it ?

Have you got access to a PS/2 keyboard (not an adapter) ? … even if it’s only to borrow.

Does the USB keyboard allow you to access/edit the GRUB bootloader menu screen ?

Are you sure there’s no BIOS setting to enable USB keyboard or “Legacy USB” or similar ?

OK, in Debian when you access the GRUB menu is there an option to boot into (Recovery Mode) or similar ?

If so, use thed arrow keys to highlight it … then hit the “Enter” key to boot into it

Hopefully you’ll get to a screen with an option to “Drop to a root shell prompt” (or similar) … select that and hit enter.

Hopefully you’ll end up at an “#” prompt.

If so, enter:

mount -o rw remount /

and hit enter.

If all goes well, enter:

passwd <username>

(where is the actual username of the user account who’s password you want to change … eg. ‘passwd mark’)

You will be prompted for the new password … type it in and hit enter.
BE AWARE, when typing in the new password you will NOT see anything echoed to screen (not even ******) but it IS going in, so just type it in then hit enter.

You will be prompted to re-enter it … type it in again and hit enter

It should tell you the password was successfully changed.


I don’t think the USB ports are dead, particularly if you’re using a USB keyboard.

Have you tried a different USB stick ?

Hi Mark,

I explained in my OP that I’ve attempted to type that command already, but the keyboard stops working at that point.

In any event, I’ve now invested just under £14.00 to get it up-and-running - I’ve ordered an external DVD/CD drive, a copy of Debian 7 32-bit and a PS2 keyboard.

I figured that it’s a reasonable thing to do, given that the PC hasn’t cost me anything (apart from time) and I can always resell the items on eBay if I don’t manage to get it working.

Thanks for all your help.

I’ll try again once I’ve received all the bits 8)

Hi Anyone,

Me again - still not able to get around my password issue.

I now have a PS2 keyboard (which works fine and doesn’t suddenly die) and I’ve gotten as far as typing the mount -o -rw remount / command but when I type passwd and get the Enter new UNIX password line (which I do) and then Retype new UNIX password (which I have) I get the following:

passwd: Authentication token manipulation error
passwd: password unchanged
root@(none):/#

and a flashing cursor at the end.

Any other ideas anyone?

Thanks :slight_smile:

In other news…

I have connected an external DVD/CD drive with the Debian 7 disk loaded, which has a light that flashes when the PC is booting.
I’ve mashed the F10 key to get into the boot menu and the DVD/CD drive is there (MATSHITA UJDA760) and the light is no longer flashing
I’ve used the arrow keys to highlight and select it, pressed enter but the PC doesn’t boot into it.
It just keeps booting into the HDD (MAXTOR STM3250310AS) which ultimately takes me back to the Debian login screen that has me stuck!

I can see myself going mad with this thing :o ;D

PS - I’ve also mashed F2 to get into the BIOS and selected USB in the Boot settings…makes no difference to the above outcome

OK, about your only option now would be to take the hard drive out of this PC … stick it in another PC (with it’s hard drive removed for safety) … fix the password, or reinstall Debian … swap the hard drives back.

Unlike Windows, you can install Linux on one machine … then move the drive to another PC, where the drivers will automatically adjust themselves (proprietary drives aside).

Jesus wept!! :o Seriously?? ;D

Bin it is then…thanks for all your help Mark 8)

well if there’s no working optical drive, the USB slots aren’t working, and the keyboards playing up … how else ?

Something tells me you have serious hardware problems … not just a forgotten password.

Well tbf, the keyboard is working fine now there’s a PS2 one present and the USB must be working because I can see the DVD/CD drive in the boot options as I said.

Getting the PC to boot from it is the issue.

I’ve just been talking to a friend about it and he reckons he can fix it so it’s safe until he can get round here ;D