Peppermint 5 and DraftSight (SOLVED)

Not quite correct. Just tested on my wheezy 64 bit server install (no prior 32 bits):

apt-get install --dry-run ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
.....................................................
The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-i386 but it is not installable

Then I run this:

dpkg --add-architecture i386

then

apt-get update

then

apt-get install --dry-run ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  acl esound-common fontconfig-config freeglut3:i386 gcc-4.7-base:i386
  ia32-libs-i386:i386 lesstif2:i386 libacl1:i386 libaio1:i386 libasound2:i386
  libasyncns0:i386 libattr1:i386 libaudio2:i386 libaudiofile1:i386
................................................
0 upgraded, 175 newly installed, 0 to remove and 0 not upgraded.

Go figure

Tested it on SolydX (effectively Debian testing)

sudo apt-get install --dry-run ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ia32-libs is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

.

don@ldwatson ~ $ ls -l /home/don/ | grep rw
drwxr-xr-x 2 don don 4096 Aug 3 12:26 Desktop
drwxr-xr-x 4 don don 4096 Aug 9 16:42 Documents
drwxr-xr-x 2 don don 4096 Aug 9 18:04 Downloads
drwxrwxr-x 4 don don 4096 Aug 1 17:08 Maps and Labels for Pens
drwxr-xr-x 2 don don 4096 Jul 25 19:52 Music
drwxrwxr-x 5 don don 4096 Aug 9 12:33 Newsletters
drwxrwxr-x 2 don don 4096 Aug 9 18:54 Octogon Drawings
drwxr-xr-x 8 don don 69632 Aug 9 12:41 Pictures
drwxr-xr-x 2 don don 4096 Jul 25 19:52 Public
drwxrwxr-x 3 don don 4096 Aug 9 16:36 Setups
drwxr-xr-x 2 don don 4096 Jul 25 19:52 Templates
drwxr-xr-x 4 don don 4096 Jul 28 20:31 Videos
don@ldwatson ~ $
This is what I get with the above command.

When I try to open the Octogon Drawings folder I can’t
don@ldwatson ~ $ ls -l /home/don/Octogon Drawings/ | grep rw
ls: cannot access /home/don/Octogon: No such file or directory
ls: cannot access Drawings/: No such file or directory
don@ldwatson ~ $

It’s because of the space in the folder name … without enclosing it in quotation marks, bash interprets “Octagon” as being the end of the command when it hits the space, and anything afterwards as additional command arguments/options.

try either:-

ls -l "/home/don/Octogon Drawings/"

or

ls -l /home/don/"Octogon Drawings"/

It’s a good idea not to use spaces in file/folder names in Linux, or they’ll need special treatment at the command line.

Thanks Mark,
I should have remembered that and put the _ to join the words.
Both commands show the same result, over a page of files marked as -r -------- only.
At the bottom of the page there are a couple different files, I saved these as .dxf on advice from SeZo and they seem to be readable and writable.

-r-------- 1 don don 309184 Sep 5 2007 OCT 318-GA1-A.dwg
-rw-rw-r-- 1 don don 921272 Aug 9 18:54 OCT 318-GA1-A.dxf
-r-------- 1 don don 260857 Sep 6 2007 OCT 318-GA2.dwg
-rw-rw-r-- 1 don don 751792 Aug 9 18:53 OCT 318-GA2.dxf
-r-------- 1 don don 61162 Sep 6 2007 OCT 318-PL1.dwg
I will open and save the drawings as .dxf if it allows me to look at them and manipulate to my satisfaction.
Thanks again you guys, your help is very much appreciated
Don W
PS I will leave the thread un ‘Solved’ for the moment as I may find more problems ::slight_smile:

Both commands show the same result, over a page of files marked as -r -------- only.

Just as I thought. How are you getting the drawings onto your machine? Is the source a cdrom?
If it is then that is fully expected.
Try changing permissions:

chmod 644 "/home/don/Octogon Drawings/318-PL1.dwg"

this should cange it to:

-rw-r--r-- 1 don don 61162 Sep 6 2007 OCT 318-PL1.dwg
Try to open that drawing.

If that works then you could do the lot recursively:

chmod 644 -R "/home/don/Octogon Drawings"

Hi SeZo,
I have applied that fix as you said and it gives the correct result
-r-------- 1 don don 309184 Sep 5 2007 OCT 318-GA1-A.dwg
-rw-rw-r-- 1 don don 921272 Aug 9 18:54 OCT 318-GA1-A.dxf
-r-------- 1 don don 260857 Sep 6 2007 OCT 318-GA2.dwg
-rw-rw-r-- 1 don don 751792 Aug 9 18:53 OCT 318-GA2.dxf
-rw-r–r-- 1 don don 61162 Sep 6 2007 OCT 318-PL1.dwg
-r-------- 1 don don 66488 Sep 6 2007 OCT 318-PL2.dwg

However when I try the other command to change the lot it gives an error
don@ldwatson ~ $ chmod 644 -R “/home/don/Octogon Drawings”
chmod: cannot access ‘/home/don/Octogon Drawings/OCT 318-PL2.dwg’: Permission denied
chmod: cannot access ‘/home/don/Octogon Drawings/OCT 318-04.dwg’: Permission denied
chmod: cannot access ‘/home/don/Octogon Drawings/OCT 318-PL5.dwg’: Permission denied
chmod: cannot access ‘/home/don/Octogon Drawings/OCT 318-11.dwg’: Permission denied
I can use the first method as I open the files to view them one at a time, would that be ok ?
Yes, the files came on a cdrom

Files on cdrom are always read only. :slight_smile:
Try:

sudo chmod 644 -R "/home/don/Octogon Drawings"

Hi SeZo,
I tried the sudo command you gave me but it returns over a page of
ls: cannot access /home/don/Octogon Drawings/OCT 318-28.dwg: Permission denied
ls: cannot access /home/don/Octogon Drawings/OCT 318-09.dwg: Permission denied
and then another page of
-??? ? ? ? ? ? OCT 318-SA4.2.dwg
-??? ? ? ? ? ? OCT 318-SA5.dwg
If I change the Octogon Drawings to Octogon_Drawings will it help.
I am having problems opening DraftSight as well but I will leave them until later :-[
DraftSight can’t find any files ?

I have made a new folder for holding the drawing files, ( Unit_Drawings ) and reloaded the files from cd rom.
I ran the command
ls -l /home/don/Unit_Drawings/ and it showed all files with -r-------
I then ran
chmod 644 /home/don/Unit_Drawings/Oct 318-01.dwg but it returned an error.
I changed the file name to OCT_318-1.dwg and ran the command again
chmod 644 /home/don/Unit_Drawings/OCT_318-01.dwg and it was ok
I ran the command
ls -l /home/don/Unit_Drawings/ and it showed all files with -r------- with the exception of OCT_318-01.dwg which, after opening in DraftSight and saving, shows.

-rw-r–r-- 1 don don 206087 Sep 5 2007 OCT_318-01.bak
-rw-rw-r-- 1 don don 129034 Aug 10 13:54 OCT_318-01.dwg
All seems to be working at the moment but I will need to change the filenames to get rid of spaces.

To change the permissions of ALL documents in the Unit_Drawings directory to 644 (without having to rename them) run:

chmod -v 644 /home/don/Unit_Drawings/*

chmod 644 /home/don/Unit_Drawings/Oct 318-01.dwg

WILL give an error because of the space in the file name

As explained you need to surround the file name (or complete path) with single or double quotation marks … so any of these would have worked:-

chmod 644 /home/don/Unit_Drawings/"Oct 318-01.dwg"

or

chmod 644 "/home/don/Unit_Drawings/Oct 318-01.dwg"

or

chmod 644 /home/don/Unit_Drawings/'Oct 318-01.dwg'

or

chmod 644 '/home/don/Unit_Drawings/Oct 318-01.dwg'

Thanks again Mark,
I have renamed all files and folders to eliminate spaces, quite easy as there are not many on this machine yet.
I have taken a note of all these commands and will refer to it when I meet any more problems.

I have a problem with the original folder, I want rid of it and its contents but it refuses to go ?
How do I dump it

You can remove the folder like this:

sudo rm -rf "/home/don/Octogon Drawings"

Thanks again SeZo,
I find DraftSight takes a while to load, possibly nearly a minute, is this usual ?

I find DraftSight takes a while to load, possibly nearly a minute, is this usual ?

It takes about 30secs the first time, then 2-3 secs after.
It does not bother me, as I do not open a new instance for every drawing.
I just open it once and after that using double click in the file manager to load the other drawings.
It is MDI (Multi Document Interface) by default. Just remember to close any unwanted drawings already open.

Thats ok then. Thanks for the help. I will probably be back with some more daft questions. ::slight_smile:

Don W

Hi I’m back :slight_smile:
I have 2 problems with DraftSight.
1 When I print a page it comes out upside down ? Normally when printing, the page top comes out first but when printing in DraftSight it comes out bottom first. Not a huge problem but can it be cured ? or is the default for printing in DraftSight ?
2 The colours are very pale/insipid. Is there any way to strengthen them. The printer is ok printing colour pictures etc. so I reckon the problem is settings in DraftSight.

EDIT I have joined the forums at DraftSight but it is quicker trying out different settings in the program than navigating to the Help page. >:(

I had non of the problems you mention, so cannot really help you there.

The page orientation could be down to your printer driver.
You could try in the print dialog, right hand side, put a check mark against Print inverse.
That will rotate the page 180 deg.

For the colours, you could try in Printer Dialog->Additional options: Print quality.
Also while there, make sure you are using the right colour table.
You can add your own into /home/.config/DraftSight/1.2.413/Print Styles/

Thanks SeZo,
I checked the Print Inverse box and the drawing came out as I wanted/expected.
I found a dropdown box in the printer setup that had use Epson Vivid and I changed that to Adobe RGB which strengthened the colours.
I will have a look at setting my own print style in the morning.
Thanks again
Don W