Peppermint 5 - encrypting the home folder at installation

I am just installing P5 on a 1991-vintage desktop and am being offered the option of encrypting the home folder.
I suspect potential problems here and would be grateful for advice on possible difficulties when things start to go wrong in the future. (They will! they will!)
My gut reaction is not to encrypt but I am open to offers.

Thanks,
Keith

Unless you have a need for it, I’d steer clear of LVM and encryption during installation … as you surmise it can make problem solving much harder.

We can add an encrypted folder later if you wish

If on the other hand you’rre likely to keep sensitive daa on the PC, and there’s a risk of theft/loss/or local access by someone untrusted … then go ahead and encrypt the home folder.
(but remember to generate a key post installation, and keep that key somewhere safe, not on the PC)

[EDIT]

If you’ve already chosen to use encryption … finished the install … and rebooted … you can generate your key with:

ecryptfs-unwrap-passphrase

Keep that somewhere safe … somewhere other than on this PC :wink:

I had a feeling that there might be problems ahead. There is suitable folder encryption s/w available and I have played with Cryptkeeper in the past so, as you suggest, I shall keep clear.
I shall finish the install now and report on the result.

Thank you Mark.

Keith

NP :slight_smile:

The installation went without a hitch, so I am up and running.

I notice that Chromium does not work at all, but this is not a problem as I prefer Firefox, which I’ve installed along with Thunderbird.
I installed “Main menu” as a menu item as described by Mark in another post http://linuxforums.org.uk/index.php?topic=11946.msg96081#msg96081 but beware that some things you tick don’t appear in the menu and some others you untick still appear - but note Mark’s caveat.

I tried to install LibreOffice and found a large number of component files (such as Writer, Calc, etc) that appear to require a “host” to be inserted into, if you see what I mean. Or can I just install the components that I require? Before I screw things up, perhaps someone would care to advise me on that.

So far so good, and many thanks to Mark for all his advice.
Keith

You can just install the LO components you require if you wish.

But bear in mind, they’ll pull in some other core components as dependencies anyway … so you won’t save much room, and it may be easier just to install the whole thing with:

sudo apt-get install libreoffice

Oh! I didn’t think of that!
You would have thought I’d learnt by now.

Thank you, Mark.

How much RAM is in this machine? What CPU does it have?
I’m thinking this could be some kind of record if it’s running a 2014 OS on a 1991 machine!

Just to be sure I fired up the PC and did a lshw check on memory and CPU - attached.
It is 1GB but I’m not sure how to add up the cache - looks like <1MB. Perhaps you would confirm that for me. The memory info refers to a third memory slot but I don’t remember seeing one, although I’m not noted for my observational skills (am I Mark? ;)) I would be grateful for any comments you might have on the hardware data.

P5 takes about 40secs to boot up which I don’t suppose is too bad and once it’s going it’s fine. Faster than my brain, anyway.

As it happens, the PC hung (no KB or mouse response) during my first lshw check and I had to do a hard reboot. (Actually not that hard - just pressed reset).

Keith

free -m

might give a clearer indication of RAM vs usage

Ah, sorry to inform you, but that chip didn’t come out until 2000, so no record today :slight_smile:

Has got me wondering what the record is though! I mean, it could be a record, but not that impressive a record. The 32 bit P5 is compiled for i386 - wonder if it’s ever been installed on anything close to that old!

Just looked at the supplier’s label with my glasses on and the handwritten “9” might well have been intended to be a “0” - sorry for the excitement.

Re Mark’s suggestion of free -m: I just booted up but it hung at trying to boot from the DVD (first boot device) without bothering to try the second device (HDD). It then went into the GNU GRUB screen for my decision, but the k/b was unresponsive, as reported yesterday (hung during a terminal session). I changed the boot order to HDD first but it went straight to the GRUB screen with the k/b unresponsive again. I’ve tried the k/b in both the PS2 and USB sockets, but no joy.

Hmm! I’m glad this is a play PC and not my every-day machine. Any ideas, gents?

I guess this is a native PS/2 keyboard? I wouldn’t mess about with USB conversion, especially as some BIOS’s can be finicky about USB keyboards.

If you leave it, GRUB should timeout and it should boot anyway - is the keyboard working then?

Btw - don’t leave the HDD as the first boot device, otherwise you can’t use a rescue disc if the OS gets borked

K/B: Nope, it’s a USB keyboard but, interestingly, the P5 live CD would only respond to it in the PS2 port.
Timeout: The GRUB doesn’t time out - not even during lunch.
Boot order: I guessed, though, that I could always change the boot order at boot time - that’s what I have been doing whilst playing around.

Perhaps this PC really is too old, but it was running Ubuntu 12.04 OK.

Shouldn’t be too old - if you got to installing it, it should work.
Lack of GRUB timeout is weird, it’s a default setting - did you manually edit GRUB?

If it’s a USB keyboard, look in the BIOS for references to USB keyboards or “Legacy USB devices”, and make sure everything is enabled

GRUB: no, I haven’t edited it - I wouldn’t know how anyway.
I’ve been through the BIOS and can’t find anything relating to legacy devices.

The odd thing is that everything worked fine (apart from Chromium) immediately after the install. It’s only now that I am trying to boot from cold that it hangs.

Let me get this straight … some kind of reset has caused the GRUB menu to be displayed, but you cannot hit enter to boot ?

As Chemicalfan suggests … a LOT of older motherboards have no support for USB keyboards until the OS has booted and loaded drivers, and those USB → PS/2 adapters rarely work properly.

Get a proper PS/2 keyboard (not a USB one with an adapter)


@ chemicalfan

I think the grub timeout is overridden when GRUB is called after a boot failure … don’t quote me on that though.

@Mark - How about booting from a live CD, then re-installing GRUB? Probably easier then seeking a PS/2 keyboard, lol

Well yeah there’s probably ways around it … but it’ll happen again at some point :wink:

Any kind of reset, including just starting from scratch, brings up the GRUB menu and the keyboard does not respond. Running P5 from the live disc is fine using the USB k/b with a PS/2 converter.

Get a proper PS/2 keyboard (not a USB one with an adapter)

The PC is probably not worth much more than a decent keyboard, but I’ll think about acquiring one. The PC is destined for loan to my lady friend, so I’ll check in a week or so if her k/b is PS/2. Another possibility is trying Mint, or do your reckon I will have the same problem?