Peppermint 5 starting/shutdown problems [ABANDONED - faulty hardware]

I’m having a very unhappy time with my brand new Acer Aspire V11 Touch.
The machine came with Windows 8.1 pre-installed, which I knew I didn’t want, having been a fan of Peppermint since the very early days.

So I attempted to install Peppermint Five 64-bit, and there my problems started.
I knew I had to change the boot order, so I went into BIOS (the F2 button on this machine), and found that I also had to change UEFI to Legacy in order to achieve this.
After connecting to the internet, I tested P5 in Live Mode, then went for the full install. At no point was Windows 8.1 mentioned, so heaven knows where that went - but I wasn’t too bothered by this.

The installation seemed to go smoothly, but afterwards I found that the system would not shut down, except by switching off the power button. To be specific, selecting either Shutdown or Reboot takes me to the shut down screen, but the red line “thermometer” stops after a couple of seconds and hangs for ever (I’ve left it for at least 4 hours). Switching the power off manually, or waiting for the battery to die is the only way to switch off the computer.

Then I noticed that switching on also becomes a problem. It usually takes 4 or 5 attempts at powering on/powering off to get a usable system. The most common response is a blank screen with the words “Scanning for Btfrs filesystems” - but nothing happens (again, I’ve left the computer for hours at that screen, but nothing happens). The only recourse is the Off-button.
Sometimes, though, I get past this screen in a few seconds, and I’m presented with a blue menu labelled “… Grub 2.02” (but on a previous visit I’ve definitely run sudo apt update then sudo apt upgrade then sudo apt dist-upgrade). Most times when I get to this second screen, I find that my keyboard isn’t working. So the only way out is to power-off yet again.
Then very occasionally, it all works perfectly (but won’t switch off!)

I wondered if my Peppermint 5 (64-bit) was perhaps corrupted, even though I was sure that the md5 sum tallied , so I eventually managed to install Peppermint 5 (32-bit) instead. Again I used the option to re-write everything as there was no point in leaving a duff system on my computer.

And guess what? - It hasn’t made the slightest bit of difference.
I’ve still got a system that hates booting up, and will never shut down except via the power button.

Please can somebody help?


OK one problem at a time … startup first.

Boot into Peppermint as best you can then run:

sudo apt remove btrfs-tools

now see if it boots any better.

BTW, have you tried shutting down with:

sudo shutdown -P now

and are there any obvious error messages when you do that ?

Hello Mark - great to hear from you :slight_smile: :slight_smile: :slight_smile:

sudo apt remove btrfs-tools gave me a good start-up this time (thank you).

I have tried sudo shutdown -P now before, but I tried it again with exactly the same result… it takes me to the shut-down screen with the red thermometer, but the mercury stalls after a couple of seconds and never seems to progress further.


After that last post, I tried shutting down (power-off key) and then attempted to re-start my computer. Nothing happened, except a blank screen, on the first two attempts. Both the third & fourth attempts produced the blue Grub 2.02 screen, and the 5th attempt booted properly.

Between each attempt there was the inevitable power-off key.


If it helps, I am absolutely positive that the md5 sum of this 32-bit Peppermint 5 is correct.

During a “thermometer” screen (shutdown or startup) hitting the Esc key normally shows what’s going on in the background … does doing this give any clues where shutdown or startup are falling over ?

And the next time you find yourself in Peppermint, post the output from:

sudo fdisk -l


sudo sfdisk -l

Does the REISUO trick work ? (to power off)

I can answer the second part of your question now because I’ve managed to get Peppermint working a little:

]tonyb@tonyb-Aspire-V3-111P ~ $ sudo fdisk -l
[sudo] password for tonyb: 

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00011a65

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   968620031   484308992   83  Linux
/dev/sda2       968622078   976771071     4074497    5  Extended
Partition 2 does not start on physical sector boundary.
/dev/sda5       968622080   976771071     4074496   82  Linux swap / Solaris
tonyb@tonyb-Aspire-V3-111P ~ $ sudo sfdisk -l

Disk /dev/sda: 60801 cylinders, 255 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1   *      0+  60293-  60294- 484308992   83  Linux
/dev/sda2      60293+  60801-    508-   4074497    5  Extended
/dev/sda3          0       -       0          0    0  Empty
/dev/sda4          0       -       0      

AltGr+Shift+SysRq plus R E I S U O locked up both my ketyboard and my touchpad.
The only way out was to power-off

I need you to try powering off normally, then when you see the “thermometer” screen, hit the Esc key … you should see some text scrolling past

Then tell me the last few lines of text on screen when the shutdown locks up

And do the same for a startup.

I’m trying to discover the last thing the PC does before it locks up.

Windows appears to be completely gone BTW

Sorry for slow repliy - took me 3 attempts to get Peppermint 5 loaded…

Hitting Esc after shutdown instruction produced the following:
[wait-for-state stop-/waiting
*Stopping rsync daemon rsync

  • Asking all remaining processes to terminate. . .
  • All processes ended within 1 seconds . . .
    nm-dispatcher.action: Caught signal 15. shutting down. . .
    ModemManager[663]: Could not acquire the 'org.freed

ModemManager[663]: ModemManager is shut down
*Deactivating swap. . .

  • Will now halt

Do you know how to add a kernel boot parameter ?

Start-Up screen reads:

(In black banner at top of screen):
GNU GRUB version 2.02 plus something else, can’t read from photo on my phone

(Then on blue screen):
*Peppermint GNU/Linux
Advanced options for Peppermint GNU/Linux
Memory test (memtest86+)
Memory test ((memtest86+, serial console 1152( plus something else, can’t read from photo on my phone

Lovely question, Mark The answer is No, I’ve never even heard of one

  • but I do appreciate the help!!

When booting does the PC always either boot properly or present you with the blue GRUB screen ? … and does it always boot OK if you hit the Enter key at that screen ?

Shutting down with the power button WILL cause he PC to present the GRUB menu at next bootup, because of the failed shutdown … so there may not be a startup problem at all (just trying to get a handle on this)

After making my last post I powered-off & then switched on again…

  • Power-on No. 1 produced nothing but a blank screen. After about 30 secs, I powered-off
  • Power-on No. 2 gave me the blue screen (I can now tell you it’s headed GNU GRUB version 2.02 beta 2.9 ubuntu1). I hit enter but it gave me a blank non-responsive screen, so I powered-off
  • Power-on No. 3 gave me the same blue screen but the keypad wasn’t working, so I powered-off again
  • Power-on No. 4 gave me the same blue screen, but again went to a blank unresponsive screen when I hit enter. So I powered-off.
  • Power-on No. 5 produced the same results as 2 & 4, so I powered-off.
  • Ppwer-on No. 6 worked… and here I am again

Does that help?

Sorry Tony … gotta run, but I’ll be on tomorrrow.

Once you get it to boot, can you put the contents of


onto pastebin and post the link here?

As half of this seems to be happening before GRUB is loaded I’m wondering if it’s some weird kind of UEFI BIOS issue.

Is there a “quick boot” option in the BIOS ? … have you tried disabling it ?

Hello chemicalfan

Thanks for your interest.

Please forgive my ignorance, but what’s a pastebin? And how do I use it?
I know how to enter the command you’ve suggested, but I am assuming that the reason you’ve recommended using a “pastebin” is that the output might be a bit bulky.
Beyond that, like Manuel in Fawlty Towers, “I know nothing”.

I’m now going to power-off and look to see if there’s a quick-boot option in the BIOS, as Mark has asked. I’m fairly sure there’s not but I’ll read everything very carefully and then attempt to get back into P5.


OK I’m back. It took even longer to re-boot this time - I didn’t count, but it must have been at least 25 attempts before everything worked.

I went into the BIOS and here are the settings at the moment

Quiet Boot Enabled
Network Boot Enabled
F12 Boot Menu Disabled
D2D Recovery Enabled
Wake on LAN Disabled

Nothing enabled

Boot Mode Legacy (which I’ve changed from UEFI)
Boot Priority obviously changed to enable boot from USB

I hope this helps & I’m so grateful for your assistance.

Thanks again,

…so, to answer your question, Mark: there’s no handy setting saying quick boot. Sorry :frowning: