Peppermint 7 not booting up (SOLVED)

Hi Mark,
This computer wouldn’t boot up today.
I am unsure how arrived here but I did get a screen with 3 options. I chose the middle option, something like boot in an earlier version. I did that and logged in.
Should I sort out the problem or shall I install Peppermint 8 alongside Pep7 , transfer what I want from 7 to 8 and then remove Pep 7.

Don W

If booting an earlier kernel works, can you post the output from:

dpkg -l | grep linux-image-generic

Hi Mark,

don@ldwatson ~ $ dpkg -l | grep linux-image-generic
ii linux-image-generic 4.4.0.109.114 amd64 Generic Linux kernel image
don@ldwatson ~ $

Okay it seems a few systems don’t like the kernel that has been patched against the Meltdown vulnerability.

I’m expecting there will be a flurry of kernel updates coming soon one of which might solve your booting issue … so we have 2 choices:-

a) set the older kernel as the default … then undo this when a new kernel comes through to test the new kernel

or

b) For the time being leave things as they are and keep choosing the older kernel manually at boot … then when a new kernel comes through, just boot WITHOUT selecting the old kernel.

Which would you prefer ?


One other option would be to upgrade to the HWE which will move you to the 4.13 kernel series (from the 4.4 series you’re currently on) and see how that runs on your system ?


One other question, can you post the output from:

inxi -Fz

please ?

Hi Mark,
don@ldwatson ~ $ inxi -Fz
System: Host: ldwatson Kernel: 4.4.0-109-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Seven
Machine: System: Notebook (portable) product: W24xCZ
Mobo: Notebook model: W24xCZ v: V3.0 Bios: American Megatrends v: 4.6.5 date: 11/18/2013
CPU: Dual core Intel Celeron 1037U (-MCP-) cache: 2048 KB
clock speeds: max: 1800 MHz 1: 800 MHz 2: 800 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 17.2.4
Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.4.0-109-generic
Network: Card-1: Realtek RTL8723AE PCIe Wireless Network Adapter driver: rtl8723ae
IF: wlp2s0 state: up mac:
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
IF: enp3s0f2 state: down mac:
Drives: HDD Total Size: 500.1GB (22.5% used) ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
Partition: ID-1: / size: 455G used: 102G (24%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 3.98GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 56.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 162 Uptime: 1:10 Memory: 945.8/3656.1MB Client: Shell (bash) inxi: 2.2.35
don@ldwatson ~ $

Is this ok ? The boot problem has not occurred again since that first time, I have logged on at least 3 times now without a problem.
Could we take option
b) For the time being leave things as they are and keep choosing the older kernel manually at boot … then when a new kernel comes through, just boot WITHOUT selecting the old kernel. I don’t select a kernel at boot, it just boots as normal. ??

Well if it’s booting now with the newer kernel and without you having to choose the earlier kernel (and I cab see from the output it is), I’d just put this down to a hiccup Don.

I did hear that the first patched kernel they rolled out (4.4.0-108) caused issues for a few people so they released a fixed version (4.4.0-109) … did you run any updates after initially booting the earlier kernel ? … if so, maybe you were unlucky enough to have gotten 4.4.0-108, then updating again from the earlier kernel pulled in the newer fixed 4.4.0-109 (which is what you’re booting now).

In any case if it’s all working now without you having to manually choose an earlier kernel at boot time, I can see no need for further action my mate :slight_smile:

Thanks Mark,
I will leave it for now as you suggest.

You’re welcome Don :slight_smile: