peppermint won't boot (SOLVED)

Try the paperclip at the bottom the post - below the “Keith”!
Look for the words dons-backup-instructions.odt

I have taken a screenshot of what I have, how do I place it here ?? as an attachment ??
I have Drpbox on my machine that I use as well if that is any help.

I’ve emailed you a couple of images that explain how to read attachments and how to attach files.
Let me know if it’s all clear.

Keith

Keith,
Sorry to be so much trouble but I have checked my profile and changed my email address. This change of address is partly what caused all my troubles in the first place.
I am beginning to lose interest here as any help I have found on the forums is so far out of date it is unusable (to me), I have checked Mark’s explanation on the peppermintos.com an it is unfortunately too far out of date to be any use to me.
Don W

The new email address will update overnight - I’ll try again tomorrow and let you know when sent.

Thanks Keith I can log in here without problem.
I will have a read through the method of backing up files before doing anything else, I do have a Dropbox that has a lot of stuff in it and I hope it will be ok.
I have an external HD that I could use if that is possible, it is 2Tb.
Don W

External HD is fine, and all your Dropbox files will be “in the cloud” on the Dropbox server, anyway.

If you get stuck with the backup, we can do it one step at a time.

Keith

HI Keith,
I have done so much of your suggestion but have stopped short before the line with ‘DELETE’ in it
I haven’t saved ‘Dropbox’ but I have anything else I want, does this look ok ?? and will I add the last line of your suggestion ??

Well done, Don.

Before backing up, we need to be sure what you want to back up. Three questions:

  1. Do you use Firefox web browser?
  2. When you send emails, do you have to login to an online account (e.g. hotmail, gmail, etc) or do you use Thunderbird?
  3. You told me that you want to backup just Documents, Pictures, Downloads and Skystuff. Sure that’s all?

Keith

Hi Keith,
I have set the backup running and the HD and the USB lights are blinking away. I have just received this so

  1. I use Firefox
  2. I login to gmail and hotmail, my 2 email accounts
  3. I don’t know why I have Pictures twice

https://linuxforums.org.uk/home/don/Downloads/Screen 2.png

I have attached a screenshot

No attached screenshot, Don.

Since you use Firefox, we can back up that, too, so when the backup seems to be finished don’t remove your USB stick as we need to:

  1. add Firefox
  2. unmount the sub stick before removing it - I forgot to add that command! Very important!!!

Keith

I think the backup has finished and the USB pen drive is still in place.
How do I add Firefox ?? Do I need to add Hotmail and Gmail ??
I can only attach things using the icons above this screen, nothing happens when I click on Attachments and other options
Don

None of the icons above the posting screen allow you to add attachments.
When you hover your cursor over Attachments and other options a line should appear under it, like a link. Try also clicking on the “+” sign to the left of “Attachments and other options”. If that doesn’t work, I have no idea what’s happening - sorry.

to add Firefox to your backup, enter

rsync -a  .mozilla $usb

When Firefox has backed up, enter

umount $usb

Then, to check the usb has unmounted, enter

df | grep media

If there is no output, all is well.

Keith

Thanks Keith,
I will have a go at adding Mozilla and report back

EDIT I’m back, and there is an error message although the the backup seems to have worked. Here is the screen

don@ldwatson ~ $ df|grep media
/dev/sdb1 15137856 2250912 12886944 15% /media/don/TOSHIBA
don@ldwatson ~ $ usb=/media/don/TOSHIBA/Backup
don@ldwatson ~ $ echo $usb
/media/don/TOSHIBA/Backup
don@ldwatson ~ $ du -shc Documents Pictures Downloads sky_stuff Pictures
4.6G Documents
325M Pictures
6.3G Downloads
316K sky_stuff
12G total
don@ldwatson ~ $ rsync -a -delete Documents Pictures Downloads sky_stuff Pictures $usb 2>/dev/null
don@ldwatson ~ $ rsync -a .mozilla $usb
rsync: symlink “/media/don/TOSHIBA/Backup/.mozilla/firefox/d2cwhjsq.default-1603970778923/lock” → “127.0.1.1:+9642” failed: Operation not permitted (1)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1196) [sender=3.1.2]
don@ldwatson ~ $
Is this ok ??

I have plugged in the USB and ran the last line with this result

don@ldwatson ~ $ df | grep media
don@ldwatson ~ $

so it looks as if all is well. I have the Peppermint 10 iso downloaded on my windows desktop machine, I also have Rufus on the desktop machine but am unsure how to use it , can you help ??
I had a look at using RUFUS on the peppermintos.com forum but the example is dated 2016 and uses an earlier version.

Don

Not so well, actually.
If your Toshiba is plugged in and recognised, df | grep media ought to show a line containing /media/don/TOSHIBA as the last line. Please try again.

Hi Keith,
I plugged it in and mounted it then ran the command, here it is

don@ldwatson ~ $ df | grep media
don@ldwatson ~ $ df | grep media
/dev/sdb1 15137856 14247632 890224 95% /media/don/TOSHIBA
don@ldwatson ~ $

Is this ok ??

Perfect! One usually has to wait a few seconds after plugging in a USB device to allow the system to recognise it.

I think it might be as well just to check that we really have backed up everything. So:

usb=/media/don/TOSHIBA/Backup

Then

cd $usb

Then

ls -a

This will list everything that you have backed up, and it might be just as well if you have a look inside, e.g. the Documents directory.
Let me know if it looks OK.

Keith

don@ldwatson ~ $ usb=/media/don/TOSHIBA/Backup
don@ldwatson ~ $ cd $usb
don@ldwatson /media/don/TOSHIBA/Backup $ ls -a
. … Documents Downloads .mozilla Pictures sky_stuff
don@ldwatson /media/don/TOSHIBA/Backup $

It has backed up what I asked for and when I look through the directories they look like mirrors of the files on my HD. Great work.

Well done, Don. Now:

cd ~

Then

umount $usb

Then

df | grep media

The result should be a blank line.