peppermintOS Three boot time on 64 bit

g’morning from AZ…

I’m a relative linux n00b, who’s hoping you all can help me improve my boot time on my HP Pavilion G6 laptop.

I picked it up really cheap as a returned open box item, wiped windows and am currently only running p3. Boot times on my 2005 32 bit laptop run 18-24 seconds, while boot times on this 2012 64 bit run 45 to 120 seconds… Mark has previously helped me remove blueman & mintupdate, but thos have not appreciably improved my boot times.

There is a webcam installed though I’ve never used it. When the desktop appears, something is calling up what looks like a terminal screen, which quickly fades into the lower right corner.

OK, that sounds like something is hanging during the boot process, so let’s take a look at dmesg and see if it gives us a clue.

Open a terminal and run:

dmesg > ~/dmesg.txt

You’ll then find a file called dmesg.txt in your Home directory … attach that too your next posting.

back from a short nap… here you go

Looking at your dmesg output it looks like there is a considerable time spent waiting for the eth0 interface:

[ 2.439476] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[ 11.268858] ADDRCONF(NETDEV_UP): eth0: link is not ready

As a test could you please:

  1. Disable IPV6
  2. Use the wired connection (disable wireless)
    Reboot to see if it makes any difference.
    Also run:
dmesg | grep -e eth

Ooops … I meant to come back to this :-[

Good spot SeZo.

brain now back in gear… am disabling IPV6 via this set of instructions have disabled in my mozilla products but not sure how to go about it in chromium clone SRW Iron

rebooting now…

Easier test before disabling anything, would just to be to turn off the wireless adapter, and see if boot speed improves … if it doesn’t there’s no point disabling IPv6 … not to mention you’ll probably only need to disable it in NetworkManager :wink:

my local cable provider has no ipv6 capability, so no harm in disabling… already done except for Iron…

turned off the wireless and plugged ethernet directly into laptop then got the dmseg.txt:


dmesg | grep -e eth


dmesg | grep -e eth
[    0.218923] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    0.218923] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    0.220259] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    0.270670] i2c-core: driver [aat2870] using legacy suspend method
[    0.270672] i2c-core: driver [aat2870] using legacy resume method
[    2.037615] r8169 0000:01:00.0: eth0: RTL8105e at 0xffffc9000066e000, 78:e3:b5:67:40:5e, XID 00a00000 IRQ 42
[   10.590652] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   10.825738] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[   12.535013] r8169 0000:01:00.0: eth0: link down
[   12.535122] r8169 0000:01:00.0: eth0: link down
[   12.535548] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   12.536073] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   14.172308] r8169 0000:01:00.0: eth0: link up
[   14.172715] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   24.912219] eth0: no IPv6 routers present

not sure what to make of those “initial brightness errors”

boot times still in 45-60 second range

i never intend to use ethernet with this laptop, so may i safely use

sudo ifconfig eth0 down

to turn off the search during boot?

went ahead and applied

sudo ifconfig eth0 down

boot times down to 30-40 seconds… still feels slow… ::slight_smile: my how impatient we’ve become, used to go make a pot of coffee while my IBM clone pc running Win3.11 booted back in 1992…

That command will make no difference, at boot the eth0 interface will be brought back up … if you want it to not come up at boot, the best way would be (if possible) to disable the LAN adapter in the system BIOS … if that option is unavailable, blacklist the driver for the LAN adapter.

But whatever you’ve done has improved things … what did you do ?

Hmm. I was hoping that by plugging in the cable on the Ethernet adaptor this would have reduced the waiting time.
It would be interesting to see if you could disable the wired connection in the bios (it could be a buggy adaptor or driver)
and then post the output from:

dmesg -T | grep eth


dmesg -T | grep wlan

hmmm appears to be no way to turn ethernet searching on via hp bios…

If you want instructions for blacklisting the LAN adapter’s driver, send the output from:

sudo lshw -C network

as for what i did earlier?



alias net-pf-10 off
alias ipv6 off

i also commented out a couple lines in my hosts file

# The following lines are desirable for IPv6 capable hosts
#::1     ip6-localhost ip6-loopback
#fe00::0 ip6-localnet
#ff00::0 ip6-mcastprefix
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters

and yes i might as well ask for blacklisting…

sudo lshw -C network
[sudo] password for spence: 
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 05
       serial: 78:e3:b5:67:40:5e
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:3000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
       description: Wireless interface
       product: RT5390 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: wlan0
       version: 00
       serial: e4:d5:3d:a7:7f:f2
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=3.2.0-23-generic firmware=0.34 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f0300000-f030ffff

OK, the driver for the LAN adapter is r8169 … so open a terminal and run:

sudo gedit /etc/modprobe.d/blacklist.conf

A file should open that contains a load of text … add a NEW LINE at the bottom that reads:-

blacklist r8169

SAVE the file, and reboot to test.

38 seconds last two reboots…

Is that with wireless ? … if so it’s an improvement at least.

yes that’s with the wireless on…

w/wireless off i get 34 seconds from a cold boot and 39 seconds reboot… (found a stopwatch for my phone ;~) but it still feels like a long time as there is a long black screen time w/no peppermint logo… again, can’t believe i’m complaining about 1/2 minute boot times… ::slight_smile: