PeppermintOS Three on an Acer Aspire ZG5 - Cursor Freeze


I’ve been running PP3 on my AA1 for a while now and have all the updates loaded.
I have Firefox 21.0
and Thunderbird 17.0.6
But running them together I have recently found that my session usually ends with the cursor freezing - usually in Firefox but it can be Thunderbird. I don’t recall this happening before I started doing the regular updates.

F7 doesn’t clear it,

I am a bit of a fast and furious typist, so I wondered if it is something like the speaker - where F8 turns it off, but to turn it on you need to click on the volume icon and unmute the speaker.

I wondered if you had any ideas?

When it next freezes … can you hit Ctrl+Alt+T to open a terminal and run:

free -m

and post the output (I only really need the line that starts with Swap:)

Can you try using Chromium+Thunderbird instead of firefox and see if it still does it.

Is this AA1 with SSD?
Is the disk activity LED solid green?
If so then you are suffering from disk write lag.
Try moving Firefox cache into memory:

go to: about:config
filter: cache.
browser.cache.disk.enable false
browser.cache.memory.enable true
Check status:

See if that makes any difference.

Thanks Mark and SeZo. Will wait and see at the next freeze.
SeZo - Yes - SSD - have now updated my profile

Froze in Thunderbird (no tabs), with Mozilla the only other active program (and 2 tabs open).
Disk light was solid for a few seconds after the freeze, then went out.
free -m gave swap 497 18 479
I did note the other readings if you want them

Does the mouse free up again when the green disk activity light goes out ?

No. The thing is so seized up that I was amazed I could rouse the Terminal.
Shutting down is a heck of a problem too

OK, first of all if you can open a terminal you can shut down with:

sudo shutdown -P now

Secondly … what happens if you unload the psmouse driver, then reload it:

sudo modprobe -r psmouse


sudo modprobe psmouse

does the mouse come back to life ?

BTW, I’m going to move these postings to their own topic after your next response … though the issue IS related to Peppermint 3 and your AA1, it’s not really related to the “installation” tutorial … I’ll also send you a link to the new topic by personal message (just in case you can’t find it).

Agree. I think it should be separate topic, but I wasn’t sure where to put it - I couldn’t find a separate Peppermint section

Been trying to bring the fault up for half an hour by being busy, but I think that’s the problem - just have to be patient and at some time in normal use it comes up - just when you least want it!

I started with Thunderbird, and while it was active, this time the cursor froze in Firefox with two tabs open.

Disk light solid. Cursor frozen.
Unloaded mouse driver as you suggested; reloaded and all OK

Does that give any clues?

BTW that Aljazeera tab really hammers the disk light

Can you try something for me … run this in a terminal:

syndaemon -i 1 -d

That will kill your touchpad whilst you’re typing … the touchpad will come back to life 1 second after you stop typing.

I just want to see if that makes any difference.

Be aware … this will NOT survive a reboot, and will need entering again … but if it improves things, we can make it load at bootup.

If (after running that) your mouse freezes … try hitting any key, then waiting for 1 second … does the touchpad start working again ?

Can you also confirm you made SeZo’s suggested changes in Firefox, and what your “about:cache” page now says.

Sorry about the silence - been away…

    While away, when running Thunderbird, the AA1 cursor continued to freeze in Firefox (even with the cache mod) - with the disk light on solid. Cursor reload worked OK.
    Checking about:config it is still set to:
    browser.cache. disk.enable false
    browser.cache. memory.enable true

  2. Cursor also repeatedly froze in Chromium - disk light on solid

    Thanks - that mod seems to work fine
    How do I get to load at boot up?

OK, syndaemon autostart …

Open a terminal and run:

mkdir ~/.config/autostart


gedit ~/.config/autostart/touchpad-pause.desktop

When a blank file opens in gedit … make it read:-

[Desktop Entry]
Name=Touchpad Pause
Comment=Make touchpad pause for 1 seconds whilst typing
Exec=bash -c "syndaemon -i 1 -d"

SAVE the file … and reboot (or log off/on) to test.

does the mouse become active again if you just wait for the SSD activity light to stop being on solid ? … may take a minute.


That all looked so easy, but when I tried to save it said:
Could not find the file /home/david/.config/auto…rt/touchpad-pause.desktop.
Please check that you typed the location correctly and try again.

Did a gremlin creep in somewhere?
The file seems to have that name, but even trying to save as with that name fails.
(Wish I wasn’t still so virginal!)

Sorry, my mistake, I forgot the ~/.config/autostart directory doesn’t exist by default, so needs to be created first.

I’ve fixed the above posting … so reload this page, then try it again.

I worked that out, but by the time I had created the directories and saved it, you had replied!
(Maybe I should move up one grade from ‘Linux virgin’!)

Anyway, it is running now, so I will let you know how I get on
BTW Terminal seemed to run at startup - is that how the patch works?

I take it the terminal closed again … it should.

I’f the terminal opening for a second is bugging you, let me know and we can try adding the command elsewhere.

Yes, terminal shuts down after a flash, but Oh dear, very quickly after startup the cursor froze again!

I had Thunderbird running and four tabs open in Firefox. The cursor froze in Firefox. Even when the disk light settled down and went out it still froze. The cursor keys scrolled the screen up and down but that was the only sign of life. (sorry - I didn’t try to scroll the touchpad)

I unloaded the psmouse driver, but this time it seemed to do a quick reboot - all the programs shut down. I don’t remember that last time. I then reloaded it and the mouse works ok.

Doesn’t look like the cursor freeze and jumping cursor are related does it?

Is this a new phenomena, or has the mouse always froze in Peppermint for you ?

No, my early experience of PP3 was good.

As I said in my first post, I seem to think it was only after doing the updates that freezing started to be a problem.
I have all the current updates. Is there any way of undoing them all?

The freeze above was with Firefox.

But last week, while on holiday I used Chromium almost exclusively and it froze every time :frowning:

  • even when it was the only program running and only one tab open