Phillips SHB 7000 Bluetooth Headphones. (SOLVED)

Just got these new bluetooth headphones.

Pairing and connecting on Ubuntu 14.04 and Peppermint 4.

Audio perfect on Ubuntu 14.04.

Nothing at all on Peppermint.

Any ideas…?

Jocklad

Have tried connecting the headphones by audio cable on P4 and it works fine.

Clearly a bluetooth problem.

Jocklad

Have you got pulseaudio installed ?

sudo apt-get install pulseaudio pulseaudio-utils pavucontrol

now see if they work.

ben@ben-Dell-DV051 ~ $ sudo apt-get install pulseaudio pulseaudio-utils pavucontrol
[sudo] password for ben:
Reading package lists… Done
Building dependency tree
Reading state information… Done
pulseaudio is already the newest version.
pulseaudio-utils is already the newest version.
pavucontrol is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
ben@ben-Dell-DV051 ~ $

No joy Mark.

Jocklad

make sure the pulseaudio-module-bluetooth package is installed:

sudo apt-get install pulseaudio-module-bluetooth

ben@ben-Dell-DV051 ~ $ sudo apt-get install pulseaudio-module-bluetooth
[sudo] password for ben:
Reading package lists… Done
Building dependency tree
Reading state information… Done
pulseaudio-module-bluetooth is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
ben@ben-Dell-DV051 ~ $

Mark I went into Synaptic and downloaded all the bluetooth files I could find…A lot of them.

Now when I open Bluetooth Manager I am getting an additional option which is “Audio Profile”

This gives two options: Telephony Duplex (HSP/HFP) sound is coming through but low and distorted.

                                 High Fidelity Playback (A2DP)   ......Failed to change profile to A2DP

Jocklad

See post 15 here:

Thanks Mark

I edited the file.

There are no bluetooth errors to the headset but still no audio.

Suspect it may be a VLC settings problem.

Jocklad

Go to:-
menu > Sound & Video >PulseAudio Volume Control > Out5put devices (tab)

In the

Port:

drop menu … is there anything about bluetooth ? … is it selected ?

Only two options Speakers and headphones.

Nothing about bluetooth.

Headphone is selected

My son has some bluetooth headphones … I’ll see if I can borrow them tonight and figure it out.

Thanks Mark…Much appreciated.

Jocklad

OK, to get the A2DP service to work…

Run:

sudo apt-get install pulseaudio pulseaudio-utils pavucontrol pulseaudio-module-bluetooth

Then:

sudo gedit /etc/bluetooth/audio.conf

make the [General] section read:-

# This section contains options which are not specific to any
# particular interface
[General]
Enable=

# Switch to master role for incoming connections (defaults to true)
#Master=true

SAVE the file and exit gedit.

Now with the Bluetooth Manager CLOSED … restart the bluetooth service:

sudo service bluetooth restart

Now start the bluetooth manager … right-click your (already paired) headphones and select “Audio Sink” and you should see “success” in the bottom left.

Fire up
menu > Sound & Video > PulseAudio Volume Control > Configuration (tab)

You should see your headphones listed … in the drop menu select “High Fidelity Playback (A2DP)”

Fire up a tune in VLC and leave it running

Back in
menu > Sound & Video > PulseAudio Volume Control > Playback (tab)

Set:-
VLC media player : audio stream on [YOUR HEADPHONES]

Audio from VLC (or whatever other app you set to use the headphones) should now be coming out of the headphones.

SUCCESS//////////////////////////////////////////////////////////////

Cant thank you enough Mark.

Headphones working perfectly.

Jocklad ;D ;D ;D ;D ;D

No problem … thanks for marking the topic solved :slight_smile:

Mark would the instructions you gave me here for P4 be ok for P5…?.

Jocklad

Should be the same, but I’d try nit WITHOUT the edit to

/etc/bluetooth/audio.conf

first, as this may no longer be necessary.

Please let me know how you get on, as someone else asked about bluetooth speakers.

When I try to connect Audio Sink…“Connection Failed:Stream Setup Failed”

Jocklad

Did you reme3mber to install pulseaudio-module-bluetooth

sudo apt-get install pulseaudio-module-bluetooth

and have you tried it both WITH and WITHOUT the edit to

/etc/bluetooth/audio.conf

?

Getting warnings in Terminal when I try to Gedit.

Wont let me copy/Paste.

Bear with me.

Jocklad

(Gedit:6281) Gtk warning** Calling Inhibit Failed:GDBus,error.Org.

Freedesktop.Dbus.Error,serviceunknown…

The name org.gnome.sessionmanager was not provided by any.service files.

That was the warning in Terminal. Had to type it .Terminal wont let me copy/paste

Jocklad