Physical and Logical Disk Commands show Different Readings?

I have RHEL 7.3 installed on a VM and it consists of a single disk with 3 partitions. The first partition is a filesystem partition (XFS at /dev/sda1 with 1.1GB). The second is a LVM2 volume (/dev/sda2 with 42GB) and the third is also a LVM2 volume (/dev/sda3 with 161GB).

When I ran the “pvs --units g”, it showed that both that the lvm2 partitions have 0 under the PFree column. The same happened when I ran the “pvscan” command. It showed that these 2 partitions have “0 free”

However when I ran the df command, it showed that the filesystem which was mounted on the lvm is only 13% in use. The filesystem is “dev/mapper/rhel” and is mounted on /

I am not sure what does the difference in readings mean? This is a new VM and contains only the OS and docker so there should be plenty of free space available.

I suspect that the disk space is not enough because when I edited the docker.conf file to store containers in /mnt/data/docker, the docker service failed to start and it complained that there was not enough storage to meet the minimum requirement of 2GB.