Poor display on Samsung Nc10

For some reason the display on my netbook has become poor. What I mean is when I look at my photo’s it seems pixilated and of limited colour depth. How can I check my colour depth?

Samsung NC10 1gb Ubuntu 10.04

xdpyinfo | grep "of root"



As I thought…256 colours. How do I change it?


sudo dpkg-reconfigure xserver-xorg

Then reboot.

If that doesn’t work…

Lets create an xorg.conf file, then check what’s in it…

xorg.conf is no longer present by default, but if there IS one (ie. you create one), it is recognised and acted upon

First, backup the old xorg.conf (if exists)… run this command anyway, just in case.

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

(obviously if there isn’t one the command will fail, but it won’t hurt to run it)

You are going to want to write these commands down, as you will be working WITHOUT a GUI for a while.

Open a console by hitting Ctrl+Alt+F4
(Note - At this point Ctrl+Alt+F7 will bring back your desktop, but it won’t after the next command until you restart gdm or reboot))

You should now be at a Black screen asking you to Log on:

So enter your username, and password…

You should end up at a $ prompt

Now you need to stop the X server (gnome desktop manager):

sudo service gdm stop

To create an xorg.conf.new (in you home directory):

sudo Xorg -configure

(note the capital X)

Restart gdm:

sudo service gdm restart

That should put you back at a graphical login screen… so log in, and you’re back at your desktop…

Then open the xorg.conf.new file you just created, and send me the contents:

gedit ~/xorg.conf.new

Can you also send the output from:

sudo lshw -C display

And let me know which distro/version we’re talking about.

Section “ServerLayout”
Identifier “X.org Configured”
Screen 0 “Screen0” 0 0
InputDevice “Mouse0” “CorePointer”
InputDevice “Keyboard0” “CoreKeyboard”

Section “Files”
ModulePath “/usr/lib/xorg/modules”
FontPath “/usr/share/fonts/X11/misc”
FontPath “/usr/share/fonts/X11/cyrillic”
FontPath “/usr/share/fonts/X11/100dpi/:unscaled”
FontPath “/usr/share/fonts/X11/75dpi/:unscaled”
FontPath “/usr/share/fonts/X11/Type1”
FontPath “/usr/share/fonts/X11/100dpi”
FontPath “/usr/share/fonts/X11/75dpi”
FontPath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”
FontPath “built-ins”

Section “Module”
Load “record”
Load “dri2”
Load “extmod”
Load “dri”
Load “glx”
Load “dbe”

Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”

Section “InputDevice”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/input/mice”
Option “ZAxisMapping” “4 5 6 7”

Section “Monitor”
Identifier “Monitor0”
VendorName “Monitor Vendor”
ModelName “Monitor Model”

Section “Device”
### Available Driver options are:-
### Values: : integer, : float, : “True”/“False”,
### : “String”, : “ Hz/kHz/MHz”
### [arg]: arg optional
#Option “NoAccel” # []
#Option “SWcursor” # []
#Option “ColorKey” #
#Option “CacheLines” #
#Option “Dac6Bit” # []
#Option “DRI” # []
#Option “NoDDC” # []
#Option “ShowCache” # []
#Option “XvMCSurfaces” #
#Option “PageFlip” # []
Identifier “Card0”
Driver “intel”
VendorName “Intel Corporation”
BoardName “Mobile 945GME Express Integrated Graphics Controller”
BusID “PCI:0:2:0”

Section “Screen”
Identifier “Screen0”
Device “Card0”
Monitor “Monitor0”
SubSection “Display”
Viewport 0 0
Depth 1
SubSection “Display”
Viewport 0 0
Depth 4
SubSection “Display”
Viewport 0 0
Depth 8
SubSection “Display”
Viewport 0 0
Depth 15
SubSection “Display”
Viewport 0 0
Depth 16
SubSection “Display”
Viewport 0 0
Depth 24

sudo lshw -C display

Doesn’t do anything …just hangs!

Samsung NC10, 1gb, Ubuntu 10.04.

This problem is new. The display worked great up till recently. Is there not a GUi or config utility in System to alter resolution?

are you SURE sudo lshw -C display just hangs… it can take a minute to finish ?

Anyway, xorg.conf.new looks OK to me, so lets put it in place:

sudo cp ~/xorg.conf.new /etc/X11/xorg.conf

Now REBOOT… did that fix things ?

If anything goes wrong, you can revert back to where you are now, by just deleting the /etc/X11/xorg.conf file… and rebooting.

I get this info

toonman@toonman-laptop:/$ xdpyinfo | grep “of root”
depth of root window: 24 planes

and pictures still look crap. :frowning:


sudo lshw -C display

still hanging ? … give it a minute or 2 to complete.

If so, what’s the output from


No longer hanging. Worked instantly.

description: VGA compatible controller
product: Mobile 945GME Express Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 03
width: 32 bits
clock: 33MHz
capabilities: msi pm bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:16 memory:f0000000-f007ffff ioport:1800(size=8) memory:d0000000-dfffffff(prefetchable) memory:f0300000-f033ffff
*-display:1 UNCLAIMED
description: Display controller
product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2.1
bus info: pci@0000:00:02.1
version: 03
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=0
resources: memory:f0080000-f00fffff

are the i915 or intel drivers mentioned in “System> Administration >Additional Drivers” ?

if so, try disabling them, then re-enabling them.


sudo apt-get install -reinstall xserver-xorg-video-intel

has there been an update to your graphics driver recently ?

have you checked the graphics are OK with a LiveUSB ?

There is no such thing as …“System> Administration >Additional Drivers” in 10.04 There is Hardware drivers and it shows that no proprietary drivers are installed.

did you try the reinstall of the intel drivers ?

No Mark I have not tries to reinstall any drivers, did you tell me how to? :-[

The only updates recently have been the standard Ubuntu ones. I never look at them just give permission to install.

This is what I got when I pasted your command line to reinstall.

toonman@toonman-laptop:/$ sudo apt-get install -reinstall xserver-xorg-video-intel
[sudo] password for toonman:
E: Command line option ‘r’ [from -reinstall] is not known.

My apologies, missed an -

sudo apt-get install --reinstall xserver-xorg-video-intel

It made some updates. I have restarted and everything seems fine now. :slight_smile:

Thanks very much.

Glad to hear it… wonder what happened there then.

Strange isn’t it. The only real glitch I’ve had in 10.04 however…it’s probably me, I will have done something inadvertently. :-[

Thanks again