Problem connecting Andriod WiFi and Netbook

I am having a problem with connecting my Netbook to my Sony Experia arc S mobile using its WiFi mode. It worked OK with Ubunbtu 10.04 but even though it can be see by the the phone and the passwords are identical it will not connect.

In my phone I go to settings-WiFi and Tethering-portable WiFi hotspot, then tick it. My Samsung NC10 Netbook can see the WiFi connection, both passwords are identical but when I click to connect the icon just whirls searching for connection and does not connect. The signal strength is 100% and the netbook has no problem connecting to any other automatic or manual connections. I have even tried deleting the connection and re-installing but the same thing happens. Any ideas?

In my phone I go to settings-WiFi and Tethering-portable WiFi hotspot

As I said, I’m not a smartphone user, but that looks like a procedure for connecting the phone to a WiFi Hotspot (like in an airport etc.) … are you for some reason using your netbook as a hotspot (say with Internet Connection Sharing) ?

Or am I missing something ???

Mark, just thought you’d be interested - A portable WiFi hotspot on your phone allows your PC to use your phones 3G connection to access the internet.

@ Toonman - What OS is your netbook running? Do you have another wireless capable computer to try and connect to the phone?

Oops … my mistake, I should have noticed the “portable” and maybe “tethering” aspects of that sentence ::slight_smile:

IIRC, he’s now using PeppermintOS (Two), but was previously using Ubuntu 10.04 …and it was working under Ubuntu.

Which is kinda odd, because the networkmanger etc. are the same in Peppermint as Ubuntu (at least 11.04)

@Toonman - In addition to my comment above, as well as trying a different machine to connect to the phone do you have a second smart phone you could to try and connect your netbook to. Just trying to narrow down which device is causing the problem.

If not let me know and I’ll try to work around it.

[EDIT]

Just thought I’d add, on my phone the default settings for Portable Wi-Fi Hotspot only allows 2 connections. Is there anything else connected to the phone? It’s a long shot but you never know.

My phone also allows you to set ‘Allowed user only’. When I do this a notification appears on my phone saying a connection is requesting access. Until I allow it my laptop won’t connect. This sounds similar to what you are seeing. Could you check your phone and the Wifi Hotspot settings.

It appears others have had the same issue with tethering in Ubuntu 11.04 (PeppermintOS 2 is based on 11.04) where it worked perfectly in earlier releases … see here:

It would appear that some people have fixed the issue by moving to kernel 3.1.4

If you want to try kernel 3.1.4 …

cd ~

then

mkdir kernel-3.1.4

then

cd ~/kernel-3.1.4

then

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1.4-oneiric/linux-headers-3.1.4-030104_3.1.4-030104.201111281851_all.deb

Next you need to use wget to download 2 more files, BUT they are architecture dependant … so ONLY get EITHER the 32bit OR 64bit version, depending on whether you have 32bit PepperiintOS or 64bit Peppermint installed.

For 32bit PeppermintOS

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1.4-oneiric/linux-headers-3.1.4-030104-generic_3.1.4-030104.201111281851_i386.deb

then

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1.4-oneiric/linux-image-3.1.4-030104-generic_3.1.4-030104.201111281851_i386.deb

OR

For 64bit PeppermintOS

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1.4-oneiric/linux-headers-3.1.4-030104-generic_3.1.4-030104.201111281851_amd64.deb

then

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1.4-oneiric/linux-image-3.1.4-030104-generic_3.1.4-030104.201111281851_amd64.deb

Now to install the kernel, just run:

sudo dpkg -i *.deb

Be SURE to wait till that last command returns you to an $ prompt (it may take a short while, it says “done” twice, but it isn’t finished till it dumps you at a normal $ prompt) … then reboot … once rebooted, run:

uname -r

if
3.1.4-030104-generic
is returned … you are now using kernel 3.1.4 … so try tethering now.


If you are unsure whether you are CURRENTLY using 32bit or 64bit Peppermint … send the output from:

uname -srp

And just so you feel more confident … you are NOT uninstalling the old kernel, so if anything goes wrong, there’s nothing stopping you from booting to the older kernel from the GRUB menu.

And I’ve just tested these instructions on my AA1 running 32bit PeppermintOS (Two), and it seems quite happy with kernel 3.1.4 :slight_smile:


As usual … any questions … ask them first :wink:

Thanks everyone.

I will get back to you with the results later.

Followed Marks instructions. BINGO!

All works fine.

Thank you.